summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-08-17 07:49:34 +0200
committerMathias Kresin <dev@kresin.me>2016-08-17 07:49:34 +0200
commit483fd5f6ad7d87a8f24674c746c609e8b36b426f (patch)
tree5a334197e5a70aa9deb256d00b1b0a5fa2a304ca /target
parent28110727f1d513a6c4c13aa87ecb606aa5d306eb (diff)
downloadmaster-31e0f0ae-483fd5f6ad7d87a8f24674c746c609e8b36b426f.tar.gz
master-31e0f0ae-483fd5f6ad7d87a8f24674c746c609e8b36b426f.tar.bz2
master-31e0f0ae-483fd5f6ad7d87a8f24674c746c609e8b36b426f.zip
ramips: add build recipe for senao header
Add it to the Makefile to allow a board which will be supported soon to use the recipe as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 7b53a2f744..2af6d68547 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -78,6 +78,11 @@ define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef
+define Build/senao-header
+ $(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
+ mv $@.new $@
+endef
+
#
# The real magic happens inside these templates
#