summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-07-02 07:42:44 +0000
committerJohn Crispin <john@openwrt.org>2014-07-02 07:42:44 +0000
commit3d81a4ef822d9261d89338b6090558b0a370c853 (patch)
tree001cfb8fceef112efaf1b087c059f5ddb3125ee6 /target
parentc749b310ed2fbd41d99039184fdfc7a64f309c4c (diff)
downloadmaster-31e0f0ae-3d81a4ef822d9261d89338b6090558b0a370c853.tar.gz
master-31e0f0ae-3d81a4ef822d9261d89338b6090558b0a370c853.tar.bz2
master-31e0f0ae-3d81a4ef822d9261d89338b6090558b0a370c853.zip
ralink: add Wansview NCS601W IP Camera
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 41453
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rw-r--r--target/linux/ramips/dts/NCS601W.dts110
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt305x/profiles/wansview.mk18
6 files changed, 136 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index d8bb095e45..b56fb63423 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -91,6 +91,7 @@ case "$FIRMWARE" in
mpr-a1 | \
mpr-a2 | \
pwh2004 | \
+ ncs601w | \
nbg-419n | \
nw718 | \
omni-emb | \
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 7612857844..4eef735d93 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -43,6 +43,7 @@ ramips_setup_interfaces()
all5003 | \
broadway | \
dcs-930| \
+ ncs601w | \
wnce2001)
ucidef_add_switch "switch0" "1" "0"
ucidef_set_interface_lan "eth0"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 697599341b..ca339b354c 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -301,6 +301,9 @@ ramips_board_detect() {
*"WRTNODE")
name="wrtnode"
;;
+ *"Wansview NCS601W")
+ name="ncs601w"
+ ;;
*"Sercomm NA930")
name="na930"
;;
diff --git a/target/linux/ramips/dts/NCS601W.dts b/target/linux/ramips/dts/NCS601W.dts
new file mode 100644
index 0000000000..dcf0e727a9
--- /dev/null
+++ b/target/linux/ramips/dts/NCS601W.dts
@@ -0,0 +1,110 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "NCS601W", "ralink,rt5350-soc";
+ model = "Wansview NCS601W";
+
+ palmbus@10000000 {
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "s25fl064k";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "s25fl064k";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ };
+
+ esw@10110000 {
+ ralink,portmap = <0x2f>;
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+/* gpio-leds {
+ compatible = "gpio-leds";
+ system {
+ label = "mpr-a1:blue:system";
+ gpios = <&gpio0 20 1>;
+ };
+ power {
+ label = "mpr-a1:red:power";
+ gpios = <&gpio0 17 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ wps {
+ label = "reset";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x198>;
+ };
+ };
+
+ gpio_export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ usb {
+ gpio-export,name = "usb";
+ gpio-export,output = <1>;
+ gpios = <&gpio0 7 0>;
+ };
+ root_hub {
+ gpio-export,name = "root_hub";
+ gpio-export,output = <1>;
+ gpios = <&gpio0 12 0>;
+ };
+ }; */
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index ec3ef75de3..5b23035b4e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -449,6 +449,8 @@ Image/Build/Profile/NBG-419N=$(call BuildFirmware/Default4M/$(1),$(1),nbg-419n,N
Image/Build/Profile/MZKW300NH2=$(call BuildFirmware/Edimax/$(1),$(1),mzk-w300nh2,MZK-W300NH2,$(mzkw300nh2_mtd_size),CSYS,RN52,0x50000,0xc0000)
+Image/Build/Profile/NCS601W=$(call BuildFirmware/Default8M/$(1),$(1),ncs601W,NCS601W)
+
nw718_mtd_size=3801088
Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw718m,NW718,$(nw718_mtd_size),ARA1B4NCRNW718;1,factory)
@@ -596,6 +598,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/MPRA2,$(1))
$(call Image/Build/Profile/MZKW300NH2,$(1))
$(call Image/Build/Profile/NBG-419N,$(1))
+ $(call Image/Build/Profile/NCS601W,$(1))
$(call Image/Build/Profile/NW718,$(1))
$(call Image/Build/Profile/OMNI-EMB,$(1))
$(call Image/Build/Profile/PSR-680W,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/wansview.mk b/target/linux/ramips/rt305x/profiles/wansview.mk
new file mode 100644
index 0000000000..064cc0613d
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/wansview.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NCS601W
+ NAME:=Wansview NCS601W
+ PACKAGES:=kmod-video-core kmod-video-uvc \
+ kmod-usb-core kmod-usb-ohci
+endef
+
+define Profile/NCS601W/Description
+ Package set for Wansview NCS601W board
+endef
+
+$(eval $(call Profile,NCS601W))