summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-03 09:43:31 +0200
committerMathias Kresin <dev@kresin.me>2016-09-03 09:43:31 +0200
commit0f3600cceef2cb47fda2a87efc24ab7eac84709f (patch)
tree659d68a6e84691130b3803e146ceb27dfaca8e2d /target
parent74da44cfc2a6d8d21a9eca0ae5dd1ef4069c1cef (diff)
downloadmaster-31e0f0ae-0f3600cceef2cb47fda2a87efc24ab7eac84709f.tar.gz
master-31e0f0ae-0f3600cceef2cb47fda2a87efc24ab7eac84709f.tar.bz2
master-31e0f0ae-0f3600cceef2cb47fda2a87efc24ab7eac84709f.zip
ramips: move seama build recipe to Makefile
The identical build step is defined twice. Move it to the parent Makefile to use only one version. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile9
-rw-r--r--target/linux/ramips/image/mt7620.mk9
-rw-r--r--target/linux/ramips/image/mt7621.mk9
3 files changed, 9 insertions, 18 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2af6d68547..39da5e09c0 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -83,6 +83,15 @@ define Build/senao-header
mv $@.new $@
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(call Build/seama,-s $@.seama $(1))
+endef
+
#
# The real magic happens inside these templates
#
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 9ccd3d9833..003fc70210 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -37,15 +37,6 @@ define Build/elecom-header
$(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
- mv $@.seama $@
-endef
-
-define Build/seama-seal
- $(call Build/seama,-s $@.seama $(1))
-endef
-
define Device/ArcherC20i
DTS := ArcherC20i
KERNEL := $(KERNEL_DTB)
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 47778c4636..769b86b81b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,15 +2,6 @@
# MT7621 Profiles
#
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
- mv $@.seama $@
-endef
-
-define Build/seama-seal
- $(call Build/seama,-s $@.seama $(1))
-endef
-
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:6' > $(1).compat; \