summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-10 17:41:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-10 17:41:52 +0000
commitffdc6ec8eddec4f2fcf524104abb42e4001eab4b (patch)
tree22200550b151e83aa9cc4d12b84cadb73ee43256 /target
parentc07fdecea89fed5716bd487fcbc3786925a57326 (diff)
downloadmaster-31e0f0ae-ffdc6ec8eddec4f2fcf524104abb42e4001eab4b.tar.gz
master-31e0f0ae-ffdc6ec8eddec4f2fcf524104abb42e4001eab4b.tar.bz2
master-31e0f0ae-ffdc6ec8eddec4f2fcf524104abb42e4001eab4b.zip
ar71xx: create smaller sysupgrade files for the TP-Link boards
SVN-Revision: 20121
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b16ee5dac2..2f990da080 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -270,7 +270,12 @@ define Image/Build/TPLINK
-B $(4) -N OpenWrt -V $(REVISION)\
-k $(KDIR)/vmlinux-$(2).bin.gz \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -o $(call imgname,$(1),$(2))-universal.bin
+ -o $(call imgname,$(1),$(2))-factory.bin
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -B $(4) -N OpenWrt -V $(REVISION) -s \
+ -k $(KDIR)/vmlinux-$(2).bin.gz \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(call imgname,$(1),$(2))-sysupgrade.bin
endef
define Image/Build/TPLINK/initramfs