summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-08 14:28:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-08 14:28:49 +0000
commitf80c6e9e292877d4c94a27fd46f73390b30d781c (patch)
treeda863ccd99b06f607a9bc321a9c84baa181f1752 /target
parent18b1a6dd6efbaacb5a46665a930f104aed4483de (diff)
downloadmaster-31e0f0ae-f80c6e9e292877d4c94a27fd46f73390b30d781c.tar.gz
master-31e0f0ae-f80c6e9e292877d4c94a27fd46f73390b30d781c.tar.bz2
master-31e0f0ae-f80c6e9e292877d4c94a27fd46f73390b30d781c.zip
use target nm instead of host nm for ar7 images (#936)
SVN-Revision: 5473
Diffstat (limited to 'target')
-rw-r--r--target/image/ar7/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/image/ar7/Makefile b/target/image/ar7/Makefile
index d2af2d9a81..bcdef970cf 100644
--- a/target/image/ar7/Makefile
+++ b/target/image/ar7/Makefile
@@ -57,7 +57,7 @@ endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $(KDIR)/vmlinux.lzma -o $(KDIR)/zimage.o
- $(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=0x$${shell nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} -T $(PKG_BUILD_DIR)/ld.script \
+ $(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} -T $(PKG_BUILD_DIR)/ld.script \
$(PKG_BUILD_DIR)/loader.o \
$(PKG_BUILD_DIR)/LzmaDecode.o \
$(KDIR)/zimage.o \