summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-08-24 10:11:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-08-24 10:11:45 +0000
commitf7eb3d94b91b87e1990d953e326d7f6afe7d67d2 (patch)
tree425a2d20e1d8e70a028412a5cab9673d84d78773 /target
parent043edd80744308e9d1b8c0bf2213bd7a71770cb1 (diff)
downloadmaster-31e0f0ae-f7eb3d94b91b87e1990d953e326d7f6afe7d67d2.tar.gz
master-31e0f0ae-f7eb3d94b91b87e1990d953e326d7f6afe7d67d2.tar.bz2
master-31e0f0ae-f7eb3d94b91b87e1990d953e326d7f6afe7d67d2.zip
ar71xx: allow to override kernel size in the CameoHornet profile
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37833
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f5650c9afe..7ab6b03b8f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -358,7 +358,7 @@ define Image/Build/CameoHornet
[ -n "$$$$r" ] && dashr="-$$$$r" || dashr=; \
[ -z "$$$$r" ] && r="DEF"; \
mkcameofw -M HORNET -R "$$$$r" -S $(7) -V $(8) -c \
- -K 0xe0000 -I $(10) \
+ -K $(10) -I $(11) \
-k "$(call sysupname,$(1),$(2))" \
-o $(call imgname,$(1),$(2))-factory$$$$dashr.bin; \
done; \
@@ -382,7 +382,7 @@ define Image/Build/Cameo7240/initramfs
endef
define Image/Build/Cameo933x
- $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout),65536,2686976,$(4),$(5),$(6),3735552)
+ $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout),65536,2686976,$(4),$(5),$(6),0xe0000,3735552)
endef
define Image/Build/Cameo933x/initramfs