summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-03-28 20:42:37 +0000
committerJonas Gorski <jogo@openwrt.org>2012-03-28 20:42:37 +0000
commitf7df1eafc4e561fb45ff742f087915195740f22b (patch)
tree98f006ab2e9db87d7f7b5951e95dffb915b5c37a /target
parentc7ae2fccb687ef1cae161910ca103a8bac57c9b2 (diff)
downloadmaster-31e0f0ae-f7df1eafc4e561fb45ff742f087915195740f22b.tar.gz
master-31e0f0ae-f7df1eafc4e561fb45ff742f087915195740f22b.tar.bz2
master-31e0f0ae-f7df1eafc4e561fb45ff742f087915195740f22b.zip
bcm63xx: enable bcm6368 for linux 3.3 and build images
Only build bcm6368 images when building for linux 3.3. SVN-Revision: 31133
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/config-3.34
-rw-r--r--target/linux/brcm63xx/image/Makefile5
2 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/config-3.3 b/target/linux/brcm63xx/config-3.3
index 3d1b01be97..19137ffbdd 100644
--- a/target/linux/brcm63xx/config-3.3
+++ b/target/linux/brcm63xx/config-3.3
@@ -16,7 +16,7 @@ CONFIG_BCM63XX_CPU_6338=y
CONFIG_BCM63XX_CPU_6345=y
CONFIG_BCM63XX_CPU_6348=y
CONFIG_BCM63XX_CPU_6358=y
-# CONFIG_BCM63XX_CPU_6368 is not set
+CONFIG_BCM63XX_CPU_6368=y
CONFIG_BCM63XX_ENET=y
CONFIG_BCM63XX_PHY=y
CONFIG_BCM63XX_WDT=y
@@ -82,7 +82,7 @@ CONFIG_HAVE_OPROFILE=y
CONFIG_HAVE_PERF_EVENTS=y
CONFIG_HW_HAS_PCI=y
CONFIG_HW_RANDOM=y
-# CONFIG_HW_RANDOM_BCM63XX is not set
+CONFIG_HW_RANDOM_BCM63XX=y
CONFIG_HZ=250
# CONFIG_HZ_100 is not set
CONFIG_HZ_250=y
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 09364c41d4..ebe09eba09 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -158,6 +158,11 @@ define Image/Build
$(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
$(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+ $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
+ $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
+ endif
+
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
# BT Voyager V210_ROI, V210_WB