summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-19 17:52:08 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-19 17:52:08 +0000
commite7f59b9326d17e4fb8ac51f619bf169d102f0870 (patch)
tree3a51494338d1d697e3dc0c276d06d4c15e01166f /target
parent3489515a7eb66c6489c3aeefda06e132532f5811 (diff)
downloadmaster-31e0f0ae-e7f59b9326d17e4fb8ac51f619bf169d102f0870.tar.gz
master-31e0f0ae-e7f59b9326d17e4fb8ac51f619bf169d102f0870.tar.bz2
master-31e0f0ae-e7f59b9326d17e4fb8ac51f619bf169d102f0870.zip
ramips: build sysupgrade image for the V11ST-FE board
SVN-Revision: 30648
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 588dfa55fb..770b12e62e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -353,6 +353,11 @@ define Image/Build/Profile/RTN15
$(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
endef
+mtdlayout_v11stfe=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1280k(kernel),2112k(rootfs),3392k@0x50000(firmware)
+define Image/Build/Profile/V11STFE
+ $(call BuildFirmware/Generic,$(1),v11st-fe,board=V11ST-FE,mtdlayout_v11stfe,1310720,2162688)
+endef
+
mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
define Image/Build/Profile/WLITX4AG300N
$(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
@@ -362,6 +367,7 @@ ifeq ($(CONFIG_RALINK_RT288X),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/F5D8235V1,$(1))
$(call Image/Build/Profile/RTN15,$(1))
+ $(call Image/Build/Profile/V11STFE,$(1))
$(call Image/Build/Profile/WLITX4AG300N,$(1))
endef
endif