summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-28 01:20:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-28 01:20:49 +0000
commitde194ac4c28207d15a858b89604369aa027ebbd8 (patch)
treed2623e71cdaf9154f04b0856d80e19c6b8b28335 /target
parent1f08de0a7e31ae97537b5db55a32016883ec09ad (diff)
downloadmaster-31e0f0ae-de194ac4c28207d15a858b89604369aa027ebbd8.tar.gz
master-31e0f0ae-de194ac4c28207d15a858b89604369aa027ebbd8.tar.bz2
master-31e0f0ae-de194ac4c28207d15a858b89604369aa027ebbd8.zip
kernel: the usb pci quirks removal patch was a bit overzealous, leave in some functions referenced from other modules
SVN-Revision: 25785
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch28
-rw-r--r--target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch28
2 files changed, 34 insertions, 22 deletions
diff --git a/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
index 49954bb567..e1efe9cc39 100644
--- a/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
@@ -1,12 +1,18 @@
---- a/drivers/usb/host/Makefile
-+++ b/drivers/usb/host/Makefile
-@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+
+--- a/drivers/usb/host/pci-quirks.c
++++ b/drivers/usb/host/pci-quirks.c
+@@ -134,6 +134,8 @@ reset_needed:
+ }
+ EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
- obj-$(CONFIG_USB_WHCI_HCD) += whci/
-
-+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
- obj-$(CONFIG_PCI) += pci-quirks.o
-+endif
-
- obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
- obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
++#ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
++
+ static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
+ {
+ u16 cmd;
+@@ -478,3 +480,5 @@ static void __devinit quirk_usb_early_ha
+ quirk_usb_handoff_xhci(pdev);
+ }
+ DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
++
++#endif
diff --git a/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
index 49954bb567..e1efe9cc39 100644
--- a/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
@@ -1,12 +1,18 @@
---- a/drivers/usb/host/Makefile
-+++ b/drivers/usb/host/Makefile
-@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+
+--- a/drivers/usb/host/pci-quirks.c
++++ b/drivers/usb/host/pci-quirks.c
+@@ -134,6 +134,8 @@ reset_needed:
+ }
+ EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
- obj-$(CONFIG_USB_WHCI_HCD) += whci/
-
-+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
- obj-$(CONFIG_PCI) += pci-quirks.o
-+endif
-
- obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
- obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
++#ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
++
+ static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
+ {
+ u16 cmd;
+@@ -478,3 +480,5 @@ static void __devinit quirk_usb_early_ha
+ quirk_usb_handoff_xhci(pdev);
+ }
+ DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
++
++#endif