summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-23 09:09:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-23 09:09:16 +0000
commitd923618f397b6d4625a552c5db488c55b202879d (patch)
tree695a1e29d0139c7f0db49fc83fc9caedbf308426 /target
parent7962a35f6233f8fc6a20c61ca0a99b6342c2c03a (diff)
downloadmaster-31e0f0ae-d923618f397b6d4625a552c5db488c55b202879d.tar.gz
master-31e0f0ae-d923618f397b6d4625a552c5db488c55b202879d.tar.bz2
master-31e0f0ae-d923618f397b6d4625a552c5db488c55b202879d.zip
generate LZMA compressed uImage as well
SVN-Revision: 11249
Diffstat (limited to 'target')
-rw-r--r--target/linux/avr32/image/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index cbaf07dfb3..2cef2653bf 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -22,6 +22,14 @@ endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
+ -e 0x90000000 \
+ -n 'OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage-lzma
+
+ cp $(KDIR)/uImage-lzma $(BIN_DIR)/openwrt-$(BOARD)-uImage-lzma
endef
define Image/Build