summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-04-04 08:43:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-04-04 08:43:07 +0000
commitd5a7e2f5c1d63e81771617940ac6f92b31a05583 (patch)
tree07f7373ae8a5ae6b4ee515e7beb88e72a04f53bd /target
parent490032400b7233fad90840ed83ae8df3566f0b93 (diff)
downloadmaster-31e0f0ae-d5a7e2f5c1d63e81771617940ac6f92b31a05583.tar.gz
master-31e0f0ae-d5a7e2f5c1d63e81771617940ac6f92b31a05583.tar.bz2
master-31e0f0ae-d5a7e2f5c1d63e81771617940ac6f92b31a05583.zip
ramips: initial board support for MOFI3500-3GN
This patch adds initial board support for the MoFi Network MOFI3500-3GN (Ralink RT3052F SoC, 8MB flash, 32MB ram, wireless N, USB-OTG). This router is basically the NA version of the HW550-3G. Signed-off-by: Layne Edwards <ledwards76@gmail.com> SVN-Revision: 26466
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig6
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-mofi3500-3gn.c141
-rw-r--r--target/linux/ramips/image/Makefile4
-rw-r--r--target/linux/ramips/rt305x/config-2.6.371
9 files changed, 161 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 051c884de1..99f497e3f5 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -45,6 +45,9 @@ get_status_led() {
hw550-3g)
status_led="hw550-3g:green:status"
;;
+ mofi3500-3gn)
+ status_led="mofi3500-3gn:green:status"
+ ;;
esac
}
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 49e5bc7741..8c64d6a8e7 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -25,6 +25,9 @@ ramips_board_name() {
*"Aztech HW550-3G")
name="hw550-3g"
;;
+ *"MoFi Network MOFI3500-3GN")
+ name="mofi3500-3gn"
+ ;;
*)
name="generic"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index bf8a9865be..c541ea0a13 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -14,7 +14,7 @@ platform_check_image() {
[ "$ARGC" -gt 1 ] && return 1
case "$board" in
- dir-300-b1 | fonera20n | v22rw-2x2 | whr-g300n | hw550-3g)
+ dir-300-b1 | fonera20n | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
[ "$magic" != "2705" ] && {
echo "Invalid image type."
return 1
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 81ee028393..c3f8ed3faf 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -28,4 +28,5 @@ enum ramips_mach_type {
RAMIPS_MACH_WHR_G300N, /* Buffalo WHR-G300N */
RAMIPS_MACH_FONERA20N, /* La Fonera 2.0N */
RAMIPS_MACH_HW550_3G, /* Aztech HW550-3G */
+ RAMIPS_MACH_MOFI3500_3GN, /* MoFi Network MOFI3500-3GN */
};
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index 354235ea25..9b34a3ef08 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -50,6 +50,12 @@ config RT305X_MACH_HW550_3G
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_MOFI3500_3GN
+ bool "MoFi Network MOFI3500-3GN support"
+ default y
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
endmenu
endif
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 9b912014f9..6e5dd08d45 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -19,3 +19,4 @@ obj-$(CONFIG_RT305X_MACH_WHR_G300N) += mach-whr-g300n.o
obj-$(CONFIG_RT305X_MACH_FONERA20N) += mach-fonera20n.o
obj-$(CONFIG_RT305X_MACH_PWH2004) += mach-pwh2004.o
obj-$(CONFIG_RT305X_MACH_HW550_3G) += mach-hw550-3g.o
+obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-mofi3500-3gn.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-mofi3500-3gn.c
new file mode 100644
index 0000000000..8e34ad0bc3
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-mofi3500-3gn.c
@@ -0,0 +1,141 @@
+/*
+ * MoFi Network MOFI3500-3GN board support
+ *
+ * Copyright (C) 2011 Layne Edwards <ledwards76@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define MOFI3500_3GN_GPIO_LED_USB 8
+#define MOFI3500_3GN_GPIO_LED_3G 11
+#define MOFI3500_3GN_GPIO_LED_STATUS 12
+#define MOFI3500_3GN_GPIO_LED_WPS 14
+
+#define MOFI3500_3GN_GPIO_BUTTON_RESET 10
+#define MOFI3500_3GN_GPIO_BUTTON_CONNECT 7
+#define MOFI3500_3GN_GPIO_BUTTON_WPS 0
+
+#define MOFI3500_3GN_BUTTONS_POLL_INTERVAL 20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition mofi3500_3gn_partitions[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x030000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "config",
+ .offset = 0x030000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "factory",
+ .offset = 0x040000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "kernel",
+ .offset = 0x050000,
+ .size = 0x0d0000,
+ }, {
+ .name = "rootfs",
+ .offset = 0x120000,
+ .size = 0x6e0000,
+ }, {
+ .name = "firmware",
+ .offset = 0x050000,
+ .size = 0x7b0000,
+ }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data mofi3500_3gn_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+ .nr_parts = ARRAY_SIZE(mofi3500_3gn_partitions),
+ .parts = mofi3500_3gn_partitions,
+#endif
+};
+
+static struct gpio_led mofi3500_3gn_leds_gpio[] __initdata = {
+ {
+ .name = "mofi3500-3gn:green:usb",
+ .gpio = MOFI3500_3GN_GPIO_LED_USB,
+ .active_low = 1,
+ }, {
+ .name = "mofi3500-3gn:green:3g",
+ .gpio = MOFI3500_3GN_GPIO_LED_3G,
+ .active_low = 1,
+ }, {
+ .name = "mofi3500-3gn:green:status",
+ .gpio = MOFI3500_3GN_GPIO_LED_STATUS,
+ .active_low = 1,
+ }, {
+ .name = "mofi3500-3gn:green:wps",
+ .gpio = MOFI3500_3GN_GPIO_LED_WPS,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_button mofi3500_3gn_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .threshold = 3,
+ .gpio = MOFI3500_3GN_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "connect",
+ .type = EV_KEY,
+ .code = KEY_CONNECT,
+ .threshold = 3,
+ .gpio = MOFI3500_3GN_GPIO_BUTTON_CONNECT,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .threshold = 3,
+ .gpio = MOFI3500_3GN_GPIO_BUTTON_WPS,
+ .active_low = 1,
+ }
+};
+
+#define MOFI3500_3GN_GPIO_MODE \
+ ((RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT) | \
+ RT305X_GPIO_MODE_MDIO)
+
+static void __init mofi3500_3gn_init(void)
+{
+ rt305x_gpio_init(MOFI3500_3GN_GPIO_MODE);
+
+ rt305x_register_flash(0, &mofi3500_3gn_flash_data);
+ rt305x_register_ethernet();
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(mofi3500_3gn_leds_gpio),
+ mofi3500_3gn_leds_gpio);
+ ramips_register_gpio_buttons(-1, MOFI3500_3GN_BUTTONS_POLL_INTERVAL,
+ ARRAY_SIZE(mofi3500_3gn_gpio_buttons),
+ mofi3500_3gn_gpio_buttons);
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_MOFI3500_3GN, "MOFI3500-3GN", "MoFi Network MOFI3500-3GN",
+ mofi3500_3gn_init);
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 361588efcf..224e4111ef 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -104,6 +104,9 @@ define Image/Build/Profile/HW5503G
$(call Image/Build/Template/GENERIC_8M,$(1),hw550-3g,HW550-3G)
endef
+define Image/Build/Profile/MOFI35003GN
+ $(call Image/Build/Template/GENERIC_8M,$(1),mofi3500-3gn,MOFI3500-3GN)
+endef
mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(Bootloader)ro,64k(Config),64k(Factory),832k(Kernel),2944k(rootfs),3776k@0x50000(firmware)
mtd_wcr150gn_kernel_part_size=851968
@@ -139,6 +142,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/F5D8235V2,$(1))
$(call Image/Build/Profile/HW5503G,$(1))
+ $(call Image/Build/Profile/MOFI35003GN,$(1))
endef
endif
diff --git a/target/linux/ramips/rt305x/config-2.6.37 b/target/linux/ramips/rt305x/config-2.6.37
index 500adb9a66..96377124c0 100644
--- a/target/linux/ramips/rt305x/config-2.6.37
+++ b/target/linux/ramips/rt305x/config-2.6.37
@@ -95,6 +95,7 @@ CONFIG_RT305X_MACH_DIR_300_REVB=y
CONFIG_RT305X_MACH_F5D8235_V2=y
CONFIG_RT305X_MACH_FONERA20N=y
CONFIG_RT305X_MACH_HW550_3G=y
+CONFIG_RT305X_MACH_MOFI3500_3GN=y
CONFIG_RT305X_MACH_PWH2004=y
CONFIG_RT305X_MACH_V22RW_2X2=y
CONFIG_RT305X_MACH_WCR150GN=y