summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-13 18:06:38 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-13 18:06:38 +0000
commitd4c8b230b54d52abeeff794e85b59009fc1445fc (patch)
tree6ecf89f6685f18a59428e8d7f99bc91261244fdb /target
parent9aff33e13f46094938feb4acd4b5a3ebe34246e7 (diff)
downloadmaster-31e0f0ae-d4c8b230b54d52abeeff794e85b59009fc1445fc.tar.gz
master-31e0f0ae-d4c8b230b54d52abeeff794e85b59009fc1445fc.tar.bz2
master-31e0f0ae-d4c8b230b54d52abeeff794e85b59009fc1445fc.zip
Refresh patches with quilt, thanks Gabor !
SVN-Revision: 7617
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120-2.6/patches/001-adm5120.patch35
-rw-r--r--target/linux/adm5120-2.6/patches/002-adm5120_flash.patch18
-rw-r--r--target/linux/adm5120-2.6/patches/003-adm5120_switch.patch20
-rw-r--r--target/linux/adm5120-2.6/patches/004-adm5120_uart.patch67
-rw-r--r--target/linux/adm5120-2.6/patches/005-adm5120_usb.patch45
-rw-r--r--target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch20
-rw-r--r--target/linux/adm5120-2.6/patches/007-adm5120_pci.patch15
-rw-r--r--target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch18
-rw-r--r--target/linux/adm5120-2.6/patches/140-cmdline_hack.patch13
-rw-r--r--target/linux/adm5120-2.6/patches/500-Nand.patch24
10 files changed, 148 insertions, 127 deletions
diff --git a/target/linux/adm5120-2.6/patches/001-adm5120.patch b/target/linux/adm5120-2.6/patches/001-adm5120.patch
index 70129373f8..8cc60678e0 100644
--- a/target/linux/adm5120-2.6/patches/001-adm5120.patch
+++ b/target/linux/adm5120-2.6/patches/001-adm5120.patch
@@ -1,10 +1,11 @@
-diff -urN linux-2.6.19.2/arch/mips/Kconfig linux-2.6.19.2.new/arch/mips/Kconfig
---- linux-2.6.19.2/arch/mips/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/arch/mips/Kconfig 2007-01-23 14:49:38.000000000 +0100
-@@ -12,6 +12,21 @@
+Index: linux-2.6.21.1/arch/mips/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/arch/mips/Kconfig
++++ linux-2.6.21.1/arch/mips/Kconfig
+@@ -16,6 +16,21 @@ choice
prompt "System type"
default SGI_IP22
-
+
+config MIPS_ADM5120
+ bool "Support for ADM5120 SoC"
+ select SYS_HAS_CPU_MIPS32_R1
@@ -23,12 +24,13 @@ diff -urN linux-2.6.19.2/arch/mips/Kconfig linux-2.6.19.2.new/arch/mips/Kconfig
config MIPS_MTX1
bool "4G Systems MTX-1 board"
select DMA_NONCOHERENT
-diff -urN linux-2.6.19.2/arch/mips/Makefile linux-2.6.19.2.new/arch/mips/Makefile
---- linux-2.6.19.2/arch/mips/Makefile 2007-01-23 14:02:57.000000000 +0100
-+++ linux-2.6.19.2.new/arch/mips/Makefile 2007-01-23 14:49:39.000000000 +0100
-@@ -165,6 +165,14 @@
+Index: linux-2.6.21.1/arch/mips/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/arch/mips/Makefile
++++ linux-2.6.21.1/arch/mips/Makefile
+@@ -165,6 +165,14 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
-
+
#
+# ADMtek 5120
+#
@@ -41,13 +43,14 @@ diff -urN linux-2.6.19.2/arch/mips/Makefile linux-2.6.19.2.new/arch/mips/Makefil
# Common Alchemy Au1x00 stuff
#
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
-diff -urN linux-2.6.19.2/include/asm-mips/bootinfo.h linux-2.6.19.2.new/include/asm-mips/bootinfo.h
---- linux-2.6.19.2/include/asm-mips/bootinfo.h 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/include/asm-mips/bootinfo.h 2007-01-23 14:49:40.000000000 +0100
-@@ -212,6 +212,42 @@
+Index: linux-2.6.21.1/include/asm-mips/bootinfo.h
+===================================================================
+--- linux-2.6.21.1.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.21.1/include/asm-mips/bootinfo.h
+@@ -213,6 +213,42 @@
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
-
+
+/*
+ * Valid machtype for group ADMtek ADM5120
+ */
@@ -85,5 +88,5 @@ diff -urN linux-2.6.19.2/include/asm-mips/bootinfo.h linux-2.6.19.2.new/include/
+#define MACH_ADM5120_ES2108PWR 30 /* ZyXEL Ethernet Switch 2108-PWR */
+
#define CL_SIZE COMMAND_LINE_SIZE
-
+
const char *get_system_type(void);
diff --git a/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch b/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch
index 503a49567c..c6237c6dd0 100644
--- a/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch
+++ b/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.19.2/drivers/mtd/maps/Kconfig linux-2.6.19.2-adm5120/drivers/mtd/maps/Kconfig
---- linux-2.6.19.2/drivers/mtd/maps/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/mtd/maps/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -622,5 +622,10 @@
+Index: linux-2.6.21.1/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/maps/Kconfig
++++ linux-2.6.21.1/drivers/mtd/maps/Kconfig
+@@ -605,5 +605,10 @@ config MTD_PLATRAM
This selection automatically selects the map_ram driver.
@@ -12,10 +13,11 @@ diff -urN linux-2.6.19.2/drivers/mtd/maps/Kconfig linux-2.6.19.2-adm5120/drivers
+
endmenu
-diff -urN linux-2.6.19.2/drivers/mtd/maps/Makefile linux-2.6.19.2-adm5120/drivers/mtd/maps/Makefile
---- linux-2.6.19.2/drivers/mtd/maps/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/mtd/maps/Makefile 2007-01-23 01:20:52.000000000 +0100
-@@ -43,6 +43,7 @@
+Index: linux-2.6.21.1/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.21.1/drivers/mtd/maps/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_OCELOT) += ocelot.o
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
diff --git a/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch b/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch
index f6fec30bca..cbd28b1aa8 100644
--- a/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch
+++ b/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.19.2/drivers/net/Kconfig linux-2.6.19.2-adm5120/drivers/net/Kconfig
---- linux-2.6.19.2/drivers/net/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/net/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -450,6 +450,10 @@
+Index: linux-2.6.21.1/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/net/Kconfig
++++ linux-2.6.21.1/drivers/net/Kconfig
+@@ -574,6 +574,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@@ -12,14 +13,15 @@ diff -urN linux-2.6.19.2/drivers/net/Kconfig linux-2.6.19.2-adm5120/drivers/net/
config NET_SB1250_MAC
tristate "SB1250 Ethernet support"
depends on NET_ETHERNET && SIBYTE_SB1xxx_SOC
-diff -urN linux-2.6.19.2/drivers/net/Makefile linux-2.6.19.2-adm5120/drivers/net/Makefile
---- linux-2.6.19.2/drivers/net/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/net/Makefile 2007-01-23 01:13:39.000000000 +0100
-@@ -164,6 +164,7 @@
+Index: linux-2.6.21.1/drivers/net/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/net/Makefile
++++ linux-2.6.21.1/drivers/net/Makefile
+@@ -165,6 +165,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o
+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
obj-$(CONFIG_ETH16I) += eth16i.o
- obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o
obj-$(CONFIG_HPLANCE) += hplance.o 7990.o
diff --git a/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch b/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
index 6f2ef7bb36..8a6d0205e2 100644
--- a/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
+++ b/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
@@ -1,10 +1,37 @@
-diff -urN linux-2.6.19.2/drivers/serial/Kconfig linux-2.6.19.2-adm5120/drivers/serial/Kconfig
---- linux-2.6.19.2/drivers/serial/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/serial/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -246,6 +246,22 @@
-
+Index: linux-2.6.21.1/drivers/serial/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/serial/Makefile
++++ linux-2.6.21.1/drivers/serial/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
+ obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
+ obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
+ obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
++obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
+ obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
+ obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
+ obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
+Index: linux-2.6.21.1/include/linux/serial_core.h
+===================================================================
+--- linux-2.6.21.1.orig/include/linux/serial_core.h
++++ linux-2.6.21.1/include/linux/serial_core.h
+@@ -135,6 +135,9 @@
+ /* Xilinx uartlite */
+ #define PORT_UARTLITE 74
+
++/* ADMtek ADM5120 SoC */
++#define PORT_ADM5120 68
++
+ #ifdef __KERNEL__
+
+ #include <linux/compiler.h>
+Index: linux-2.6.21.1/drivers/serial/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/serial/Kconfig
++++ linux-2.6.21.1/drivers/serial/Kconfig
+@@ -256,6 +256,22 @@ config SERIAL_8250_AU1X00
+
comment "Non-8250 serial port support"
-
+
+config SERIAL_ADM5120
+ bool "ADM5120 serial port support"
+ depends on MIPS_ADM5120
@@ -22,29 +49,5 @@ diff -urN linux-2.6.19.2/drivers/serial/Kconfig linux-2.6.19.2-adm5120/drivers/s
+ support.
+
config SERIAL_AMBA_PL010
- tristate "ARM AMBA PL010 serial port support"
- depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)
-diff -urN linux-2.6.19.2/drivers/serial/Makefile linux-2.6.19.2-adm5120/drivers/serial/Makefile
---- linux-2.6.19.2/drivers/serial/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/serial/Makefile 2007-01-23 01:21:45.000000000 +0100
-@@ -20,6 +20,7 @@
- obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
- obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
- obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
-+obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
- obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
- obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
- obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
-diff -urN linux-2.6.19.2/include/linux/serial_core.h linux-2.6.19.2-adm5120/include/linux/serial_core.h
---- linux-2.6.19.2/include/linux/serial_core.h 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/include/linux/serial_core.h 2007-01-23 01:13:39.000000000 +0100
-@@ -133,6 +133,9 @@
- #define PORT_S3C2412 73
-
-
-+/* ADMtek ADM5120 SoC */
-+#define PORT_ADM5120 68
-+
- #ifdef __KERNEL__
-
- #include <linux/compiler.h>
+ tristate "ARM AMBA PL010 serial port support"
+ depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)
diff --git a/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch b/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
index 40e4fbedf4..f48b0f96c3 100644
--- a/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
+++ b/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.19.2/drivers/usb/core/hub.c linux-2.6.19.2-adm5120/drivers/usb/core/hub.c
---- linux-2.6.19.2/drivers/usb/core/hub.c 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/core/hub.c 2007-01-23 01:13:39.000000000 +0100
-@@ -2156,6 +2156,8 @@
+Index: linux-2.6.21.1/drivers/usb/core/hub.c
+===================================================================
+--- linux-2.6.21.1.orig/drivers/usb/core/hub.c
++++ linux-2.6.21.1/drivers/usb/core/hub.c
+@@ -2227,6 +2227,8 @@ hub_port_init (struct usb_hub *hub, stru
USB_DT_DEVICE << 8, 0,
buf, GET_DESCRIPTOR_BUFSIZE,
(i ? USB_CTRL_GET_TIMEOUT : 1000));
@@ -10,28 +11,31 @@ diff -urN linux-2.6.19.2/drivers/usb/core/hub.c linux-2.6.19.2-adm5120/drivers/u
switch (buf->bMaxPacketSize0) {
case 8: case 16: case 32: case 64: case 255:
if (buf->bDescriptorType ==
-diff -urN linux-2.6.19.2/drivers/usb/host/Kconfig linux-2.6.19.2-adm5120/drivers/usb/host/Kconfig
---- linux-2.6.19.2/drivers/usb/host/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/host/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -192,3 +192,6 @@
+Index: linux-2.6.21.1/drivers/usb/host/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/usb/host/Kconfig
++++ linux-2.6.21.1/drivers/usb/host/Kconfig
+@@ -224,3 +224,6 @@ config USB_SL811_CS
To compile this driver as a module, choose M here: the
module will be called "sl811_cs".
+config USB_ADM5120_HCD
+ tristate "ADM5120 HCD support"
+ depends on USB && MIPS_ADM5120
-diff -urN linux-2.6.19.2/drivers/usb/host/Makefile linux-2.6.19.2-adm5120/drivers/usb/host/Makefile
---- linux-2.6.19.2/drivers/usb/host/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/host/Makefile 2007-01-23 01:13:39.000000000 +0100
-@@ -16,3 +16,4 @@
+Index: linux-2.6.21.1/drivers/usb/host/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/usb/host/Makefile
++++ linux-2.6.21.1/drivers/usb/host/Makefile
+@@ -16,3 +16,4 @@ obj-$(CONFIG_USB_SL811_HCD) += sl811-hcd
obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
obj-$(CONFIG_USB_U132_HCD) += u132-hcd.o
obj-$(CONFIG_ETRAX_ARCH_V10) += hc_crisv10.o
+obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
-diff -urN linux-2.6.19.2/drivers/usb/Kconfig linux-2.6.19.2-adm5120/drivers/usb/Kconfig
---- linux-2.6.19.2/drivers/usb/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -91,8 +91,6 @@
+Index: linux-2.6.21.1/drivers/usb/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/usb/Kconfig
++++ linux-2.6.21.1/drivers/usb/Kconfig
+@@ -91,8 +91,6 @@ source "drivers/usb/image/Kconfig"
source "drivers/usb/net/Kconfig"
@@ -40,10 +44,11 @@ diff -urN linux-2.6.19.2/drivers/usb/Kconfig linux-2.6.19.2-adm5120/drivers/usb/
comment "USB port drivers"
depends on USB
-diff -urN linux-2.6.19.2/drivers/usb/Makefile linux-2.6.19.2-adm5120/drivers/usb/Makefile
---- linux-2.6.19.2/drivers/usb/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/Makefile 2007-01-23 01:22:18.000000000 +0100
-@@ -17,6 +17,7 @@
+Index: linux-2.6.21.1/drivers/usb/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/usb/Makefile
++++ linux-2.6.21.1/drivers/usb/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_ETRAX_USB_HOST) += host/
obj-$(CONFIG_USB_OHCI_AT91) += host/
diff --git a/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch b/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
index 593743d7ba..15a5eabf16 100644
--- a/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
+++ b/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.19.2/drivers/char/Kconfig linux-2.6.19.2-adm5120/drivers/char/Kconfig
---- linux-2.6.19.2/drivers/char/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/char/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -1034,7 +1034,9 @@
+Index: linux-2.6.21.1/drivers/char/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/char/Kconfig
++++ linux-2.6.21.1/drivers/char/Kconfig
+@@ -1056,7 +1056,9 @@ config MMTIMER
The mmtimer device allows direct userspace access to the
Altix system timer.
@@ -11,11 +12,12 @@ diff -urN linux-2.6.19.2/drivers/char/Kconfig linux-2.6.19.2-adm5120/drivers/cha
+ depends on MIPS_ADM5120
config TELCLOCK
- tristate "Telecom clock driver for MPBL0010 ATCA SBC"
-diff -urN linux-2.6.19.2/drivers/char/Makefile linux-2.6.19.2-adm5120/drivers/char/Makefile
---- linux-2.6.19.2/drivers/char/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/char/Makefile 2007-01-23 01:20:01.000000000 +0100
-@@ -90,6 +90,7 @@
+ tristate "Telecom clock driver for ATCA SBC"
+Index: linux-2.6.21.1/drivers/char/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/char/Makefile
++++ linux-2.6.21.1/drivers/char/Makefile
+@@ -93,6 +93,7 @@ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio
obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
obj-$(CONFIG_TANBAC_TB0219) += tb0219.o
obj-$(CONFIG_TELCLOCK) += tlclk.o
diff --git a/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch b/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch
index 25ec59a390..1098a24ba8 100644
--- a/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch
+++ b/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch
@@ -1,13 +1,16 @@
-diff -urN linux-2.6.21.1/arch/mips/pci/Makefile linux-2.6.21.1-adm5120/arch/mips/pci/Makefile
---- linux-2.6.21.1/arch/mips/pci/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.21.1-adm5120/arch/mips/pci/Makefile 2007-01-23 14:49:40.000000000 +0100
-@@ -53,3 +53,4 @@
+Index: linux-2.6.21.1/arch/mips/pci/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/arch/mips/pci/Makefile
++++ linux-2.6.21.1/arch/mips/pci/Makefile
+@@ -53,3 +53,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += fixup-adm5120.o ops-adm5120.o pci-adm5120.o
---- linux-2.6.21.1.old/include/linux/pci_ids.h 2007-04-27 23:49:26.000000000 +0200
-+++ linux-2.6.21.1/include/linux/pci_ids.h 2007-05-31 09:36:56.000000000 +0200
+Index: linux-2.6.21.1/include/linux/pci_ids.h
+===================================================================
+--- linux-2.6.21.1.orig/include/linux/pci_ids.h
++++ linux-2.6.21.1/include/linux/pci_ids.h
@@ -1701,6 +1701,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch b/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch
index 81ec37d05f..88b90454a8 100644
--- a/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch
+++ b/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch
@@ -1,7 +1,8 @@
-diff -Nur linux-2.6.19.2/drivers/mtd/Kconfig.old linux-2.6.19.2/drivers/mtd/Kconfig
---- linux-2.6.19.2/drivers/mtd/Kconfig.old 2007-03-25 08:13:02.000000000 +0200
-+++ linux-2.6.19.2/drivers/mtd/Kconfig 2007-03-26 13:37:47.000000000 +0200
-@@ -157,6 +157,22 @@
+Index: linux-2.6.21.1/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/Kconfig
++++ linux-2.6.21.1/drivers/mtd/Kconfig
+@@ -157,6 +157,22 @@ config MTD_AFS_PARTS
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@@ -24,10 +25,11 @@ diff -Nur linux-2.6.19.2/drivers/mtd/Kconfig.old linux-2.6.19.2/drivers/mtd/Kcon
comment "User Modules And Translation Layers"
depends on MTD
-diff -Nur linux-2.6.19.2/drivers/mtd/Makefile.old linux-2.6.19.2/drivers/mtd/Makefile
---- linux-2.6.19.2/drivers/mtd/Makefile.old 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2/drivers/mtd/Makefile 2007-03-26 13:28:23.000000000 +0200
-@@ -12,6 +12,7 @@
+Index: linux-2.6.21.1/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/Makefile
++++ linux-2.6.21.1/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
diff --git a/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch b/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
index 23f377c90b..d5edc23dce 100644
--- a/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
+++ b/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
@@ -1,7 +1,8 @@
-diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
---- linux.old/arch/mips/kernel/head.S 2006-12-06 17:30:27.000000000 +0100
-+++ linux.dev/arch/mips/kernel/head.S 2006-12-06 18:34:43.000000000 +0100
-@@ -129,15 +129,20 @@
+Index: linux-2.6.21.1/arch/mips/kernel/head.S
+===================================================================
+--- linux-2.6.21.1.orig/arch/mips/kernel/head.S
++++ linux-2.6.21.1/arch/mips/kernel/head.S
+@@ -129,14 +129,19 @@
#endif
.endm
@@ -17,11 +18,9 @@ diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
+ * Use as temporary storage for the kernel command line, so that it
+ * can be updated easily without having to relink the kernel.
*/
-- .align 10
+
+EXPORT(_image_cmdline)
+ .ascii "CMDLINE:"
-+ .align 10
+ .align 10
EXPORT(stext) # used for profiling
- EXPORT(_stext)
diff --git a/target/linux/adm5120-2.6/patches/500-Nand.patch b/target/linux/adm5120-2.6/patches/500-Nand.patch
index 05beb20241..8929a73fbb 100644
--- a/target/linux/adm5120-2.6/patches/500-Nand.patch
+++ b/target/linux/adm5120-2.6/patches/500-Nand.patch
@@ -1,10 +1,10 @@
-diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
-index cfe288a..c528024 100644
---- a/drivers/mtd/nand/Kconfig
-+++ b/drivers/mtd/nand/Kconfig
-@@ -55,6 +55,12 @@ config MTD_NAND_TOTO
+Index: linux-2.6.21.1/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Kconfig
++++ linux-2.6.21.1/drivers/mtd/nand/Kconfig
+@@ -75,6 +75,12 @@ config MTD_NAND_TS7250
help
- Support for NAND flash on Texas Instruments Toto platform.
+ Support for NAND flash on Technologic Systems TS-7250 platform.
+config MTD_NAND_RB100
+ tristate "NAND Flash device on RB100 board"
@@ -15,13 +15,13 @@ index cfe288a..c528024 100644
config MTD_NAND_IDS
tristate
-diff --git a/drivers/mtd/nand/Makefile b/drivers/mtd/nand/Makefile
-index 4174202..2be57c1 100644
---- a/drivers/mtd/nand/Makefile
-+++ b/drivers/mtd/nand/Makefile
-@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_NAND_IDS) += nand_ids.
-
+Index: linux-2.6.21.1/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Makefile
++++ linux-2.6.21.1/drivers/mtd/nand/Makefile
+@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
+obj-$(CONFIG_MTD_NAND_RB100) += rbmipsnand.o
obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o