summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:22 +0000
commitd3c75d79cd7fef96ed943fdd2ddf9ffafec7b011 (patch)
tree785b26947f71bbc6a9e7526e69b25dd851122fcd /target
parent5137cdb1e161f4d8385b9d2b78dbe8f07738e339 (diff)
downloadmaster-31e0f0ae-d3c75d79cd7fef96ed943fdd2ddf9ffafec7b011.tar.gz
master-31e0f0ae-d3c75d79cd7fef96ed943fdd2ddf9ffafec7b011.tar.bz2
master-31e0f0ae-d3c75d79cd7fef96ed943fdd2ddf9ffafec7b011.zip
ar71xx: image: remove too big files in the CatFiles macro
Also improve the warning message. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38125
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index bb6f6124f8..65ddabec15 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -115,7 +115,8 @@ define CatFiles
esac; \
( dd if=$(1) bs=$$$${bs} conv=sync; cat $(3) ) > $(5); \
if [ `stat -c%s $(5)` -gt $(4) ]; then \
- echo "Warning: $(1) is too big" >&2; \
+ echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
+ rm -f $(5); \
fi; \
else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
echo "Warning: $(1) is too big" >&2; \