summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-05 00:38:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-05 00:38:37 +0000
commitcf282c9a694209b7d8265a07f3297a99134d6f17 (patch)
tree720e209127b5f67083d94fc69f21840e26ce969b /target
parent8621fbdb4e3d794b34c505364f979512b7339c51 (diff)
downloadmaster-31e0f0ae-cf282c9a694209b7d8265a07f3297a99134d6f17.tar.gz
master-31e0f0ae-cf282c9a694209b7d8265a07f3297a99134d6f17.tar.bz2
master-31e0f0ae-cf282c9a694209b7d8265a07f3297a99134d6f17.zip
add missing init=/etc/preinit cmdline parameter
SVN-Revision: 6523
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86-2.6/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
index 9c26d6851c..c5a2163256 100644
--- a/target/linux/x86-2.6/image/Makefile
+++ b/target/linux/x86-2.6/image/Makefile
@@ -27,11 +27,11 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/ext2