summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-14 18:51:41 +0000
committerJohn Crispin <john@openwrt.org>2014-11-14 18:51:41 +0000
commitce1c580efbc0427c7e2e4eca7ddc738fae518aea (patch)
treebbec247f9832f5cf8cf7b43e2ba860fd11708240 /target
parent76a54a424ca2118da632b43e79feb83b2e7f79b3 (diff)
downloadmaster-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.tar.gz
master-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.tar.bz2
master-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.zip
ralink: make the sdhci module build again
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43274
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/modules.mk10
-rw-r--r--target/linux/ramips/patches-3.14/0060-soc_type.patch27
2 files changed, 20 insertions, 17 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 5b57f4c5bc..08eea9bb86 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -9,12 +9,14 @@ OTHER_MENU:=Other modules
define KernelPackage/sdhci-mt7620
SUBMENU:=Other modules
TITLE:=MT7620 SDCI
- DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+ DEPENDS:=@(TARGET_ramips_mt7620a||TARGET_ramips_mt7628||TARGET_ramips_mt7621) +kmod-sdhci
KCONFIG:= \
- CONFIG_MMC_SDHCI_MT7620
+ CONFIG_MTK_MMC \
+ CONFIG_MTK_AEE_KDUMP=n \
+ CONFIG_MTK_MMC_CD_POLL=n
FILES:= \
- $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
- AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+ $(LINUX_DIR)/drivers/mmc/host/mtk-mmc/mtk_sd.ko
+ AUTOLOAD:=$(call AutoProbe,mtk_sd,1)
endef
$(eval $(call KernelPackage,sdhci-mt7620))
diff --git a/target/linux/ramips/patches-3.14/0060-soc_type.patch b/target/linux/ramips/patches-3.14/0060-soc_type.patch
index f59be39f88..33b676bdf0 100644
--- a/target/linux/ramips/patches-3.14/0060-soc_type.patch
+++ b/target/linux/ramips/patches-3.14/0060-soc_type.patch
@@ -1,7 +1,7 @@
Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/mt7620.h
===================================================================
---- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/mt7620.h 2014-11-13 15:45:37.331344390 +0100
-+++ linux-3.14.18/arch/mips/include/asm/mach-ralink/mt7620.h 2014-11-13 15:45:37.679357795 +0100
+--- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/mt7620.h 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/include/asm/mach-ralink/mt7620.h 2014-11-14 14:38:04.453668044 +0100
@@ -13,14 +13,6 @@
#ifndef _MT7620_REGS_H_
#define _MT7620_REGS_H_
@@ -19,8 +19,8 @@ Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/mt7620.h
#define SYSC_REG_CHIP_NAME0 0x00
Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/ralink_regs.h
===================================================================
---- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/ralink_regs.h 2014-11-13 15:45:37.019332371 +0100
-+++ linux-3.14.18/arch/mips/include/asm/mach-ralink/ralink_regs.h 2014-11-13 16:22:25.320391798 +0100
+--- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/ralink_regs.h 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/include/asm/mach-ralink/ralink_regs.h 2014-11-14 14:38:04.453668044 +0100
@@ -13,6 +13,20 @@
#ifndef _RALINK_REGS_H_
#define _RALINK_REGS_H_
@@ -44,8 +44,8 @@ Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/ralink_regs.h
Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/rt305x.h
===================================================================
---- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/rt305x.h 2014-11-13 15:45:37.311343619 +0100
-+++ linux-3.14.18/arch/mips/include/asm/mach-ralink/rt305x.h 2014-11-13 15:45:37.679357795 +0100
+--- linux-3.14.18.orig/arch/mips/include/asm/mach-ralink/rt305x.h 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/include/asm/mach-ralink/rt305x.h 2014-11-14 14:38:04.453668044 +0100
@@ -13,25 +13,16 @@
#ifndef _RT305X_REGS_H_
#define _RT305X_REGS_H_
@@ -98,8 +98,8 @@ Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/rt305x.h
#define RT305X_SYSC_BASE 0x10000000
Index: linux-3.14.18/arch/mips/ralink/mt7620.c
===================================================================
---- linux-3.14.18.orig/arch/mips/ralink/mt7620.c 2014-11-13 15:45:37.311343619 +0100
-+++ linux-3.14.18/arch/mips/ralink/mt7620.c 2014-11-13 15:45:37.679357795 +0100
+--- linux-3.14.18.orig/arch/mips/ralink/mt7620.c 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/ralink/mt7620.c 2014-11-14 14:38:04.453668044 +0100
@@ -43,8 +43,6 @@
#define CLKCFG_FFRAC_MASK 0x001f
#define CLKCFG_FFRAC_USB_VAL 0x0003
@@ -170,8 +170,8 @@ Index: linux-3.14.18/arch/mips/ralink/mt7620.c
rt2880_pinmux_data = mt7620a_pinmux_data;
Index: linux-3.14.18/arch/mips/ralink/rt305x.c
===================================================================
---- linux-3.14.18.orig/arch/mips/ralink/rt305x.c 2014-11-13 15:45:37.363345622 +0100
-+++ linux-3.14.18/arch/mips/ralink/rt305x.c 2014-11-13 15:45:37.679357795 +0100
+--- linux-3.14.18.orig/arch/mips/ralink/rt305x.c 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/ralink/rt305x.c 2014-11-14 14:38:04.453668044 +0100
@@ -21,8 +21,6 @@
#include "common.h"
@@ -213,9 +213,9 @@ Index: linux-3.14.18/arch/mips/ralink/rt305x.c
} else {
Index: linux-3.14.18/arch/mips/ralink/prom.c
===================================================================
---- linux-3.14.18.orig/arch/mips/ralink/prom.c 2014-11-13 16:09:38.442855784 +0100
-+++ linux-3.14.18/arch/mips/ralink/prom.c 2014-11-13 16:10:20.220466636 +0100
-@@ -15,9 +15,12 @@
+--- linux-3.14.18.orig/arch/mips/ralink/prom.c 2014-11-14 14:37:58.341438796 +0100
++++ linux-3.14.18/arch/mips/ralink/prom.c 2014-11-14 18:36:23.815612485 +0100
+@@ -15,9 +15,13 @@
#include <asm/bootinfo.h>
#include <asm/addrspace.h>
@@ -225,6 +225,7 @@ Index: linux-3.14.18/arch/mips/ralink/prom.c
struct ralink_soc_info soc_info;
+enum ralink_soc_type ralink_soc;
++EXPORT_SYMBOL_GPL(ralink_soc);
const char *get_system_type(void)
{