summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-08-05 12:35:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-08-05 12:35:22 +0000
commitc80dd34924322153106081ad4ff6d233841acbc9 (patch)
tree3222727d4479102d8bface0d2c03550d52aae8f3 /target
parent267810f73a4565fc497132279810f5d457ad8f7e (diff)
downloadmaster-31e0f0ae-c80dd34924322153106081ad4ff6d233841acbc9.tar.gz
master-31e0f0ae-c80dd34924322153106081ad4ff6d233841acbc9.tar.bz2
master-31e0f0ae-c80dd34924322153106081ad4ff6d233841acbc9.zip
ramips: allow to build Seama firmware images with arbitrary size
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37707
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 88954f13aa..3e82432144 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -156,9 +156,9 @@ BuildFirmware/Edimax/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
# build Seama header images
define BuildFirmware/Seama/squashfs
- $(call BuildFirmware/OF,$(1),$(2),$(3),$(ralink_default_fw_size_8M))
+ $(call BuildFirmware/OF,$(1),$(2),$(3),$(4))
cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
- if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt 8060864 ]; then \
+ if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(4) - 64)) ]; then \
echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
else \
dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \
@@ -558,7 +558,7 @@ endif
#
# RT3662/RT3883 Profiles
#
-Image/Build/Profile/DIR645=$(call BuildFirmware/Seama/$(1),$(1),dir-645,DIR-645,wrgn39_dlob.hans_dir645)
+Image/Build/Profile/DIR645=$(call BuildFirmware/Seama/$(1),$(1),dir-645,DIR-645,wrgn39_dlob.hans_dir645,$(ralink_default_fw_size_8M))
omniembhpm_mtd_size=16449536
Image/Build/Profile/OMNIEMBHPM=$(call BuildFirmware/CustomFlash/$(1),$(1),omni-emb-hpm,OMNI-EMB-HPM,$(omniembhpm_mtd_size))