summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2012-02-16 07:29:26 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2012-02-16 07:29:26 +0000
commitc736e2d4b04a35c0ebf2c7a67579b6e798c0c8e7 (patch)
treec960b35320d312ca75cb2da5e44e22b82cb71bf0 /target
parent4685a513018d8cf41e2b23a8e89b6e0e7da1ad69 (diff)
downloadmaster-31e0f0ae-c736e2d4b04a35c0ebf2c7a67579b6e798c0c8e7.tar.gz
master-31e0f0ae-c736e2d4b04a35c0ebf2c7a67579b6e798c0c8e7.tar.bz2
master-31e0f0ae-c736e2d4b04a35c0ebf2c7a67579b6e798c0c8e7.zip
Fix partitions for Cameo-based boards; kernel 3.2 is bigger
SVN-Revision: 30569
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2caa58637d..2cde9cb679 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -206,14 +206,14 @@ define Image/Build/Cameo
fi
endef
-cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2944k(rootfs),64k(art)ro,3840k@0x30000(firmware)
+cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,960k(kernel),2880k(rootfs),64k(art)ro,3840k@0x30000(firmware)
define Image/Build/Cameo913x
- $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),917504,2949120,$(4))
+ $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),983040,2949120,$(4))
endef
-cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,896k(kernel),2816k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
+cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,960k(kernel),2752k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
define Image/Build/Cameo7240
- $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),917504,2818048,$(4))
+ $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),983040,2818048,$(4))
endef
define Image/Build/Ath