summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2010-12-08 00:40:24 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2010-12-08 00:40:24 +0000
commitc6ef9a072080fb37f566759659fb35b448fcce31 (patch)
tree5a4845811eda4b91e58baa9746dac686b7e13d7a /target
parent4ab241662165cbdb3eab68854409c1fae6c52438 (diff)
downloadmaster-31e0f0ae-c6ef9a072080fb37f566759659fb35b448fcce31.tar.gz
master-31e0f0ae-c6ef9a072080fb37f566759659fb35b448fcce31.tar.bz2
master-31e0f0ae-c6ef9a072080fb37f566759659fb35b448fcce31.zip
Profiles: Move wpad-mini to the profiles that use it, rather than default for all profiles (because -wpad-mini means it's not selectable, which isn't what we always want for the No WiFi profile
SVN-Revision: 24314
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/brcm63xx/profiles/100-Broadcom.mk2
-rw-r--r--target/linux/brcm63xx/profiles/101-Broadcom-wl.mk2
-rw-r--r--target/linux/brcm63xx/profiles/102-Atheros.mk2
-rw-r--r--target/linux/brcm63xx/profiles/103-Ralink.mk2
5 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 5bdc10384d..9b9043269f 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -14,7 +14,7 @@ LINUX_VERSION:=2.6.35.9
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += kmod-switch gpioctl
define Target/Description
Build firmware images for Broadcom based xDSL/routers
diff --git a/target/linux/brcm63xx/profiles/100-Broadcom.mk b/target/linux/brcm63xx/profiles/100-Broadcom.mk
index b7e1f46ec5..bc68f14937 100644
--- a/target/linux/brcm63xx/profiles/100-Broadcom.mk
+++ b/target/linux/brcm63xx/profiles/100-Broadcom.mk
@@ -7,7 +7,7 @@
define Profile/Broadcom
NAME:=Broadcom WiFi (default)
- PACKAGES:=kmod-b43
+ PACKAGES:=kmod-b43 wpad-mini
endef
define Profile/Broadcom/Description
diff --git a/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
index d67298cc9d..4f2d605eb7 100644
--- a/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
+++ b/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
@@ -7,7 +7,7 @@
define Profile/Broadcom-wl
NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
- PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+ PACKAGES:= kmod-brcm-wl wlc nas
endef
define Profile/Broadcom-wl/Description
diff --git a/target/linux/brcm63xx/profiles/102-Atheros.mk b/target/linux/brcm63xx/profiles/102-Atheros.mk
index 029586848f..c6d2da636e 100644
--- a/target/linux/brcm63xx/profiles/102-Atheros.mk
+++ b/target/linux/brcm63xx/profiles/102-Atheros.mk
@@ -7,7 +7,7 @@
define Profile/Atheros
NAME:=Atheros WiFi (default)
- PACKAGES:=kmod-madwifi
+ PACKAGES:=kmod-madwifi wpad-mini
endef
define Profile/Atheros/Description
diff --git a/target/linux/brcm63xx/profiles/103-Ralink.mk b/target/linux/brcm63xx/profiles/103-Ralink.mk
index 0d78ae4a5a..412c5a45ad 100644
--- a/target/linux/brcm63xx/profiles/103-Ralink.mk
+++ b/target/linux/brcm63xx/profiles/103-Ralink.mk
@@ -7,7 +7,7 @@
define Profile/Ralink
NAME:=Ralink WiFi
- PACKAGES:=kmod-rt61-pci
+ PACKAGES:=kmod-rt61-pci wpad-mini
endef
$(eval $(call Profile,Ralink))