summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-31 11:10:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-31 11:10:20 +0000
commitc5879ba76d5e02b80f9062fa2f8c41462aed6749 (patch)
tree969e5c770629a586421e6179e1d7595c431cfb48 /target
parent252607a79c7acc7d6061dc94515df38f03154e26 (diff)
downloadmaster-31e0f0ae-c5879ba76d5e02b80f9062fa2f8c41462aed6749.tar.gz
master-31e0f0ae-c5879ba76d5e02b80f9062fa2f8c41462aed6749.tar.bz2
master-31e0f0ae-c5879ba76d5e02b80f9062fa2f8c41462aed6749.zip
refresh 2.6.27 patches
SVN-Revision: 17061
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch4
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch6
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch22
4 files changed, 18 insertions, 16 deletions
diff --git a/target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch b/target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch
index 9d33edc2a1..163f8bea52 100644
--- a/target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch
+++ b/target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch
@@ -22,7 +22,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
cpu_wait = r4k_wait;
break;
-@@ -802,11 +806,28 @@ static inline void cpu_probe_broadcom(st
+@@ -802,11 +805,28 @@ static inline void cpu_probe_broadcom(st
decode_configs(c);
switch (c->processor_id & 0xff00) {
case PRID_IMP_BCM3302:
@@ -51,7 +51,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
default:
c->cputype = CPU_UNKNOWN;
break;
-@@ -892,6 +913,10 @@ static __cpuinit const char *cpu_to_name
+@@ -892,6 +912,10 @@ static __cpuinit const char *cpu_to_name
case CPU_SR71000: name = "Sandcraft SR71000"; break;
case CPU_BCM3302: name = "Broadcom BCM3302"; break;
case CPU_BCM4710: name = "Broadcom BCM4710"; break;
diff --git a/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch b/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
index 4019683333..b656a2cb92 100644
--- a/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
+++ b/target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
@@ -45,9 +45,9 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
static inline unsigned int ehci_readl(const struct ehci_hcd *ehci,
__u32 __iomem * regs)
{
---- a/drivers/usb/host/Kconfig 2009-07-03 01:33:19.000000000 +0200
-+++ b/drivers/usb/host/Kconfig 2009-07-17 17:53:11.000000000 +0200
-@@ -44,7 +44,7 @@
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -44,7 +44,7 @@ config USB_EHCI_HCD
config USB_EHCI_ROOT_HUB_TT
bool "Root Hub Transaction Translators"
diff --git a/target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch
index d6866899c3..9a15d5d378 100644
--- a/target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -549,6 +549,9 @@ endif
+@@ -550,6 +550,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
diff --git a/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
index e89f81754a..297db2ac7e 100644
--- a/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
@@ -27,16 +27,18 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI
-@@ -2878,10 +2878,12 @@ static irqreturn_t rtl8169_interrupt(int
- goto out;
- }
-
+@@ -2872,12 +2872,12 @@ static irqreturn_t rtl8169_interrupt(int
+ rtl8169_tx_timeout(dev);
+ break;
+ }
+-
+#if 0
- if (unlikely(status & SYSErr)) {
- rtl8169_pcierr_interrupt(dev);
- goto out;
- }
+ if (unlikely(status & SYSErr)) {
+ rtl8169_pcierr_interrupt(dev);
+ break;
+ }
+-
+#endif
+ if (status & LinkChg)
+ rtl8169_check_link_status(dev, tp, ioaddr);
- if (status & LinkChg)
- rtl8169_check_link_status(dev, tp, ioaddr);