summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2009-01-03 12:24:51 +0000
committerMichael Büsch <mb@bu3sch.de>2009-01-03 12:24:51 +0000
commitc53c88b8b4f38039c93f52ba0405febb9fe91818 (patch)
tree206bf8c70f98d65621eda2a27b94a845bc1e5e97 /target
parent625482aef1e35cbdd72f89b8b57318d115612347 (diff)
downloadmaster-31e0f0ae-c53c88b8b4f38039c93f52ba0405febb9fe91818.tar.gz
master-31e0f0ae-c53c88b8b4f38039c93f52ba0405febb9fe91818.tar.bz2
master-31e0f0ae-c53c88b8b4f38039c93f52ba0405febb9fe91818.zip
moko: Fix 2.6.28 boot.
SVN-Revision: 13833
Diffstat (limited to 'target')
-rw-r--r--target/linux/s3c24xx/Makefile4
-rw-r--r--target/linux/s3c24xx/config-2.6.2810
-rw-r--r--target/linux/s3c24xx/patches-2.6.28/001-merge-openmoko.patch (renamed from target/linux/s3c24xx/patches-2.6.28/0001-merge-openmoko.patch)0
-rw-r--r--target/linux/s3c24xx/patches-2.6.28/002-call-preinit-instead-of-init.patch12
-rw-r--r--target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch (renamed from target/linux/s3c24xx/patches-2.6.28/0002-disable-xt-chaos.patch)0
5 files changed, 19 insertions, 7 deletions
diff --git a/target/linux/s3c24xx/Makefile b/target/linux/s3c24xx/Makefile
index afcbc78564..acd3b926cb 100644
--- a/target/linux/s3c24xx/Makefile
+++ b/target/linux/s3c24xx/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -11,7 +11,7 @@ BOARD:=s3c24xx
BOARDNAME:=s3c24xx
FEATURES:=jffs2
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.28
DEVICE_TYPE=phone
diff --git a/target/linux/s3c24xx/config-2.6.28 b/target/linux/s3c24xx/config-2.6.28
index 5a51d412c2..d1fe910125 100644
--- a/target/linux/s3c24xx/config-2.6.28
+++ b/target/linux/s3c24xx/config-2.6.28
@@ -581,11 +581,11 @@ CONFIG_NET_IPIP=m
CONFIG_NET_KEY_MIGRATE=y
# CONFIG_NET_PKTGEN is not set
CONFIG_NET_SCH_NETEM=m
-CONFIG_NFSD=y
-CONFIG_NFSD_V2_ACL=y
-CONFIG_NFSD_V3_ACL=y
+# CONFIG_NFSD is not set
+# CONFIG_NFSD_V2_ACL is not set
+# CONFIG_NFSD_V3_ACL is not set
# CONFIG_NFSD_V4 is not set
-CONFIG_NFS_ACL_SUPPORT=y
+# CONFIG_NFS_ACL_SUPPORT is not set
# CONFIG_NFS_FS is not set
CONFIG_NF_CONNTRACK=y
# CONFIG_NF_CONNTRACK_AMANDA is not set
@@ -648,7 +648,7 @@ CONFIG_PREEMPT=y
CONFIG_PRINTK_TIME=y
CONFIG_PROC_PAGE_MONITOR=y
# CONFIG_PROVE_LOCKING is not set
-CONFIG_RCU_CPU_STALL_DETECTOR=y
+# CONFIG_RCU_CPU_STALL_DETECTOR is not set
# CONFIG_RCU_TORTURE_TEST is not set
CONFIG_REGULATOR=y
CONFIG_REGULATOR_DEBUG=y
diff --git a/target/linux/s3c24xx/patches-2.6.28/0001-merge-openmoko.patch b/target/linux/s3c24xx/patches-2.6.28/001-merge-openmoko.patch
index 77be55078b..77be55078b 100644
--- a/target/linux/s3c24xx/patches-2.6.28/0001-merge-openmoko.patch
+++ b/target/linux/s3c24xx/patches-2.6.28/001-merge-openmoko.patch
diff --git a/target/linux/s3c24xx/patches-2.6.28/002-call-preinit-instead-of-init.patch b/target/linux/s3c24xx/patches-2.6.28/002-call-preinit-instead-of-init.patch
new file mode 100644
index 0000000000..19ecbf96c6
--- /dev/null
+++ b/target/linux/s3c24xx/patches-2.6.28/002-call-preinit-instead-of-init.patch
@@ -0,0 +1,12 @@
+Index: linux-2.6.28/init/main.c
+===================================================================
+--- linux-2.6.28.orig/init/main.c 2009-01-03 13:03:03.000000000 +0100
++++ linux-2.6.28/init/main.c 2009-01-03 13:03:14.000000000 +0100
+@@ -825,6 +825,7 @@ static int noinline init_post(void)
+ printk(KERN_WARNING "Failed to execute %s. Attempting "
+ "defaults...\n", execute_command);
+ }
++ run_init_process("/etc/preinit");
+ run_init_process("/sbin/init");
+ run_init_process("/etc/init");
+ run_init_process("/bin/init");
diff --git a/target/linux/s3c24xx/patches-2.6.28/0002-disable-xt-chaos.patch b/target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch
index e1b017feb1..e1b017feb1 100644
--- a/target/linux/s3c24xx/patches-2.6.28/0002-disable-xt-chaos.patch
+++ b/target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch