summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-26 09:01:41 +0000
committerJohn Crispin <john@openwrt.org>2015-10-26 09:01:41 +0000
commitc466a46a776183fcf05b4a99aa5df38f71754137 (patch)
treec01416e802e2a3b54dc9dbad277c175dc8a9dc38 /target
parentc9426352ce94afc6ec85ba019a4609873119e14a (diff)
downloadmaster-31e0f0ae-c466a46a776183fcf05b4a99aa5df38f71754137.tar.gz
master-31e0f0ae-c466a46a776183fcf05b4a99aa5df38f71754137.tar.bz2
master-31e0f0ae-c466a46a776183fcf05b4a99aa5df38f71754137.zip
ar71xx: add support for TP-LINK TL-WR841N/ND v10
The TL-WR841N/ND v10 is mostly identical to the v9. Apart from some minor changes, it contains a newer revision of the QCA9533 SoC and the CPU clock is significantly higher. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 47263
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7759a0d681..a659af9fa6 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -704,6 +704,13 @@ define Device/tl-wr841n-v9
TPLINK_HWID := 0x08410009
endef
+define Device/tl-wr841n-v10
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR841
+ TPLINK_HWID := 0x08410010
+endef
+
define Device/tl-wr842n-v1
$(Device/tplink-8m)
BOARDNAME := TL-MR3420
@@ -731,7 +738,7 @@ define Device/tl-wr847n-v8
DEVICE_PROFILE := TLWR841
TPLINK_HWID := 0x08470008
endef
-TARGET_DEVICES += tl-wr841nd-v3 tl-wr841nd-v5 tl-wr841nd-v7 tl-wr841n-v8 tl-wr841n-v9 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841nd-v3 tl-wr841nd-v5 tl-wr841nd-v7 tl-wr841n-v8 tl-wr841n-v9 tl-wr841n-v10 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
define Device/tl-wr941nd-v2
$(Device/tplink-4m)