summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-06 14:48:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-06 14:48:56 +0000
commitbb0d563919819d5e2bb2e175412785d3bc5a421d (patch)
tree8be77c0b949ee15ea3a0a0c3e4d63dfe0bf8d992 /target
parent6ac26a1ef71c0d7a0d38572f6bc0698be11616bf (diff)
downloadmaster-31e0f0ae-bb0d563919819d5e2bb2e175412785d3bc5a421d.tar.gz
master-31e0f0ae-bb0d563919819d5e2bb2e175412785d3bc5a421d.tar.bz2
master-31e0f0ae-bb0d563919819d5e2bb2e175412785d3bc5a421d.zip
imx23: fix kernel module dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37181
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx23/modules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/imx23/modules.mk b/target/linux/imx23/modules.mk
index 1e27e415ac..fb81cef91c 100644
--- a/target/linux/imx23/modules.mk
+++ b/target/linux/imx23/modules.mk
@@ -7,7 +7,7 @@
define KernelPackage/rtc-stmp3xxx
SUBMENU:=$(OTHER_MENU)
TITLE:=STMP3xxx SoC built-in RTC support
- DEPENDS:=@(TARGET_imx23)
+ DEPENDS:=@TARGET_imx23
$(call AddDepends/rtc)
KCONFIG:=\
CONFIG_RTC_CLASS=y \
@@ -35,6 +35,7 @@ $(eval $(call KernelPackage,wdt-stmp3xxx))
define KernelPackage/usb-chipidea
TITLE:=Support for ChipIdea controllers
+ DEPENDS:=@TARGET_imx23
KCONFIG:= \
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
@@ -70,6 +71,7 @@ $(eval $(call KernelPackage,usb-mxs-phy,1))
define KernelPackage/usb-net-smsc95xx
TITLE:=SMSC95xx USB/2.0 Ethernet driver
+ DEPENDS:=@TARGET_imx23
KCONFIG:=CONFIG_USB_NET_SMSC95XX
FILES:=$(LINUX_DIR)/drivers/net/usb/smsc95xx.ko
AUTOLOAD:=$(call AutoLoad,64,smsc95xx)