summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-01 11:06:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-01 11:06:32 +0000
commitb99dfc713360fe497da88fa1ee12b539d4d68859 (patch)
treeb911d082b3e3b8d93d7cc0b64b5ba6df067d1999 /target
parent8312a2acc2643b7421a5310c3a07663fceb36cc4 (diff)
downloadmaster-31e0f0ae-b99dfc713360fe497da88fa1ee12b539d4d68859.tar.gz
master-31e0f0ae-b99dfc713360fe497da88fa1ee12b539d4d68859.tar.bz2
master-31e0f0ae-b99dfc713360fe497da88fa1ee12b539d4d68859.zip
Restore image creation for rdc boards
SVN-Revision: 6780
Diffstat (limited to 'target')
-rw-r--r--target/linux/rdc-2.6/image/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/rdc-2.6/image/Makefile b/target/linux/rdc-2.6/image/Makefile
index dc54bc5b6b..6c733087c2 100644
--- a/target/linux/rdc-2.6/image/Makefile
+++ b/target/linux/rdc-2.6/image/Makefile
@@ -11,10 +11,16 @@ define Image/Prepare
$(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
endef
+define Image/Build/Airlink
+ touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+ $(STAGING_DIR)/bin/airlink -b 1 -j 64 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endef
+
define Image/Build
- # FIXME
- #touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- #$(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).bzImage
+ifneq ($(1),jffs2-128K)
+ $(call Image/Build/Airlink,$(1),ar525w,$(patsubst jffs2-%,jffs2,$(1)))
+endif
endef
$(eval $(call BuildImage))