summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:29 +0000
committerJonas Gorski <jogo@openwrt.org>2013-02-21 11:45:29 +0000
commitb91eab631b2d06e18c076526dba370d52e92c0da (patch)
tree793b41dba611f4bc4b2054036968a7558d681338 /target
parent2d8c5117c0f7f9f4eef7e57dc4349588db1f4fe7 (diff)
downloadmaster-31e0f0ae-b91eab631b2d06e18c076526dba370d52e92c0da.tar.gz
master-31e0f0ae-b91eab631b2d06e18c076526dba370d52e92c0da.tar.bz2
master-31e0f0ae-b91eab631b2d06e18c076526dba370d52e92c0da.zip
ar71xx: print image build warnings/errors to stderr
Makes warnings/errors visible when building with V=w/V=1. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 35719
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 94d321398d..51fd3a9a8a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -116,9 +116,9 @@ endef
define CatFiles
if [ `stat -c%s "$(1)"` -gt $(2) ]; then \
- echo "Warning: $(1) is too big"; \
+ echo "Warning: $(1) is too big" >&2; \
else if [ `stat -c%s $(3)` -gt $(4) ]; then \
- echo "Warning: $(3) is too big"; \
+ echo "Warning: $(3) is too big" >&2; \
else \
( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
fi; fi
@@ -219,7 +219,7 @@ define Image/Build/DIR825B1
echo -n "$(4)"; \
) > $(call imgname,$(1),$(2))-backup-loader.bin; \
if [ `stat -c%s $(call sysupname,$(1),$(2))` -gt 4194304 ]; then \
- echo "Warning: $(call sysupname,$(1),$(2)) is too big"; \
+ echo "Warning: $(call sysupname,$(1),$(2)) is too big" >&2; \
else \
( \
dd if=$(call sysupname,$(1),$(2)) bs=4096k conv=sync; \
@@ -247,7 +247,7 @@ define Image/Build/DLRTDEV
echo -n "$(4)"; \
) > $(call imgname,$(1),$(2))-backup-loader.bin; \
if [ `stat -c%s $(call sysupname,$(1),$(2))` -gt 4194304 ]; then \
- echo "Warning: $(call sysupname,$(1),$(2)) is too big"; \
+ echo "Warning: $(call sysupname,$(1),$(2)) is too big" >&2; \
else \
( \
dd if=$(call sysupname,$(1),$(2)) bs=4096k conv=sync; \
@@ -708,7 +708,7 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
$(call Sysupgrade/KRuImage,$(1),$(2),917504,2752512)
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
if [ ! -f $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin ]; then \
- echo "Warning: $(IMG_PREFIX)-$(2)-u-boot.bin not found"; \
+ echo "Warning: $(IMG_PREFIX)-$(2)-u-boot.bin not found" >&2; \
else \
$(STAGING_DIR_HOST)/bin/mkzynfw \
-B $(4) \