summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-26 01:07:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-26 01:07:16 +0000
commitb2b0770576a90da0a23dd4f96fe1b5af6a7b7908 (patch)
tree11629a0beef6ff02b334a5a623bf35243eaf03a9 /target
parent335877a2b3220b9b0a901fe7af038c04ca1a2e8b (diff)
downloadmaster-31e0f0ae-b2b0770576a90da0a23dd4f96fe1b5af6a7b7908.tar.gz
master-31e0f0ae-b2b0770576a90da0a23dd4f96fe1b5af6a7b7908.tar.bz2
master-31e0f0ae-b2b0770576a90da0a23dd4f96fe1b5af6a7b7908.zip
kernel: use -fno-caller-saves
SVN-Revision: 26301
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-2.6.37/012-extra_optimization.patch11
-rw-r--r--target/linux/generic/patches-2.6.38/012-extra_optimization.patch9
2 files changed, 13 insertions, 7 deletions
diff --git a/target/linux/generic/patches-2.6.37/012-extra_optimization.patch b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
index d7066486fc..4ffa26e9eb 100644
--- a/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
+++ b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
@@ -1,15 +1,18 @@
--- a/Makefile
+++ b/Makefile
-@@ -540,7 +540,7 @@ all: vmlinux
+@@ -538,9 +538,9 @@
+ all: vmlinux
+
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -595,6 +595,9 @@ endif
+@@ -595,6 +595,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
diff --git a/target/linux/generic/patches-2.6.38/012-extra_optimization.patch b/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
index 4984fad29b..d173e4c753 100644
--- a/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
+++ b/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
@@ -1,11 +1,14 @@
--- a/Makefile
+++ b/Makefile
-@@ -541,7 +541,7 @@ all: vmlinux
+@@ -539,9 +539,9 @@ endif # $(dot-config)
+ all: vmlinux
+
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile