summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-06-02 16:35:09 +0000
committerRod Whitby <rod@whitby.id.au>2007-06-02 16:35:09 +0000
commitad2bc9c63bc35842198afaae9262c08229be99ec (patch)
tree671b9f759b18b8f96dedf492bd0136fdf6ab0b70 /target
parent414bc92dea59804e639cc713ed45338b4e1f80f7 (diff)
downloadmaster-31e0f0ae-ad2bc9c63bc35842198afaae9262c08229be99ec.tar.gz
master-31e0f0ae-ad2bc9c63bc35842198afaae9262c08229be99ec.tar.bz2
master-31e0f0ae-ad2bc9c63bc35842198afaae9262c08229be99ec.zip
apex: Updated to version 1.5.6 (which includes the compiler inlining fixes).
SVN-Revision: 7451
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/Makefile4
-rw-r--r--target/linux/ixp4xx-2.6/image/apex/patches/100-fix_compiler_inlining.patch28
2 files changed, 2 insertions, 30 deletions
diff --git a/target/linux/ixp4xx-2.6/image/apex/Makefile b/target/linux/ixp4xx-2.6/image/apex/Makefile
index 8d202904d0..abaa4324e5 100644
--- a/target/linux/ixp4xx-2.6/image/apex/Makefile
+++ b/target/linux/ixp4xx-2.6/image/apex/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=apex
-PKG_VERSION:=1.5.4
+PKG_VERSION:=1.5.6
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
ftp://metalab.unc.edu/pub/Linux/system/boot/apex/
-PKG_MD5SUM:=b07790b259f48653c32955244c23cc57
+PKG_MD5SUM:=1ef0881f80b89c7c0fb5d1c66a3b5ea1
include $(INCLUDE_DIR)/package.mk
diff --git a/target/linux/ixp4xx-2.6/image/apex/patches/100-fix_compiler_inlining.patch b/target/linux/ixp4xx-2.6/image/apex/patches/100-fix_compiler_inlining.patch
deleted file mode 100644
index 427068dab2..0000000000
--- a/target/linux/ixp4xx-2.6/image/apex/patches/100-fix_compiler_inlining.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- apex-1.5.4/src/arch-arm/entry/apex.lds.S~ 2007-05-31 14:54:41.000000000 +0930
-+++ apex-1.5.4/src/arch-arm/entry/apex.lds.S 2007-06-02 14:26:51.000000000 +0930
-@@ -48,8 +48,8 @@
- }
- .reset.post : { /* Post-SDRAM init code.*/
- *(.reset.post)
-- *(.reset.postfn)
-- *(.reset.postex)
-+ *(.reset.post.func)
-+ *(.reset.post.exit)
- }
- .rlocate : { /* Final/only relocation of APEX to SDRAM */
- *(.rlocate)
---- apex-1.5.4/src/arch-arm/entry/reset.c~ 2007-05-31 14:54:41.000000000 +0930
-+++ apex-1.5.4/src/arch-arm/entry/reset.c 2007-06-02 14:27:20.000000000 +0930
-@@ -292,10 +292,10 @@
- // __asm volatile ("mov sp, %0" :: "r" (&APEX_VMA_STACK_START));
-
- __asm volatile ("mov r0, %0" :: "r" (offset));
-- __asm volatile ("b reset_post_2");
-+ __asm volatile ("b reset_post_exit");
- }
-
--void __naked __section (.reset.post) reset_post_2 (void)
-+void __naked __section (.reset.post.exit) reset_post_exit (void)
- {
- }
-