summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-16 10:29:50 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-16 10:29:50 +0000
commitacdb0ac35c4b527b4e827809160c7478b1162817 (patch)
tree84d028bc5f6ebe711d34dd0ac59e38a0a407dd05 /target
parent76dfe21a272cbac9bc633453c764676e84992a8c (diff)
downloadmaster-31e0f0ae-acdb0ac35c4b527b4e827809160c7478b1162817.tar.gz
master-31e0f0ae-acdb0ac35c4b527b4e827809160c7478b1162817.tar.bz2
master-31e0f0ae-acdb0ac35c4b527b4e827809160c7478b1162817.zip
build: move mkits.sh script to more common place
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38430
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx6/files-3.10/scripts/mkits.sh111
-rw-r--r--target/linux/imx6/image/Makefile27
2 files changed, 15 insertions, 123 deletions
diff --git a/target/linux/imx6/files-3.10/scripts/mkits.sh b/target/linux/imx6/files-3.10/scripts/mkits.sh
deleted file mode 100644
index 3b02b6950a..0000000000
--- a/target/linux/imx6/files-3.10/scripts/mkits.sh
+++ /dev/null
@@ -1,111 +0,0 @@
-#!/bin/bash
-#
-# Licensed under the terms of the GNU GPL License version 2 or later.
-#
-# Author: Peter Tyser <ptyser@xes-inc.com>
-#
-# U-Boot firmware supports the booting of images in the Flattened Image
-# Tree (FIT) format. The FIT format uses a device tree structure to
-# describe a kernel image, device tree blob, ramdisk, etc. This script
-# creates an Image Tree Source (.its file) which can be passed to the
-# 'mkimage' utility to generate an Image Tree Blob (.itb file). The .itb
-# file can then be booted by U-Boot (or other bootloaders which support
-# FIT images). See doc/uImage.FIT/howto.txt in U-Boot source code for
-# additional information on FIT images.
-#
-
-usage() {
- echo "Usage: `basename $0` -A arch -C comp -a addr -e entry" \
- "-v version -k kernel [-d dtb] -o its_file"
- echo -e "\t-A ==> set architecture to 'arch'"
- echo -e "\t-C ==> set compression type 'comp'"
- echo -e "\t-a ==> set load address to 'addr' (hex)"
- echo -e "\t-e ==> set entry point to 'entry' (hex)"
- echo -e "\t-v ==> set kernel version to 'version'"
- echo -e "\t-k ==> include kernel image 'kernel'"
- echo -e "\t-d ==> include Device Tree Blob 'dtb'"
- echo -e "\t-o ==> create output file 'its_file'"
- exit 1
-}
-
-while getopts ":A:C:a:d:e:k:o:v:" OPTION
-do
- case $OPTION in
- A ) ARCH=$OPTARG;;
- C ) COMPRESS=$OPTARG;;
- a ) LOAD_ADDR=$OPTARG;;
- d ) DTB=$OPTARG;;
- e ) ENTRY_ADDR=$OPTARG;;
- k ) KERNEL=$OPTARG;;
- o ) OUTPUT=$OPTARG;;
- v ) VERSION=$OPTARG;;
- * ) echo "Invalid option passed to '$0' (options:$@)"
- usage;;
- esac
-done
-
-# Make sure user entered all required parameters
-if [ -z "${ARCH}" ] || [ -z "${COMPRESS}" ] || [ -z "${LOAD_ADDR}" ] || \
- [ -z "${ENTRY_ADDR}" ] || [ -z "${VERSION}" ] || [ -z "${KERNEL}" ] || \
- [ -z "${OUTPUT}" ]; then
- usage
-fi
-
-# Create a default, fully populated DTS file
-DATA="/dts-v1/;
-
-/ {
- description = \"Linux kernel ${VERSION}\";
- #address-cells = <1>;
-
- images {
- kernel@1 {
- description = \"Linux Kernel ${VERSION}\";
- data = /incbin/(\"${KERNEL}\");
- type = \"kernel\";
- arch = \"${ARCH}\";
- os = \"linux\";
- compression = \"${COMPRESS}\";
- load = <${LOAD_ADDR}>;
- entry = <${ENTRY_ADDR}>;
- hash@1 {
- algo = \"crc32\";
- };
- hash@2 {
- algo = \"sha1\";
- };
- };
-
- fdt@1 { /* start fdt */
- description = \"Flattened Device Tree blob\";
- data = /incbin/(\"${DTB}\");
- type = \"flat_dt\";
- arch = \"${ARCH}\";
- compression = \"none\";
- hash@1 {
- algo = \"crc32\";
- };
- hash@2 {
- algo = \"sha1\";
- };
- }; /* end fdt */
- };
-
- configurations {
- default = \"config@1\";
- config@1 {
- description = \"Default Linux kernel\";
- kernel = \"kernel@1\";
- fdt = \"fdt@1\";
- };
- };
-};"
-
-# Conditionally strip fdt information out of tree
-if [ -z "${DTB}" ]; then
- DATA=`echo "$DATA" | sed '/start fdt/,/end fdt/d'`
- DATA=`echo "$DATA" | sed '/fdt/d'`
-fi
-
-# Write .its file to disk
-echo "$DATA" > ${OUTPUT}
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 0bcb85bee5..aad15271a0 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -11,22 +11,25 @@ BOARDS := \
imx6dl-wandboard \
imx6q-gw5400-a
-# board-specific Flattened Image Tree
-define mkfit
- /bin/sh $(LINUX_DIR)/scripts/mkits.sh -A arm -C none -a $(2) -e $(2) \
- -v 'OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(LINUX_DIR)/arch/arm/boot/dts/$(1).dtb -k $(LINUX_DIR)/arch/arm/boot/zImage \
- -o $(KDIR)/$(1)-uImage.its
- PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/$(1)-uImage.its $(BIN_DIR)/openwrt-$(1)-uImage.itb
-endef
-
# emit FIT images, DTB's and generic zImage
define Image/BuildKernel
$(foreach board,$(BOARDS),
- $(call mkfit,$(board),0x10008000)
- cp $(LINUX_DIR)/arch/arm/boot/dts/$(board).dtb $(BIN_DIR)
+ cp $(LINUX_DIR)/arch/arm/boot/dts/$(board).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(board).dtb
+
+ $(call Image/BuildKernel/MkFIT,$(board),$(KDIR)/zImage,$(BIN_DIR)/$(IMG_PREFIX)-$(board).dtb,none,0x10008000,0x10008000)
+ cp $(KDIR)/fit-$(board).itb $(BIN_DIR)/$(IMG_PREFIX)-$(board)-uImage.itb
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/BuildKernel/MkFIT,$(board),$(KDIR)/zImage-initramfs,$(BIN_DIR)/$(IMG_PREFIX)-$(board).dtb,none,0x10008000,0x10008000,-initramfs)
+ cp $(KDIR)/fit-$(board)-initramfs.itb $(BIN_DIR)/$(IMG_PREFIX)-$(board)-uImage-initramfs.itb
+ endif
)
- cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ cp $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-zImage-initramfs
+ endif
endef
# board-specific sysupgrade image