summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:19 +0000
commita7c5f6708bd398fa1e5456baa7d1249e29761f80 (patch)
treebe635880d56d82ba2c5bfa31136083fe9ac1c589 /target
parentab5e21a9a58ce3225ebf8b0767b0f09318af143b (diff)
downloadmaster-31e0f0ae-a7c5f6708bd398fa1e5456baa7d1249e29761f80.tar.gz
master-31e0f0ae-a7c5f6708bd398fa1e5456baa7d1249e29761f80.tar.bz2
master-31e0f0ae-a7c5f6708bd398fa1e5456baa7d1249e29761f80.zip
ar71xx: use uimage split for WZR-HP-G450H
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37292
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c12
-rw-r--r--target/linux/ar71xx/image/Makefile24
2 files changed, 25 insertions, 11 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c
index 2c28a55f55..03b63c9eec 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c
@@ -43,21 +43,13 @@ static struct mtd_partition wzrhpg450h_partitions[] = {
.size = 0x0010000,
.mask_flags = MTD_WRITEABLE,
}, {
- .name = "uImage",
+ .name = "firmware",
.offset = 0x0060000,
- .size = 0x0100000,
- }, {
- .name = "rootfs",
- .offset = 0x0160000,
- .size = 0x1e80000,
+ .size = 0x1f80000,
}, {
.name = "user_property",
.offset = 0x1fe0000,
.size = 0x0020000,
- }, {
- .name = "firmware",
- .offset = 0x0060000,
- .size = 0x1f80000,
}
};
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7b83b6424a..b50f333d4c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -270,6 +270,28 @@ define Image/Build/DLRTDEV
fi
endef
+define Image/Build/WZRHP64K
+ $(call MkuImageLzma,$(2),$(3))
+ $(call Sysupgrade/KRuImage,$(1),$(2),65536,31850496)
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ ( \
+ echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+ dd if=$(call sysupname,$(1),$(2)); \
+ ) > $(call imgname,$(1),$(2))-tftp.bin; \
+ buffalo-enc -p $(4) -v 1.99 \
+ -i $(call sysupname,$(1),$(2)) \
+ -o $(KDIR_TMP)/$(2).enc; \
+ buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
+ -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
+ -i $(KDIR_TMP)/$(2).enc \
+ -o $(call factoryname,$(1),$(2)); \
+ fi
+endef
+
+define Image/Build/WZRHP64K/initramfs
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+endef
+
define Image/Build/WZRHPG30XNH
$(call MkuImageLzma,$(2),$(3))
$(call Sysupgrade/KRuImage,$(1),$(2),1048576,31850496)
@@ -994,7 +1016,7 @@ $(eval $(call SingleProfile,WRT400N,$(fs_64k),WRT400N,wrt400n,WRT400N,ttyS0,1152
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
-$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
+$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))
$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))