summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-07-13 18:21:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-07-13 18:21:09 +0000
commita749d8163f8ee180ec42142b784db3871a57f073 (patch)
treec69a29c5656dd2c3be53a23e68b4b83a9ce468f2 /target
parentdef30210f8f8859b611c099e2c0f9450c56e3baf (diff)
downloadmaster-31e0f0ae-a749d8163f8ee180ec42142b784db3871a57f073.tar.gz
master-31e0f0ae-a749d8163f8ee180ec42142b784db3871a57f073.tar.bz2
master-31e0f0ae-a749d8163f8ee180ec42142b784db3871a57f073.zip
ar71xx: add profile and build image for GL.iNet v1
Patch is based on http://patchwork.openwrt.org/patch/5273/. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Michel Stempin <michel.stempin@wanadoo.fr> Signed-off-by: Mark Janssen <mark@sig-io.nl> Signed-off-by: alzhao <alzhao@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/5653/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 41621
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/gl-connect.mk17
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/gl-connect.mk b/target/linux/ar71xx/generic/profiles/gl-connect.mk
new file mode 100644
index 0000000000..e9377dbbfa
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/gl-connect.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GLINET
+ NAME:=GL.iNet
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/GLINET/Description
+ Package set optimized for the GL-Connect GL.iNet v1.
+endef
+
+$(eval $(call Profile,GLINET))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a1036393bb..595389fd2d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1132,6 +1132,7 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ARCHERC7V1,archer-c7-v1,ARCHER-C7
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ARCHERC7V2,archer-c7-v2,ARCHER-C7,ttyS0,115200,0xc7000002,1,16Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ELM150,el-m150,EL-M150,ttyATH0,115200,0x01500101,1,8Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ELMINI,el-mini,EL-MINI,ttyATH0,115200,0x01530001,1,8Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,GLINET,gl-inet-v1,GL-INET,ttyATH0,115200,0x08000001,1,8Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR10U,tl-mr10u-v1,TL-MR10U,ttyATH0,115200,0x00100101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV1,tl-mr11u-v1,TL-MR11U,ttyATH0,115200,0x00110101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV2,tl-mr11u-v2,TL-MR11U,ttyATH0,115200,0x00110102,1,4Mlzma))