summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2011-03-28 01:18:58 +0000
committerTravis Kemen <thepeople@openwrt.org>2011-03-28 01:18:58 +0000
commit99c3236182cdd38ef844bef985883ff01421c9b0 (patch)
tree63e687d8cc79f6261fec59900a3929dc261fd92d /target
parent87f5872f35b9485d1c7f073e1ad1182b96ae96c2 (diff)
downloadmaster-31e0f0ae-99c3236182cdd38ef844bef985883ff01421c9b0.tar.gz
master-31e0f0ae-99c3236182cdd38ef844bef985883ff01421c9b0.tar.bz2
master-31e0f0ae-99c3236182cdd38ef844bef985883ff01421c9b0.zip
The Geos target (and probably others, like net5501) need to grab the new cs5535 gpio driver.
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> SVN-Revision: 26330
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/geos/target.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
index cfeffd7427..faf616690b 100644
--- a/target/linux/x86/geos/target.mk
+++ b/target/linux/x86/geos/target.mk
@@ -1,8 +1,13 @@
BOARDNAME:=Traverse Geos
FEATURES:=squashfs jffs2 ext4 pci usb gpio
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
+ GEOS_GPIO:=gpio-cs5535-new
+else
+ GEOS_GPIO:=gpio-cs5535
+endif
DEFAULT_PACKAGES += kmod-ata-via-sata \
kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-gpio-cs5535 kmod-gpio-nsc \
+ kmod-$(GEOS_GPIO) kmod-gpio-nsc \
kmod-wdt-geode kmod-hwmon-core kmod-hwmon-lm90 \
kmod-8139cp kmod-solos-pci \
kmod-i2c-core kmod-i2c-gpio \
@@ -23,6 +28,6 @@ define Target/Description
Build firmware images for Traverse Geos board
endef
-define KernelPackage/gpio-cs5535/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535
+define KernelPackage/$(GEOS_GPIO)/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(GEOS_GPIO)
endef