summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-12-15 19:16:30 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-12-15 19:16:30 +0000
commit952db22551ae621deef18680625aaede453001f4 (patch)
tree3e70781509679af75aa1d73cc62d32b1f3a9ebb7 /target
parentfd50416248add8012b0581fc3c28875c546c947b (diff)
downloadmaster-31e0f0ae-952db22551ae621deef18680625aaede453001f4.tar.gz
master-31e0f0ae-952db22551ae621deef18680625aaede453001f4.tar.bz2
master-31e0f0ae-952db22551ae621deef18680625aaede453001f4.zip
kernel: update kernel 3.10 to 3.10.24
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 39059
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch2
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/bcm53xx/Makefile2
-rw-r--r--target/linux/brcm2708/Makefile2
-rw-r--r--target/linux/brcm2708/patches-3.10/014-bcm2708-sdhci-driver.patch2
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/cns21xx/Makefile2
-rw-r--r--target/linux/generic/patches-3.10/010-tsq_queueing_minimum.patch80
-rw-r--r--target/linux/generic/patches-3.10/100-overlayfs.patch2
-rw-r--r--target/linux/generic/patches-3.10/630-packet_socket_type.patch20
-rw-r--r--target/linux/generic/patches-3.10/655-increase_skb_pad.patch2
-rw-r--r--target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch2
-rw-r--r--target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch18
-rw-r--r--target/linux/generic/patches-3.10/721-phy_packets.patch4
-rw-r--r--target/linux/generic/patches-3.10/902-debloat_proc.patch4
-rw-r--r--target/linux/imx6/Makefile2
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/kirkwood/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mvebu/Makefile2
-rw-r--r--target/linux/octeon/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/rb532/Makefile2
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/sparc/Makefile2
-rw-r--r--target/linux/x86/alix2/target.mk2
-rw-r--r--target/linux/x86/generic/target.mk2
-rw-r--r--target/linux/x86/patches-3.10/100-rdc_boards.patch2
-rw-r--r--target/linux/xburst/Makefile2
36 files changed, 54 insertions, 134 deletions
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index 6707291620..f6935873e7 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 5fddd6f3fc..c865a547be 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=mips16
CPU_TYPE=34kc
SUBTARGETS:=generic nand mikrotik
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
index 1807dfb2ed..a0b5824850 100644
--- a/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
@@ -265,7 +265,7 @@
&sin->sin6_addr);
sin->sin6_scope_id = 0;
}
-@@ -687,12 +687,12 @@ int ip6_datagram_send_ctl(struct net *ne
+@@ -691,12 +691,12 @@ int ip6_datagram_send_ctl(struct net *ne
}
if (fl6->flowlabel&IPV6_FLOWINFO_MASK) {
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index 5ebee3d177..fe88770888 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index 02ed4e9a72..d5472e7bb4 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
CPU_TYPE:=cortex-a9
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 2caa549852..823bd08b4e 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
CPU_TYPE:=arm1176jzf-s
CPU_SUBTYPE:=vfp
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
diff --git a/target/linux/brcm2708/patches-3.10/014-bcm2708-sdhci-driver.patch b/target/linux/brcm2708/patches-3.10/014-bcm2708-sdhci-driver.patch
index d2449f5ba1..048d6e9269 100644
--- a/target/linux/brcm2708/patches-3.10/014-bcm2708-sdhci-driver.patch
+++ b/target/linux/brcm2708/patches-3.10/014-bcm2708-sdhci-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/mmc/card/block.c
+++ b/drivers/mmc/card/block.c
-@@ -1294,7 +1294,7 @@ static void mmc_blk_rw_rq_prep(struct mm
+@@ -1333,7 +1333,7 @@ static void mmc_blk_rw_rq_prep(struct mm
brq->data.blocks = 1;
}
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index e6b526a403..e56bd162db 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index e4f7283869..c4dfa25a3b 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
SUBTARGETS:=generic smp
FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index d77b926a41..3a635d0394 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs
CPU_TYPE:=fa526
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-3.10/010-tsq_queueing_minimum.patch b/target/linux/generic/patches-3.10/010-tsq_queueing_minimum.patch
deleted file mode 100644
index 2d2dafcdb2..0000000000
--- a/target/linux/generic/patches-3.10/010-tsq_queueing_minimum.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 98e09386c0ef4dfd48af7ba60ff908f0d525cdee Mon Sep 17 00:00:00 2001
-From: Eric Dumazet <edumazet@google.com>
-Date: Wed, 13 Nov 2013 14:32:54 +0000
-Subject: tcp: tsq: restore minimal amount of queueing
-
-After commit c9eeec26e32e ("tcp: TSQ can use a dynamic limit"), several
-users reported throughput regressions, notably on mvneta and wifi
-adapters.
-
-802.11 AMPDU requires a fair amount of queueing to be effective.
-
-This patch partially reverts the change done in tcp_write_xmit()
-so that the minimal amount is sysctl_tcp_limit_output_bytes.
-
-It also remove the use of this sysctl while building skb stored
-in write queue, as TSO autosizing does the right thing anyway.
-
-Users with well behaving NICS and correct qdisc (like sch_fq),
-can then lower the default sysctl_tcp_limit_output_bytes value from
-128KB to 8KB.
-
-This new usage of sysctl_tcp_limit_output_bytes permits each driver
-authors to check how their driver performs when/if the value is set
-to a minimum of 4KB.
-
-Normally, line rate for a single TCP flow should be possible,
-but some drivers rely on timers to perform TX completion and
-too long TX completion delays prevent reaching full throughput.
-
-Fixes: c9eeec26e32e ("tcp: TSQ can use a dynamic limit")
-Signed-off-by: Eric Dumazet <edumazet@google.com>
-Reported-by: Sujith Manoharan <sujith@msujith.org>
-Reported-by: Arnaud Ebalard <arno@natisbad.org>
-Tested-by: Sujith Manoharan <sujith@msujith.org>
-Cc: Felix Fietkau <nbd@openwrt.org>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
---- a/Documentation/networking/ip-sysctl.txt
-+++ b/Documentation/networking/ip-sysctl.txt
-@@ -571,9 +571,6 @@ tcp_limit_output_bytes - INTEGER
- typical pfifo_fast qdiscs.
- tcp_limit_output_bytes limits the number of bytes on qdisc
- or device to reduce artificial RTT/cwnd and reduce bufferbloat.
-- Note: For GSO/TSO enabled flows, we try to have at least two
-- packets in flight. Reducing tcp_limit_output_bytes might also
-- reduce the size of individual GSO packet (64KB being the max)
- Default: 131072
-
- tcp_challenge_ack_limit - INTEGER
---- a/net/ipv4/tcp.c
-+++ b/net/ipv4/tcp.c
-@@ -807,12 +807,6 @@ static unsigned int tcp_xmit_size_goal(s
- xmit_size_goal = min_t(u32, gso_size,
- sk->sk_gso_max_size - 1 - hlen);
-
-- /* TSQ : try to have at least two segments in flight
-- * (one in NIC TX ring, another in Qdisc)
-- */
-- xmit_size_goal = min_t(u32, xmit_size_goal,
-- sysctl_tcp_limit_output_bytes >> 1);
--
- xmit_size_goal = tcp_bound_to_half_wnd(tp, xmit_size_goal);
-
- /* We try hard to avoid divides here */
---- a/net/ipv4/tcp_output.c
-+++ b/net/ipv4/tcp_output.c
-@@ -1866,8 +1866,12 @@ static bool tcp_write_xmit(struct sock *
- * - better RTT estimation and ACK scheduling
- * - faster recovery
- * - high rates
-+ * Alas, some drivers / subsystems require a fair amount
-+ * of queued bytes to ensure line rate.
-+ * One example is wifi aggregation (802.11 AMPDU)
- */
-- limit = max(skb->truesize, sk->sk_pacing_rate >> 10);
-+ limit = max_t(unsigned int, sysctl_tcp_limit_output_bytes,
-+ sk->sk_pacing_rate >> 10);
-
- if (atomic_read(&sk->sk_wmem_alloc) > limit) {
- set_bit(TSQ_THROTTLED, &tp->tsq_flags);
diff --git a/target/linux/generic/patches-3.10/100-overlayfs.patch b/target/linux/generic/patches-3.10/100-overlayfs.patch
index 5d1c5f6d38..f8c8aacbcc 100644
--- a/target/linux/generic/patches-3.10/100-overlayfs.patch
+++ b/target/linux/generic/patches-3.10/100-overlayfs.patch
@@ -330,7 +330,7 @@
/**
* sb_permission - Check superblock-level permissions
-@@ -2867,9 +2868,12 @@ finish_open_created:
+@@ -2868,9 +2869,12 @@ finish_open_created:
error = may_open(&nd->path, acc_mode, open_flag);
if (error)
goto out;
diff --git a/target/linux/generic/patches-3.10/630-packet_socket_type.patch b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
index 48a9bb9126..62a81c7c0c 100644
--- a/target/linux/generic/patches-3.10/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
-@@ -1375,6 +1375,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1382,6 +1382,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* When we registered the protocol we saved the socket in the data
-@@ -1382,6 +1383,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1389,6 +1390,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* Yank back the headers [hope the device set this
-@@ -1394,7 +1396,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1401,7 +1403,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1601,12 +1603,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -1608,12 +1610,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -1719,12 +1721,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -1726,12 +1728,12 @@ static int tpacket_rcv(struct sk_buff *s
struct timespec ts;
__u32 ts_status;
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2614,6 +2616,7 @@ static int packet_create(struct net *net
+@@ -2627,6 +2629,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3226,6 +3229,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3237,6 +3240,16 @@ packet_setsockopt(struct socket *sock, i
po->tp_tx_has_off = !!val;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3277,6 +3290,13 @@ static int packet_getsockopt(struct sock
+@@ -3288,6 +3301,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
@@ -124,9 +124,9 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
break;
--- a/net/packet/internal.h
+++ b/net/packet/internal.h
-@@ -114,6 +114,7 @@ struct packet_sock {
- unsigned int tp_tx_has_off:1;
+@@ -115,6 +115,7 @@ struct packet_sock {
unsigned int tp_tstamp;
+ struct net_device __rcu *cached_dev;
struct packet_type prot_hook ____cacheline_aligned_in_smp;
+ unsigned int pkt_type;
};
diff --git a/target/linux/generic/patches-3.10/655-increase_skb_pad.patch b/target/linux/generic/patches-3.10/655-increase_skb_pad.patch
index 590fa1686c..44ab947bd6 100644
--- a/target/linux/generic/patches-3.10/655-increase_skb_pad.patch
+++ b/target/linux/generic/patches-3.10/655-increase_skb_pad.patch
@@ -1,6 +1,6 @@
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -1853,7 +1853,7 @@ static inline int pskb_network_may_pull(
+@@ -1844,7 +1844,7 @@ static inline int pskb_network_may_pull(
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
*/
#ifndef NET_SKB_PAD
diff --git a/target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch b/target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch
index 86b7e1ff3b..9aa96a8670 100644
--- a/target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch
+++ b/target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch
@@ -14,7 +14,7 @@ when needed.
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -1898,6 +1898,24 @@ static inline void pskb_trim_unique(stru
+@@ -1889,6 +1889,24 @@ static inline void pskb_trim_unique(stru
BUG_ON(err);
}
diff --git a/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch b/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
index 7e8e526612..122d23c417 100644
--- a/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
+++ b/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
@@ -127,7 +127,7 @@
static const struct rt6_info ip6_blk_hole_entry_template = {
.dst = {
.__refcnt = ATOMIC_INIT(1),
-@@ -1508,6 +1526,9 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1511,6 +1529,9 @@ int ip6_route_add(struct fib6_config *cf
case RTN_THROW:
rt->dst.error = -EAGAIN;
break;
@@ -137,7 +137,7 @@
default:
rt->dst.error = -ENETUNREACH;
break;
-@@ -2087,6 +2108,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2090,6 +2111,17 @@ static int ip6_pkt_prohibit_out(struct s
return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
}
@@ -155,7 +155,7 @@
#endif
/*
-@@ -2293,7 +2325,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2296,7 +2328,8 @@ static int rtm_to_fib6_config(struct sk_
if (rtm->rtm_type == RTN_UNREACHABLE ||
rtm->rtm_type == RTN_BLACKHOLE ||
rtm->rtm_type == RTN_PROHIBIT ||
@@ -165,7 +165,7 @@
cfg->fc_flags |= RTF_REJECT;
if (rtm->rtm_type == RTN_LOCAL)
-@@ -2495,6 +2528,9 @@ static int rt6_fill_node(struct net *net
+@@ -2498,6 +2531,9 @@ static int rt6_fill_node(struct net *net
case -EACCES:
rtm->rtm_type = RTN_PROHIBIT;
break;
@@ -175,7 +175,7 @@
case -EAGAIN:
rtm->rtm_type = RTN_THROW;
break;
-@@ -2745,6 +2781,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2748,6 +2784,8 @@ static int ip6_route_dev_notify(struct n
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -184,7 +184,7 @@
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
#endif
-@@ -3005,6 +3043,17 @@ static int __net_init ip6_route_net_init
+@@ -3008,6 +3046,17 @@ static int __net_init ip6_route_net_init
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
ip6_template_metrics, true);
@@ -202,7 +202,7 @@
#endif
net->ipv6.sysctl.flush_delay = 0;
-@@ -3023,6 +3072,8 @@ out:
+@@ -3026,6 +3075,8 @@ out:
return ret;
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -211,7 +211,7 @@
out_ip6_prohibit_entry:
kfree(net->ipv6.ip6_prohibit_entry);
out_ip6_null_entry:
-@@ -3040,6 +3091,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3043,6 +3094,7 @@ static void __net_exit ip6_route_net_exi
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
kfree(net->ipv6.ip6_prohibit_entry);
kfree(net->ipv6.ip6_blk_hole_entry);
@@ -219,7 +219,7 @@
#endif
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
}
-@@ -3136,6 +3188,9 @@ int __init ip6_route_init(void)
+@@ -3139,6 +3191,9 @@ int __init ip6_route_init(void)
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
diff --git a/target/linux/generic/patches-3.10/721-phy_packets.patch b/target/linux/generic/patches-3.10/721-phy_packets.patch
index f678ef42e2..7d51ae70ff 100644
--- a/target/linux/generic/patches-3.10/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.10/721-phy_packets.patch
@@ -34,7 +34,7 @@
#define IF_GET_IFACE 0x0001 /* for querying only */
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -1883,6 +1883,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -1874,6 +1874,10 @@ static inline int pskb_trim(struct sk_bu
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
}
@@ -45,7 +45,7 @@
/**
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
* @skb: buffer to alter
-@@ -2007,16 +2011,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -1998,16 +2002,6 @@ static inline struct sk_buff *dev_alloc_
}
diff --git a/target/linux/generic/patches-3.10/902-debloat_proc.patch b/target/linux/generic/patches-3.10/902-debloat_proc.patch
index fd50eb1a28..dc2a923989 100644
--- a/target/linux/generic/patches-3.10/902-debloat_proc.patch
+++ b/target/linux/generic/patches-3.10/902-debloat_proc.patch
@@ -133,7 +133,7 @@
}
--- a/mm/vmstat.c
+++ b/mm/vmstat.c
-@@ -1241,10 +1241,12 @@ static int __init setup_vmstat(void)
+@@ -1242,10 +1242,12 @@ static int __init setup_vmstat(void)
start_cpu_timer(cpu);
#endif
#ifdef CONFIG_PROC_FS
@@ -285,7 +285,7 @@
" key shmid perms size cpid lpid nattch uid gid cuid cgid atime dtime ctime rss swap\n",
--- a/ipc/util.c
+++ b/ipc/util.c
-@@ -158,6 +158,9 @@ void __init ipc_init_proc_interface(cons
+@@ -173,6 +173,9 @@ void __init ipc_init_proc_interface(cons
struct proc_dir_entry *pde;
struct ipc_proc_iface *iface;
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index e8d558e2c0..794a709b77 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 4538d7813a..39b7cc746c 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/kirkwood/Makefile b/target/linux/kirkwood/Makefile
index 1861243996..0b44512642 100644
--- a/target/linux/kirkwood/Makefile
+++ b/target/linux/kirkwood/Makefile
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand ubifs
CPU_TYPE:=xscale
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 8a7f88d5ce..6a698c6ad4 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs
SUBTARGETS=xway xrx200 ase falcon
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
CPU_TYPE:=mips32r2
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 2b7dff84a2..4470bde3d3 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
DEVICE_TYPE:=developerboard
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 2f4bcc92d1..7b375d6075 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic p1020
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index d6d2d54e2f..de109de35e 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 7fd54a9c8b..420c5c7226 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
CPU_CFLAGS_octeon:=-march=octeon
MAINTAINER:=John Crispin <blogic@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 03efd28f1b..c8860c5a95 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CPU_TYPE:=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 49b6696625..5c98bc43d8 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
CPU_TYPE:=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index ad3f690a88..a2f6156575 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
FEATURES:=squashfs gpio
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index fb39dbc6f2..97ca176825 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=pci targz broken
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 61cf3eb01b..8521052c10 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
CPU_SUBTYPE:=vfp
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
DEVICE_TYPE:=developerboard
diff --git a/target/linux/sparc/Makefile b/target/linux/sparc/Makefile
index d838059dcc..b0d70cbdd0 100644
--- a/target/linux/sparc/Makefile
+++ b/target/linux/sparc/Makefile
@@ -11,7 +11,7 @@ BOARD:=sparc
BOARDNAME:=Sun UltraSPARC
FEATURES+=fpu tgz ext4 squashfs broken
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index b6744b0abd..adb34a6004 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
CS5535_MASK:=0x0b000042
CPU_TYPE := geode
diff --git a/target/linux/x86/generic/target.mk b/target/linux/x86/generic/target.mk
index b4eab5e0cf..72b970e4a0 100644
--- a/target/linux/x86/generic/target.mk
+++ b/target/linux/x86/generic/target.mk
@@ -1,6 +1,6 @@
BOARDNAME:=Generic
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
define Target/Description
Build firmware images for x86 based boards
diff --git a/target/linux/x86/patches-3.10/100-rdc_boards.patch b/target/linux/x86/patches-3.10/100-rdc_boards.patch
index 197b5dbdbc..6b8fe6c24a 100644
--- a/target/linux/x86/patches-3.10/100-rdc_boards.patch
+++ b/target/linux/x86/patches-3.10/100-rdc_boards.patch
@@ -1,6 +1,6 @@
--- a/arch/x86/Makefile
+++ b/arch/x86/Makefile
-@@ -168,6 +168,9 @@ libs-y += arch/x86/lib/
+@@ -174,6 +174,9 @@ libs-y += arch/x86/lib/
# See arch/x86/Kbuild for content of core part of the kernel
core-y += arch/x86/
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 717298b8c9..cf4a542b49 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=3.10.21
+LINUX_VERSION:=3.10.24
DEVICE_TYPE=other