summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 12:19:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 12:19:57 +0000
commit904ffa32d8f25a2e8a6b7a29eb7d2eb7cf30391d (patch)
tree40d0add7714c59c62e63b0dfcdf8145bcb997cdd /target
parent2f5694398d4d5bd6634aa8c49eeb0035c723c234 (diff)
downloadmaster-31e0f0ae-904ffa32d8f25a2e8a6b7a29eb7d2eb7cf30391d.tar.gz
master-31e0f0ae-904ffa32d8f25a2e8a6b7a29eb7d2eb7cf30391d.tar.bz2
master-31e0f0ae-904ffa32d8f25a2e8a6b7a29eb7d2eb7cf30391d.zip
ar71xx: image: simplify mynet_n600_mtdlayout
Remove the kernel and rootfs partitions. The Seama parser can find those automatically: 0x000000070000-0x000000ff0000 : "firmware" 2 seama-fw partitions found on MTD device firmware 0x000000070000-0x0000001b0000 : "kernel" 0x0000001b0000-0x000000ff0000 : "rootfs" mtd: partition "rootfs" set to be root filesystem 1 squashfs-split partitions found on MTD device rootfs 0x000000360000-0x000000ff0000 : "rootfs_data" 0x000000ff0000-0x000001000000 : "radiocfg" Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38155
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 139abe2d9c..d4d7da92b7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -200,7 +200,7 @@ wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,7680k(firmw
wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,15872k(firmware),64k(art)ro
wndr4300_mtdlayout=mtdparts=ar934x-nfc:256k(u-boot)ro,256k(u-boot-env)ro,256k(caldata),512k(pot),2048k(language),512k(config),3072k(traffic_meter),1152k(kernel),24448k(rootfs),25600k@0x6c0000(firmware),256k(caldata_backup),-(reserved)
zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
-mynet_n600_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,64k(devdata)ro,64k(devconf)ro,1280k(kernel),14592k(rootfs),64k(radiocfg)ro,15872k@0x70000(firmware)
+mynet_n600_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,64k(devdata)ro,64k(devconf)ro,15872k(firmware),64k(radiocfg)ro
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(VMLINUX).elf