summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-04 08:28:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-04 08:28:20 +0000
commit86494323fe2fa4cd6b2a76a7b4b31ef01b0c7d5f (patch)
treecddf8dd8c23d272f7ecc3d4c499a3ca83a73250c /target
parentfe348a7039854bc3cdcfc0c2953b884c6c2c79ce (diff)
downloadmaster-31e0f0ae-86494323fe2fa4cd6b2a76a7b4b31ef01b0c7d5f.tar.gz
master-31e0f0ae-86494323fe2fa4cd6b2a76a7b4b31ef01b0c7d5f.tar.bz2
master-31e0f0ae-86494323fe2fa4cd6b2a76a7b4b31ef01b0c7d5f.zip
rework reboot mechanism with the new watchdog fixes
The fixing of the watchdog driver makes it generate a NMI so the reboot_fixup can no longer be called from NMI context, instead, override the machine_retart callback with our southrbridge reboot mechanism. Patch by Bernhard Loos. SVN-Revision: 19977
Diffstat (limited to 'target')
-rw-r--r--target/linux/rdc/config-2.6.302
-rw-r--r--target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/Makefile2
-rw-r--r--target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/reboot.c44
3 files changed, 46 insertions, 2 deletions
diff --git a/target/linux/rdc/config-2.6.30 b/target/linux/rdc/config-2.6.30
index 9f4ce72615..0788d55623 100644
--- a/target/linux/rdc/config-2.6.30
+++ b/target/linux/rdc/config-2.6.30
@@ -280,7 +280,7 @@ CONFIG_X86_MINIMUM_CPU_FAMILY=4
CONFIG_X86_POPAD_OK=y
# CONFIG_X86_PPRO_FENCE is not set
CONFIG_X86_RDC321X=y
-CONFIG_X86_REBOOTFIXUPS=y
+# CONFIG_X86_REBOOTFIXUPS is not set
# CONFIG_X86_RESERVE_LOW_64K is not set
# CONFIG_X86_UP_APIC is not set
# CONFIG_X86_VERBOSE_BOOTUP is not set
diff --git a/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/Makefile b/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/Makefile
index 15f2739eaf..21d8879238 100644
--- a/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/Makefile
+++ b/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/Makefile
@@ -1,5 +1,5 @@
#
# Makefile for the RDC321x specific parts of the kernel
#
-obj-$(CONFIG_X86_RDC321X) := gpio.o platform.o pci.o
+obj-$(CONFIG_X86_RDC321X) := gpio.o platform.o pci.o reboot.o
diff --git a/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/reboot.c b/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/reboot.c
new file mode 100644
index 0000000000..2dacfefb21
--- /dev/null
+++ b/target/linux/rdc/files-2.6.30/arch/x86/mach-rdc321x/reboot.c
@@ -0,0 +1,44 @@
+/*
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+ * Boston, MA 02110-1301, USA.
+ *
+ */
+
+#include <asm/reboot.h>
+#include <asm/io.h>
+
+static void rdc321x_reset(void)
+{
+ unsigned i;
+
+ /* write to southbridge config register 0x41
+ enable pci reset on cpu reset, make internal port 0x92 writeable
+ and switch port 0x92 to internal */
+ outl(0x80003840, 0xCF8);
+ i = inl(0xCFC);
+ i |= 0x1600;
+ outl(i, 0xCFC);
+
+ /* soft reset */
+ outb(1, 0x92);
+}
+
+static int __init rdc_setup_reset(void)
+{
+ machine_ops.emergency_restart = rdc321x_reset;
+ return 0;
+}
+
+arch_initcall(rdc_setup_reset);