summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 14:45:25 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 14:45:25 +0000
commit85b889940d66b4c4a28691d8166eeef119912473 (patch)
tree570070176a432fa398fcd9e5b57663ab6c19f5fc /target
parent599ddc7a85dd3906b1022036657e4ad86df16dad (diff)
downloadmaster-31e0f0ae-85b889940d66b4c4a28691d8166eeef119912473.tar.gz
master-31e0f0ae-85b889940d66b4c4a28691d8166eeef119912473.tar.bz2
master-31e0f0ae-85b889940d66b4c4a28691d8166eeef119912473.zip
ar71xx: add support to TP-LINK TL-WA730RE v1
The TL-WA730RE seems to be almost identical to TL-WA701ND, just that it comes without PoE and a stock-firmware claiming the device to be a "Range Extender". Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 40972
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk9
-rw-r--r--target/linux/ar71xx/image/Makefile2
3 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 7a285f21cb..2fbef9653e 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -106,6 +106,9 @@ tplink_board_detect() {
"070100"*)
model="TP-Link TL-WA701N/ND"
;;
+ "073000"*)
+ model="TP-Link TL-WA730RE"
+ ;;
"074000"*)
model="TP-Link TL-WR740N/ND"
;;
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index aaf581b95c..5bd2cf68a0 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -139,6 +139,15 @@ define Profile/TLWA701/Description
endef
$(eval $(call Profile,TLWA701))
+define Profile/TLWA730RE
+ NAME:=TP-LINK TL-WA730RE
+ PACKAGES:=
+endef
+
+define Profile/TLWA730RE/Description
+ Package set optimized for the TP-LINK TL-WA730RE.
+endef
+$(eval $(call Profile,TLWA730RE))
define Profile/TLWA750
NAME:=TP-LINK TL-WA750RE
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8da2095eda..38f9e72a20 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1092,6 +1092,7 @@ $(eval $(call SingleProfile,TPLINK,64kraw,RNXN360RT,rnx-n360rt,TL-WR941ND,ttyS0,
$(eval $(call SingleProfile,TPLINK,64kraw,TLMR3220V1,tl-mr3220-v1,TL-MR3220,ttyS0,115200,0x32200001,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLMR3420V1,tl-mr3420-v1,TL-MR3420,ttyS0,115200,0x34200001,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLWA701,tl-wa701n-v1,TL-WA901ND,ttyS0,115200,0x07010001,1,4M))
+$(eval $(call SingleProfile,TPLINK,64kraw,TLWA730REV1,tl-wa730rev1,TL-WA901ND,ttyS0,115200,0x07300001,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLWA7510NV1,tl-wa7510n,TL-WA7510N,ttyS0,115200,0x75100001,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLWA801NV1,tl-wa801nd-v1,TL-WA901ND,ttyS0,115200,0x08010001,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLWA830RV1,tl-wa830re-v1,TL-WA901ND,ttyS0,115200,0x08300010,1,4M))
@@ -1193,6 +1194,7 @@ $(eval $(call MultiProfile,TLMR11U,TLMR11UV1 TLMR11UV2))
$(eval $(call MultiProfile,TLMR3040,TLMR3040V1 TLMR3040V2))
$(eval $(call MultiProfile,TLMR3220,TLMR3220V1 TLMR3220V2))
$(eval $(call MultiProfile,TLMR3420,TLMR3420V1 TLMR3420V2))
+$(eval $(call MultiProfile,TLWA730RE,TLWA730REV1))
$(eval $(call MultiProfile,TLWA801,TLWA801NV1 TLWA801NV2))
$(eval $(call MultiProfile,TLWA830,TLWA830RV1))
$(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2 TLWA901NV3))