summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:43 +0000
commit846b8593fc2b9ab6fc03a4407f2146ac9396fb51 (patch)
tree2d97f5fc9ba0f376f79a551100d64b5922caea0b /target
parentae7e7239b864c00b1e6c8b7856f1770a56c38c29 (diff)
downloadmaster-31e0f0ae-846b8593fc2b9ab6fc03a4407f2146ac9396fb51.tar.gz
master-31e0f0ae-846b8593fc2b9ab6fc03a4407f2146ac9396fb51.tar.bz2
master-31e0f0ae-846b8593fc2b9ab6fc03a4407f2146ac9396fb51.zip
ar71xx: add support for the TP-LINK TL-WR1043ND v3
The hardware of the v3 is identical to the v2. Based-on-patch-by: Andreas Ziegler <github@andreas-ziegler.de> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 47406
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 29e5064909..09e5394fd9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -804,7 +804,14 @@ define Device/tl-wr1043nd-v2
DEVICE_PROFILE := TLWR1043
TPLINK_HWID := 0x10430002
endef
-TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2
+
+define Device/tl-wr1043nd-v3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := TL-WR1043ND-v2
+ DEVICE_PROFILE := TLWR1043
+ TPLINK_HWID := 0x10430003
+endef
+TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2 tl-wr1043nd-v3
define Device/tl-wr2543-v1
$(Device/tplink-8mlzma)