summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:46 +0000
commit83b7462ac918f8a8cc2c529086802a0843212aef (patch)
tree9d7aead7f132aa2e1ad61c807bb5b7e7372cd32e /target
parent584bc13d38bb088181aa82d602d386b91907405a (diff)
downloadmaster-31e0f0ae-83b7462ac918f8a8cc2c529086802a0843212aef.tar.gz
master-31e0f0ae-83b7462ac918f8a8cc2c529086802a0843212aef.tar.bz2
master-31e0f0ae-83b7462ac918f8a8cc2c529086802a0843212aef.zip
package cobalt lcd as a module
SVN-Revision: 32840
Diffstat (limited to 'target')
-rw-r--r--target/linux/cobalt/config-3.37
-rw-r--r--target/linux/cobalt/modules.mk21
2 files changed, 21 insertions, 7 deletions
diff --git a/target/linux/cobalt/config-3.3 b/target/linux/cobalt/config-3.3
index c29540eb9c..ccc5839513 100644
--- a/target/linux/cobalt/config-3.3
+++ b/target/linux/cobalt/config-3.3
@@ -45,13 +45,6 @@ CONFIG_DUMMY_CONSOLE=y
CONFIG_EARLY_PRINTK=y
CONFIG_ELF_CORE=y
CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_FB=y
-CONFIG_FB_COBALT=y
-# CONFIG_FB_SM7XX is not set
-# CONFIG_FB_WMT_GE_ROPS is not set
-# CONFIG_FB_XGI is not set
-# CONFIG_FIRMWARE_EDID is not set
-CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_FS_POSIX_ACL=y
CONFIG_GENERIC_ACL=y
CONFIG_GENERIC_CLOCKEVENTS=y
diff --git a/target/linux/cobalt/modules.mk b/target/linux/cobalt/modules.mk
new file mode 100644
index 0000000000..fcba757312
--- /dev/null
+++ b/target/linux/cobalt/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/fb-cobalt
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=Cobalt framebuffer support
+ DEPENDS:=@TARGET_cobalt +kmod-fb
+ KCONFIG:=CONFIG_FB_COBALT
+ FILES:=$(LINUX_DIR)/drivers/video/cobalt_lcdfb.ko
+ AUTOLOAD:=$(call AutoLoad,50,cobalt_lcdfb)
+endef
+
+define KernelPackage/fb-cobalt/descriptione
+ Kernel module for the Cobalt Microservers framebuffer
+endef
+
+$(eval $(call KernelPackage,fb-cobalt))