summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2010-08-06 20:21:32 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2010-08-06 20:21:32 +0000
commit7640f8904590b4810ef7a104fd69fc5b35caee4e (patch)
tree8d7efe4112b89513a927a527cdfe8d5c42a824a1 /target
parent419128775a76ef97e344462212b1a646a07e08a5 (diff)
downloadmaster-31e0f0ae-7640f8904590b4810ef7a104fd69fc5b35caee4e.tar.gz
master-31e0f0ae-7640f8904590b4810ef7a104fd69fc5b35caee4e.tar.bz2
master-31e0f0ae-7640f8904590b4810ef7a104fd69fc5b35caee4e.zip
brcm47xx: Add new image generation and fix leds/reset button on WNR834B V2
Thank you realopty for the patch. tools/firmware-utils/src/mkchkimg.c is from http://www.myopenrouter.com/download/10611/mkchkimg/ This closes #7702. SVN-Revision: 22516
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm47xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 69a31e7554..daee392da9 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -98,6 +98,10 @@ define Image/Build/Initramfs
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/$(IMG_PREFIX)-initramfs.trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma
endef
+define Image/Build/Chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(5).chk -k $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -b $(3) -r $(4)
+endef
+
define Image/Build
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx \
-f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma \
@@ -105,6 +109,8 @@ define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Motorola,$(1),wr850g,1,$(1))
$(call Image/Build/USR,$(1),usr5461,$(1))
+ $(call Image/Build/Chk,$(1),wnr834b_v2,U12H081T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/Chk,$(1),wgr614_v8,U12H072T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
endef
$(eval $(call BuildImage))