summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-05 20:55:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-05 20:55:21 +0000
commit72823077cdabdb6b3432a254d413000d00630634 (patch)
tree066601b192a8c03efa0c1f613b7a98f12648b9b1 /target
parent40f74f411d890de64200dfe8eaffb1332e7cc2e6 (diff)
downloadmaster-31e0f0ae-72823077cdabdb6b3432a254d413000d00630634.tar.gz
master-31e0f0ae-72823077cdabdb6b3432a254d413000d00630634.tar.bz2
master-31e0f0ae-72823077cdabdb6b3432a254d413000d00630634.zip
add support for jffs2 filesystems with 256k blocksize, fix taishan support
SVN-Revision: 7506
Diffstat (limited to 'target')
-rw-r--r--target/linux/amcc-2.6/Makefile2
-rw-r--r--target/linux/amcc-2.6/image/Makefile7
2 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/amcc-2.6/Makefile b/target/linux/amcc-2.6/Makefile
index 935e639a53..58d739df10 100644
--- a/target/linux/amcc-2.6/Makefile
+++ b/target/linux/amcc-2.6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=powerpc
BOARD:=amcc
BOARDNAME:=AMCC Taishan
-FEATURES:=squashfs broken
+FEATURES:=jffs2
define Target/Description
Build firmware images for the AMCC Taishan evaluation board
diff --git a/target/linux/amcc-2.6/image/Makefile b/target/linux/amcc-2.6/image/Makefile
index bab2e647ee..bd391f02f2 100644
--- a/target/linux/amcc-2.6/image/Makefile
+++ b/target/linux/amcc-2.6/image/Makefile
@@ -19,6 +19,13 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/jffs2-256k
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-jffs2.img
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \