summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-21 01:16:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-21 01:16:34 +0000
commit70bf92d03c3afad25f131c74e58b1257027eddbe (patch)
tree858890b9479b0326fc2d7362a730e5d668ce1939 /target
parent54d622a81572a18927c4bb907dd41fde6ff358c8 (diff)
downloadmaster-31e0f0ae-70bf92d03c3afad25f131c74e58b1257027eddbe.tar.gz
master-31e0f0ae-70bf92d03c3afad25f131c74e58b1257027eddbe.tar.bz2
master-31e0f0ae-70bf92d03c3afad25f131c74e58b1257027eddbe.zip
Generate suitable images for the UBNT PicoStation2
SVN-Revision: 15314
Diffstat (limited to 'target')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 73657334ee..e2f6315705 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -35,6 +35,12 @@ define Image/Build
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+ -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-8-$(1).bin
+
-$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
-p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz \
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \