summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-06-23 05:21:50 +0000
committerLuka Perkov <luka@openwrt.org>2015-06-23 05:21:50 +0000
commit6de9aeee35c67b993ec9f6f8321391219995e2c2 (patch)
tree6bb161b0f5bff0f128f9b47d78f43878f5c0ed36 /target
parent2e07e23a60dc9a38c085a342523797470d1e5568 (diff)
downloadmaster-31e0f0ae-6de9aeee35c67b993ec9f6f8321391219995e2c2.tar.gz
master-31e0f0ae-6de9aeee35c67b993ec9f6f8321391219995e2c2.tar.bz2
master-31e0f0ae-6de9aeee35c67b993ec9f6f8321391219995e2c2.zip
ar71xx: add support for tp-link wr740n v5.0 (EU)
TP-Link ships wr740n v5.0 to Romania (so probably everywhere except China) with 4 MB flash and 32 MB memory (confirmed by their local support). This patch adds support for the v5.0 clone of v4, i just tested it on my own v5.0 router and it works. Signed-off-by: Daniel Petre <daniel.petre@posteo.net> SVN-Revision: 46115
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1d860f91f8..3956927ce4 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -510,6 +510,14 @@ define Device/tl-wr740n-v4
CONSOLE := ttyATH0,115200
endef
+define Device/tl-wr740n-v5
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR741ND-v4
+ DEVICE_PROFILE := TLWR740
+ TPLINK_HWID := 0x07400005
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/tl-wr741nd-v1
$(Device/tplink-4m)
BOARDNAME := TL-WR741ND
@@ -539,7 +547,7 @@ define Device/tl-wr743nd-v2
TPLINK_HWID := 0x07430002
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
define Device/tl-wr841n-v8
$(Device/tplink-4mlzma)