summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-28 09:28:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-28 09:28:25 +0000
commit6d2fa1c89648d9492714ca54c394e022af61adf6 (patch)
treef03fac64cf9ec97b16cbebc9184daad591dab62e /target
parentbd4bec689d27485ec83a45ccd08a3107424ef6f0 (diff)
downloadmaster-31e0f0ae-6d2fa1c89648d9492714ca54c394e022af61adf6.tar.gz
master-31e0f0ae-6d2fa1c89648d9492714ca54c394e022af61adf6.tar.bz2
master-31e0f0ae-6d2fa1c89648d9492714ca54c394e022af61adf6.zip
ar71xx: create images for the WNDR3700, which can be flashed via the factory web interface
SVN-Revision: 18571
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4c88a85e64..04629ffd54 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -241,6 +241,10 @@ define Image/Build/WNDR3700
dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1M conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B WNDR3700 -v OpenWrt.$(REVISION) \
+ -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+ -o $(call imgname,$(1),$(2))-factory.bin
endef
define Image/Build/Template/Compex