summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-22 15:30:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-22 15:30:56 +0000
commit6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322 (patch)
treec509094fab78eeabacde97824507826b776d48a7 /target
parent06a27059bd238abfc0310c50cb59e997ec208798 (diff)
downloadmaster-31e0f0ae-6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322.tar.gz
master-31e0f0ae-6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322.tar.bz2
master-31e0f0ae-6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322.zip
kernel: update 3.9 to 3.9.11
Also refresh 3.9 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37501
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/gemini/Makefile2
-rw-r--r--target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch4
-rw-r--r--target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch8
5 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index 1ee72ae4e9..f4bac3c6d8 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index c2cbdf6c36..e76e152f0f 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
SUBTARGETS:=generic smp
FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index daa46889a3..f0e802dba8 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs pci
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.9.10
+LINUX_VERSION:=3.9.11
KERNELNAME:="zImage"
diff --git a/target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch b/target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch
index 986b3f843b..64a980ebdd 100644
--- a/target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch
+++ b/target/linux/generic/patches-3.9/644-bridge_optimize_netfilter_hooks.patch
@@ -48,8 +48,8 @@
return RX_HANDLER_CONSUMED; /* consumed by filter */
} else {
@@ -224,7 +224,7 @@ forward:
- if (!ether_addr_equal(p->br->dev->dev_addr, dest))
- goto drop;
+ if (ether_addr_equal(p->br->dev->dev_addr, dest))
+ skb->pkt_type = PACKET_HOST;
- if (NF_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
+ if (BR_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
diff --git a/target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch b/target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch
index adf34c9b19..6d1b22259a 100644
--- a/target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch
+++ b/target/linux/lantiq/patches-3.9/0010-NET-MIPS-lantiq-update-etop-driver-for-devicetree.patch
@@ -276,17 +276,17 @@ Subject: [PATCH 10/22] NET: MIPS: lantiq: update etop driver for devicetree
struct ltq_etop_priv *priv = netdev_priv(dev);
- int i;
+ int mii_mode = priv->mii_mode;
-+
-+ clk_enable(priv->clk_ppe);
- ltq_pmu_enable(PMU_PPE);
++ clk_enable(priv->clk_ppe);
+
+- switch (priv->pldata->mii_mode) {
+ if (of_machine_is_compatible("lantiq,ar9")) {
+ ltq_etop_gbit_init(dev);
+ /* force the etops link to the gbit to MII */
+ mii_mode = PHY_INTERFACE_MODE_MII;
+ }
-
-- switch (priv->pldata->mii_mode) {
++
+ switch (mii_mode) {
case PHY_INTERFACE_MODE_RMII:
ltq_etop_w32_mask(ETOP_MII_MASK,