summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-02-08 15:09:45 +0000
committerLuka Perkov <luka@openwrt.org>2015-02-08 15:09:45 +0000
commit683da1384bc567d1a29544ca98f56dea4542cb3c (patch)
tree206e0e80e66a93e8eee961cde4eaf207a413a060 /target
parent7294b892dcc5e28a5180d6e9bb3fa9bb08e29493 (diff)
downloadmaster-31e0f0ae-683da1384bc567d1a29544ca98f56dea4542cb3c.tar.gz
master-31e0f0ae-683da1384bc567d1a29544ca98f56dea4542cb3c.tar.bz2
master-31e0f0ae-683da1384bc567d1a29544ca98f56dea4542cb3c.zip
lantiq: fix patches after 3.14.32 bump
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 44320
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/patches-3.14/0001-MIPS-lantiq-add-pcie-driver.patch2
-rw-r--r--target/linux/lantiq/patches-3.14/0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch2
-rw-r--r--target/linux/lantiq/patches-3.14/0012-pinctrl-lantiq-fix-up-pinmux.patch2
-rw-r--r--target/linux/lantiq/patches-3.14/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch4
-rw-r--r--target/linux/lantiq/patches-3.14/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch8
-rw-r--r--target/linux/lantiq/patches-3.14/0026-NET-multi-phy-support.patch6
-rw-r--r--target/linux/lantiq/patches-3.14/0028-NET-lantiq-various-etop-fixes.patch12
-rw-r--r--target/linux/lantiq/patches-3.14/0030-GPIO-add-named-gpio-exports.patch18
-rw-r--r--target/linux/lantiq/patches-3.14/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch54
-rw-r--r--target/linux/lantiq/patches-3.14/0038-MIPS-lantiq-fpi-on-ar9.patch6
10 files changed, 49 insertions, 65 deletions
diff --git a/target/linux/lantiq/patches-3.14/0001-MIPS-lantiq-add-pcie-driver.patch b/target/linux/lantiq/patches-3.14/0001-MIPS-lantiq-add-pcie-driver.patch
index 35bc54879e..f73fab6672 100644
--- a/target/linux/lantiq/patches-3.14/0001-MIPS-lantiq-add-pcie-driver.patch
+++ b/target/linux/lantiq/patches-3.14/0001-MIPS-lantiq-add-pcie-driver.patch
@@ -5516,7 +5516,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
(AER) driver support. Error reporting messages sent to Root
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
-@@ -1121,6 +1121,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1123,6 +1123,8 @@ void pci_walk_bus(struct pci_bus *top, i
void *userdata);
int pci_cfg_space_size(struct pci_dev *dev);
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
diff --git a/target/linux/lantiq/patches-3.14/0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch b/target/linux/lantiq/patches-3.14/0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch
index 55d8824999..7a0e1c3e91 100644
--- a/target/linux/lantiq/patches-3.14/0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch
+++ b/target/linux/lantiq/patches-3.14/0011-lantiq-add-support-for-xrx200-firmware-depending-on-.patch
@@ -14,7 +14,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
--- a/arch/mips/lantiq/xway/xrx200_phy_fw.c
+++ b/arch/mips/lantiq/xway/xrx200_phy_fw.c
-@@ -24,7 +24,23 @@ static dma_addr_t xway_gphy_load(struct
+@@ -24,7 +24,23 @@ static dma_addr_t xway_gphy_load(struct
void *fw_addr;
size_t size;
diff --git a/target/linux/lantiq/patches-3.14/0012-pinctrl-lantiq-fix-up-pinmux.patch b/target/linux/lantiq/patches-3.14/0012-pinctrl-lantiq-fix-up-pinmux.patch
index 6a5a260742..ecd143f91f 100644
--- a/target/linux/lantiq/patches-3.14/0012-pinctrl-lantiq-fix-up-pinmux.patch
+++ b/target/linux/lantiq/patches-3.14/0012-pinctrl-lantiq-fix-up-pinmux.patch
@@ -24,7 +24,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
int port = PORT(pin);
u32 alt1_reg = GPIO_ALT1(pin);
-@@ -632,6 +631,14 @@ static inline int xway_mux_apply(struct
+@@ -632,6 +631,14 @@ static inline int xway_mux_apply(struct
return 0;
}
diff --git a/target/linux/lantiq/patches-3.14/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch b/target/linux/lantiq/patches-3.14/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
index 8ebdc99878..4c010f8282 100644
--- a/target/linux/lantiq/patches-3.14/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
+++ b/target/linux/lantiq/patches-3.14/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -1105,6 +1105,10 @@ static int m25p_probe(struct spi_device
+@@ -1105,6 +1105,10 @@ static int m25p_probe(struct spi_device
struct mtd_part_parser_data ppdata;
struct device_node *np = spi->dev.of_node;
int ret;
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* Platform data helps sort out which chip type we have, as
* well as how this board partitions it. If we don't have
-@@ -1177,6 +1181,8 @@ static int m25p_probe(struct spi_device
+@@ -1177,6 +1181,8 @@ static int m25p_probe(struct spi_device
if (data && data->name)
flash->mtd.name = data->name;
diff --git a/target/linux/lantiq/patches-3.14/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch b/target/linux/lantiq/patches-3.14/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
index 3f53bf808f..a60166e38e 100644
--- a/target/linux/lantiq/patches-3.14/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
+++ b/target/linux/lantiq/patches-3.14/0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -157,6 +157,11 @@ config MICREL_PHY
- ---help---
- Currently has a driver for the KSZ8041
+@@ -152,6 +152,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+config LANTIQ_PHY
+ tristate "Driver for Lantiq PHYs"
@@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_DP83640_PHY) += dp83640.o
obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
diff --git a/target/linux/lantiq/patches-3.14/0026-NET-multi-phy-support.patch b/target/linux/lantiq/patches-3.14/0026-NET-multi-phy-support.patch
index 3bd2419daf..1601015a45 100644
--- a/target/linux/lantiq/patches-3.14/0026-NET-multi-phy-support.patch
+++ b/target/linux/lantiq/patches-3.14/0026-NET-multi-phy-support.patch
@@ -21,7 +21,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
phydev->adjust_link(phydev->attached_dev);
break;
}
-@@ -830,7 +831,8 @@ void phy_state_machine(struct work_struc
+@@ -841,7 +842,8 @@ void phy_state_machine(struct work_struc
netif_carrier_on(phydev->attached_dev);
} else {
phydev->state = PHY_NOLINK;
@@ -31,7 +31,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
phydev->adjust_link(phydev->attached_dev);
-@@ -842,7 +844,8 @@ void phy_state_machine(struct work_struc
+@@ -853,7 +855,8 @@ void phy_state_machine(struct work_struc
case PHY_HALTED:
if (phydev->link) {
phydev->link = 0;
@@ -39,7 +39,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ if (!phydev->no_auto_carrier_off)
+ netif_carrier_off(phydev->attached_dev);
phydev->adjust_link(phydev->attached_dev);
- do_suspend = 1;
+ do_suspend = true;
}
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
diff --git a/target/linux/lantiq/patches-3.14/0028-NET-lantiq-various-etop-fixes.patch b/target/linux/lantiq/patches-3.14/0028-NET-lantiq-various-etop-fixes.patch
index 7f737fab1a..6e3a03a498 100644
--- a/target/linux/lantiq/patches-3.14/0028-NET-lantiq-various-etop-fixes.patch
+++ b/target/linux/lantiq/patches-3.14/0028-NET-lantiq-various-etop-fixes.patch
@@ -265,7 +265,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
return IRQ_HANDLED;
}
-@@ -224,7 +301,7 @@ ltq_etop_free_channel(struct net_device
+@@ -224,7 +301,7 @@ ltq_etop_free_channel(struct net_device
ltq_dma_free(&ch->dma);
if (ch->dma.irq)
free_irq(ch->dma.irq, priv);
@@ -442,7 +442,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
static void
-@@ -309,7 +454,10 @@ ltq_etop_get_settings(struct net_device
+@@ -309,7 +454,10 @@ ltq_etop_get_settings(struct net_device
{
struct ltq_etop_priv *priv = netdev_priv(dev);
@@ -454,7 +454,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
static int
-@@ -317,7 +465,10 @@ ltq_etop_set_settings(struct net_device
+@@ -317,7 +465,10 @@ ltq_etop_set_settings(struct net_device
{
struct ltq_etop_priv *priv = netdev_priv(dev);
@@ -675,7 +675,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
return 0;
}
-@@ -520,16 +716,16 @@ ltq_etop_tx(struct sk_buff *skb, struct
+@@ -520,16 +716,16 @@ ltq_etop_tx(struct sk_buff *skb, struct
int queue = skb_get_queue_mapping(skb);
struct netdev_queue *txq = netdev_get_tx_queue(dev, queue);
struct ltq_etop_priv *priv = netdev_priv(dev);
@@ -697,7 +697,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
netdev_err(dev, "tx ring full\n");
netif_tx_stop_queue(txq);
return NETDEV_TX_BUSY;
-@@ -537,7 +733,7 @@ ltq_etop_tx(struct sk_buff *skb, struct
+@@ -537,7 +733,7 @@ ltq_etop_tx(struct sk_buff *skb, struct
/* dma needs to start on a 16 byte aligned address */
byte_offset = CPHYSADDR(skb->data) % 16;
@@ -706,7 +706,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
dev->trans_start = jiffies;
-@@ -547,11 +743,11 @@ ltq_etop_tx(struct sk_buff *skb, struct
+@@ -547,11 +743,11 @@ ltq_etop_tx(struct sk_buff *skb, struct
wmb();
desc->ctl = LTQ_DMA_OWN | LTQ_DMA_SOP | LTQ_DMA_EOP |
LTQ_DMA_TX_OFFSET(byte_offset) | (len & LTQ_DMA_SIZE_MASK);
diff --git a/target/linux/lantiq/patches-3.14/0030-GPIO-add-named-gpio-exports.patch b/target/linux/lantiq/patches-3.14/0030-GPIO-add-named-gpio-exports.patch
index da71d0b539..21db7d8a82 100644
--- a/target/linux/lantiq/patches-3.14/0030-GPIO-add-named-gpio-exports.patch
+++ b/target/linux/lantiq/patches-3.14/0030-GPIO-add-named-gpio-exports.patch
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
struct gpio_desc;
-@@ -296,3 +298,69 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -302,3 +304,69 @@ void of_gpiochip_remove(struct gpio_chip
if (chip->of_node)
of_node_put(chip->of_node);
}
@@ -94,7 +94,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+device_initcall(of_gpio_export_init);
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
-@@ -803,7 +803,7 @@ static struct class gpio_class = {
+@@ -798,7 +798,7 @@ static struct class gpio_class = {
*
* Returns zero on success, else an error.
*/
@@ -103,17 +103,17 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
{
unsigned long flags;
int status;
-@@ -843,7 +843,8 @@ int gpiod_export(struct gpio_desc *desc,
- offset = gpio_chip_hwgpio(desc);
+@@ -839,6 +839,9 @@ int gpiod_export(struct gpio_desc *desc,
if (desc->chip->names && desc->chip->names[offset])
ioname = desc->chip->names[offset];
--
+
+ if (name)
+ ioname = name;
- dev = device_create(&gpio_class, desc->chip->dev, MKDEV(0, 0),
- desc, ioname ? ioname : "gpio%u",
- desc_to_gpio(desc));
-@@ -880,6 +881,12 @@ fail_unlock:
++
+ dev = device_create_with_groups(&gpio_class, desc->chip->dev,
+ MKDEV(0, 0), desc, gpio_groups,
+ ioname ? ioname : "gpio%u",
+@@ -874,6 +877,12 @@ fail_unlock:
gpiod_dbg(desc, "%s: status %d\n", __func__, status);
return status;
}
diff --git a/target/linux/lantiq/patches-3.14/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch b/target/linux/lantiq/patches-3.14/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
index f2c0395a0e..834f3ff04c 100644
--- a/target/linux/lantiq/patches-3.14/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
+++ b/target/linux/lantiq/patches-3.14/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
@@ -19,10 +19,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 arch/mips/lantiq/xway/pci-ath-fixup.c
create mode 100644 arch/mips/lantiq/xway/rt_eep.c
-Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h 2015-01-17 10:55:03.329443942 -0800
+--- /dev/null
++++ b/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h
@@ -0,0 +1,6 @@
+#ifndef _PCI_ATH_FIXUP
+#define _PCI_ATH_FIXUP
@@ -30,11 +28,9 @@ Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h
+void ltq_pci_ath_fixup(unsigned slot, u16 *cal_data) __init;
+
+#endif /* _PCI_ATH_FIXUP */
-Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
-===================================================================
---- linux-3.14.28.orig/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2015-01-17 10:55:03.337443971 -0800
-+++ linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2015-01-17 10:55:03.329443942 -0800
-@@ -90,5 +90,8 @@
+--- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
++++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
+@@ -90,5 +90,8 @@ int xrx200_gphy_boot(struct device *dev,
extern void ltq_pmu_enable(unsigned int module);
extern void ltq_pmu_disable(unsigned int module);
@@ -43,11 +39,9 @@ Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
+
#endif /* CONFIG_SOC_TYPE_XWAY */
#endif /* _LTQ_XWAY_H__ */
-Index: linux-3.14.28/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.14.28.orig/arch/mips/lantiq/xway/Makefile 2015-01-17 10:55:03.337443971 -0800
-+++ linux-3.14.28/arch/mips/lantiq/xway/Makefile 2015-01-17 11:58:16.000000000 -0800
-@@ -2,4 +2,7 @@
+--- a/arch/mips/lantiq/xway/Makefile
++++ b/arch/mips/lantiq/xway/Makefile
+@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
obj-y += vmmc.o tffs.o
@@ -55,10 +49,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/Makefile
+obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o
+
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
-Index: linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c 2015-01-17 10:55:03.329443942 -0800
+--- /dev/null
++++ b/arch/mips/lantiq/xway/ath_eep.c
@@ -0,0 +1,282 @@
+/*
+ * Copyright (C) 2011 Luca Olivetti <luca@ventoso.org>
@@ -342,10 +334,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c
+ return platform_driver_probe(&ath5k_eeprom_driver, of_ath5k_eeprom_probe);
+}
+device_initcall(of_ath5k_eeprom_init);
-Index: linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c 2015-01-17 11:14:42.823292726 -0800
+--- /dev/null
++++ b/arch/mips/lantiq/xway/eth_mac.c
@@ -0,0 +1,76 @@
+/*
+ * Copyright (C) 2012 John Crispin <blogic@openwrt.org>
@@ -423,10 +413,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c
+ return platform_driver_probe(&eth_mac_driver, of_eth_mac_probe);
+}
+device_initcall(of_eth_mac_init);
-Index: linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c 2015-01-17 10:55:03.329443942 -0800
+--- /dev/null
++++ b/arch/mips/lantiq/xway/pci-ath-fixup.c
@@ -0,0 +1,109 @@
+/*
+ * Atheros AP94 reference board PCI initialization
@@ -537,10 +525,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c
+ ath_fixups[ath_num_fixups].cal_data = cal_data;
+ ath_num_fixups++;
+}
-Index: linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c 2015-01-17 10:55:03.329443942 -0800
+--- /dev/null
++++ b/arch/mips/lantiq/xway/rt_eep.c
@@ -0,0 +1,60 @@
+/*
+ * Copyright (C) 2011 John Crispin <blogic@openwrt.org>
@@ -602,11 +588,9 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c
+ return platform_driver_probe(&ralink_eeprom_driver, of_ralink_eeprom_probe);
+}
+device_initcall(of_ralink_eeprom_init);
-Index: linux-3.14.28/drivers/net/ethernet/lantiq_etop.c
-===================================================================
---- linux-3.14.28.orig/drivers/net/ethernet/lantiq_etop.c 2015-01-17 11:52:03.818405214 -0800
-+++ linux-3.14.28/drivers/net/ethernet/lantiq_etop.c 2015-01-17 12:02:20.905465188 -0800
-@@ -843,6 +843,9 @@
+--- a/drivers/net/ethernet/lantiq_etop.c
++++ b/drivers/net/ethernet/lantiq_etop.c
+@@ -843,6 +843,9 @@ ltq_etop_init(struct net_device *dev)
if (priv->mac)
memcpy(&mac.sa_data, priv->mac, ETH_ALEN);
diff --git a/target/linux/lantiq/patches-3.14/0038-MIPS-lantiq-fpi-on-ar9.patch b/target/linux/lantiq/patches-3.14/0038-MIPS-lantiq-fpi-on-ar9.patch
index cfa3a1f79a..5fbe0a1137 100644
--- a/target/linux/lantiq/patches-3.14/0038-MIPS-lantiq-fpi-on-ar9.patch
+++ b/target/linux/lantiq/patches-3.14/0038-MIPS-lantiq-fpi-on-ar9.patch
@@ -5,9 +5,9 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
arch/mips/lantiq/xway/clk.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
---- a/arch/mips/lantiq/xway/clk.c 2015-01-21 10:15:44.000000000 +0100
-+++ b/arch/mips/lantiq/xway/clk.c 2015-01-21 10:17:29.000000000 +0100
-@@ -104,8 +104,9 @@ unsigned long ltq_ar9_fpi_hz(void)
+--- a/arch/mips/lantiq/xway/clk.c
++++ b/arch/mips/lantiq/xway/clk.c
+@@ -87,8 +87,9 @@ unsigned long ltq_ar9_fpi_hz(void)
unsigned long sys = ltq_ar9_sys_hz();
if (ltq_cgu_r32(CGU_SYS) & BIT(0))