summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
commit658cfef9bc33752a05c154d58adba25838bbab1e (patch)
treea6c1b38635cd0c5208ea66d11ede53b46a452d28 /target
parent21075a17f77be37c466053f6150e8fcf8f6d52cd (diff)
downloadmaster-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.tar.gz
master-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.tar.bz2
master-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.zip
Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a module
SVN-Revision: 8317
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120eb-2.6/config/default2
-rw-r--r--target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk17
-rw-r--r--target/linux/adm5120eb-2.6/profiles/100-Texas.mk2
3 files changed, 19 insertions, 2 deletions
diff --git a/target/linux/adm5120eb-2.6/config/default b/target/linux/adm5120eb-2.6/config/default
index 9b1daa2c41..05de7eee60 100644
--- a/target/linux/adm5120eb-2.6/config/default
+++ b/target/linux/adm5120eb-2.6/config/default
@@ -241,7 +241,7 @@ CONFIG_TRAD_SIGNALS=y
CONFIG_USB=y
# CONFIG_USBPCWATCHDOG is not set
# CONFIG_USB_ACM is not set
-CONFIG_USB_ADM5120_HCD=y
+CONFIG_USB_ADM5120_HCD=m
# CONFIG_USB_ATM is not set
# CONFIG_USB_CATC is not set
# CONFIG_USB_DEVICEFS is not set
diff --git a/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk b/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk
new file mode 100644
index 0000000000..b0741e84be
--- /dev/null
+++ b/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Zyxel
+ NAME:=Zyxel Prestige P-334/335/335-WT (default)
+ PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/Zyxel/Description
+ Package set compatible with the Zyxel prestige P-334/335/335-WT boards
+endef
+$(eval $(call Profile,Zyxel))
+
diff --git a/target/linux/adm5120eb-2.6/profiles/100-Texas.mk b/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
index a9306ca702..727a0c0648 100644
--- a/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
+++ b/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
@@ -6,7 +6,7 @@
#
define Profile/Texas
- NAME:=Texas Instruments WiFi (default)
+ NAME:=Texas Instruments WiFi
PACKAGES:=kmod-acx
endef