summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-01 22:14:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-01 22:14:11 +0000
commit616c3841c6767a8cfa5fd79a6842d6208943d426 (patch)
tree95796b79249df1624205fea258a8c575e6820ee2 /target
parent569330c102a664c9ad8b936e00974031eca6e985 (diff)
downloadmaster-31e0f0ae-616c3841c6767a8cfa5fd79a6842d6208943d426.tar.gz
master-31e0f0ae-616c3841c6767a8cfa5fd79a6842d6208943d426.tar.bz2
master-31e0f0ae-616c3841c6767a8cfa5fd79a6842d6208943d426.zip
add ip175c switch driver patch to 2.6.30
SVN-Revision: 16287
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic-2.6/config-2.6.301
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch23
2 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/config-2.6.30 b/target/linux/generic-2.6/config-2.6.30
index 778b05d93e..4feb9c853e 100644
--- a/target/linux/generic-2.6/config-2.6.30
+++ b/target/linux/generic-2.6/config-2.6.30
@@ -733,6 +733,7 @@ CONFIG_INPUT_MISC=y
CONFIG_IOSCHED_DEADLINE=y
CONFIG_IOSCHED_NOOP=y
# CONFIG_IP1000 is not set
+# CONFIG_IP175C_PHY is not set
# CONFIG_IP6_NF_FILTER is not set
# CONFIG_IP6_NF_IPTABLES is not set
# CONFIG_IP6_NF_MANGLE is not set
diff --git a/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
new file mode 100644
index 0000000000..461df50465
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP175C_PHY
++ tristate "Driver for IC+ IP175C/IP178C switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o