summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-01 00:50:56 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-01 00:50:56 +0000
commit5f726ccd79b23d362647b2d306e7c48811634f88 (patch)
tree7c5043312a4b59b46096ab6e09b2e187997a9a26 /target
parent309cdd61014c7018a48ffae85487caa6ae02edef (diff)
downloadmaster-31e0f0ae-5f726ccd79b23d362647b2d306e7c48811634f88.tar.gz
master-31e0f0ae-5f726ccd79b23d362647b2d306e7c48811634f88.tar.bz2
master-31e0f0ae-5f726ccd79b23d362647b2d306e7c48811634f88.zip
brcm63xx: add DT support for F@ST2404
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43447
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/dts/fast2404.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
-rw-r--r--target/linux/brcm63xx/profiles/sagem.mk15
3 files changed, 47 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/dts/fast2404.dts b/target/linux/brcm63xx/dts/fast2404.dts
new file mode 100644
index 0000000000..92ba6bf99e
--- /dev/null
+++ b/target/linux/brcm63xx/dts/fast2404.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+ model = "Sagem F@ST2404";
+ compatible = "sagem,f@st2404", "brcm,bcm6348";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ linux@10000 {
+ label = "linux";
+ reg = <0x010000 0x3e0000>;
+ };
+
+ nvram@3f0000 {
+ label = "nvram";
+ reg = <0x3f0000 0x010000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index f91be6381b..812e74111f 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -220,9 +220,6 @@ define Image/Build
# TP-Link 8900GB
$(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
- # Sagem F@ST2404
- $(call Image/Build/CFE,$(1),F@ST2404,6348,F@ST2404-cfe)
- $(call Image/Build/CFE,$(1),F@ST2404,6348,F@ST2404,OpenWRT-$(REVISION))
# Sagem F@ST2604
$(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604-cfe)
$(call Image/Build/CFE,$(1),F@ST2604,6348,F@ST2604,OpenWRT-$(REVISION))
@@ -326,6 +323,8 @@ $(eval $(call ImageDTB,CFEDTB,A226G,a226g,DWV-S0,6358,A226G,--signature2 IMAGE -
# Pirelli A226M/A226M-FWB
$(eval $(call ImageDTB,CFEDTB,A226M,a226m,DWV-S0,6358,A226M,--signature2 IMAGE --tag-version 8))
$(eval $(call ImageDTB,CFEDTB,A226M,a226m-fwb,DWV-S0,6358,A226M-FWB,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
+# Sagem F@ST2404
+$(eval $(call ImageDTB,CFEDTB,FAST2404,fast2404,F@ST2404,6348,F@ST2404))
# T-Com Speedport W 303V Typ B
$(eval $(call ImageDTB,SPW303VCFEDTB,SPW303V,spw303v,96358-502V,6358,SPW303V,--pad 4))
# T-Com Speedport W 500V
diff --git a/target/linux/brcm63xx/profiles/sagem.mk b/target/linux/brcm63xx/profiles/sagem.mk
new file mode 100644
index 0000000000..94cb056468
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/sagem.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FAST2404
+ NAME:=Sagem F@ST2404
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/FAST2404/Description
+ Package set optimized for F@ST2404.
+endef
+$(eval $(call Profile,FAST2404))