summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-07-11 15:15:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-07-11 15:15:23 +0000
commit59d37b2472eb14e16e838f5d51c36f9da0fff455 (patch)
tree7964b9ad5ee80185356c7baf9400ef27223161f3 /target
parent065091e0152a13dab298f115973aebdf589d724f (diff)
downloadmaster-31e0f0ae-59d37b2472eb14e16e838f5d51c36f9da0fff455.tar.gz
master-31e0f0ae-59d37b2472eb14e16e838f5d51c36f9da0fff455.tar.bz2
master-31e0f0ae-59d37b2472eb14e16e838f5d51c36f9da0fff455.zip
upgrade ixp4xx to 2.6.26-rc9, resync patches
SVN-Revision: 11768
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch2
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch6
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch8
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch2
11 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch b/target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch
index 1dfd95e82b..6d97dc356e 100644
--- a/target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch
@@ -40,7 +40,7 @@
enum
--- a/net/sched/Kconfig
+++ b/net/sched/Kconfig
-@@ -139,6 +139,37 @@
+@@ -128,6 +128,37 @@
To compile this code as a module, choose M here: the
module will be called sch_sfq.
diff --git a/target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch b/target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch
index e52f11a294..f1c1580e0d 100644
--- a/target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch
@@ -50,7 +50,7 @@
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -609,6 +609,7 @@
+@@ -613,6 +613,7 @@
void *ax25_ptr; /* AX.25 specific data */
struct wireless_dev *ieee80211_ptr; /* IEEE 802.11 specific data,
assign before registering */
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 1e2a52ff07..c922ffa611 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.26-rc8
+LINUX_VERSION:=2.6.26-rc9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch b/target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch
index 2044a20ac0..c2b684d056 100644
--- a/target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/mach-ixp4xx/pronghorn-setup.c
+++ b/arch/arm/mach-ixp4xx/pronghorn-setup.c
-@@ -50,31 +50,31 @@
+@@ -51,31 +51,31 @@
static struct resource pronghorn_uart_resources [] = {
{
diff --git a/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch b/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
index 9f309a6fa6..76111fd53b 100644
--- a/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
@@ -1,8 +1,8 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -83,6 +83,14 @@
- depends on MACH_PRONGHORN
- default y
+@@ -81,6 +81,14 @@
+ config MACH_PRONGHORNMETRO
+ def_bool MACH_PRONGHORN
+config MACH_COMPEX
+ bool "Compex WP18 / NP18A"
diff --git a/target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch b/target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch
index 29c86390e8..edd68ecd68 100644
--- a/target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -91,6 +91,14 @@
+@@ -89,6 +89,14 @@
WP18 or NP18A boards. For more information on this
platform, see http://openwrt.org
diff --git a/target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch b/target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch
index e3f450fdbd..fcd9d67b67 100644
--- a/target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch
@@ -1,8 +1,8 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -83,6 +83,14 @@
- depends on MACH_PRONGHORN
- default y
+@@ -81,6 +81,14 @@
+ config MACH_PRONGHORNMETRO
+ def_bool MACH_PRONGHORN
+config MACH_SIDEWINDER
+ bool "Sidewinder"
@@ -15,7 +15,7 @@
config MACH_COMPEX
bool "Compex WP18 / NP18A"
select PCI
-@@ -181,7 +189,7 @@
+@@ -179,7 +187,7 @@
#
config CPU_IXP46X
bool
diff --git a/target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch b/target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch
index fd1567bcac..9a00273551 100644
--- a/target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch
@@ -166,7 +166,7 @@
}
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -107,6 +107,14 @@
+@@ -105,6 +105,14 @@
WRT300N v2 router. For more information on this
platform, see http://openwrt.org
diff --git a/target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch b/target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch
index 2632f80e17..40724203c1 100644
--- a/target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -160,6 +160,14 @@
+@@ -158,6 +158,14 @@
PrPCM1100 Processor Mezanine Module. For more information on
this platform, see <file:Documentation/arm/IXP4xx>.
diff --git a/target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch b/target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch
index b63cb17aaf..14555b4852 100644
--- a/target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch
@@ -15,7 +15,7 @@
config MACH_LOFT
bool "Loft"
depends on MACH_AVILA
-@@ -210,7 +218,7 @@
+@@ -208,7 +216,7 @@
config CPU_IXP43X
bool
diff --git a/target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch b/target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch
index 28230272ea..8d2b4c7a73 100644
--- a/target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch
@@ -13,7 +13,7 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -246,6 +246,11 @@
+@@ -244,6 +244,11 @@
default y
depends on PCI