summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:57 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:57 +0000
commit582dfc52f592b24669c61bfc57ad75b7370c833b (patch)
treeb2160f6a279ab353ff540abac615e12b706127d1 /target
parent46b4d4d1d56950bb0f4c171ee70f3472d1677d0c (diff)
downloadmaster-31e0f0ae-582dfc52f592b24669c61bfc57ad75b7370c833b.tar.gz
master-31e0f0ae-582dfc52f592b24669c61bfc57ad75b7370c833b.tar.bz2
master-31e0f0ae-582dfc52f592b24669c61bfc57ad75b7370c833b.zip
brcm63xx: move CPVA502+ to dts
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44990
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh6
-rw-r--r--target/linux/brcm63xx/dts/cpva502plus.dts44
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
-rw-r--r--target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/528-board_nb6.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/534-board_hw556.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/565-board_hw520.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/528-board_nb6.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/534-board_hw556.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/565-board_hw520.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch2
-rw-r--r--target/linux/brcm63xx/profiles/telsey.mk9
35 files changed, 103 insertions, 32 deletions
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index 991e3636a6..d9ec3ed719 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -192,6 +192,9 @@ brcm63xx_dt_detect() {
"TECOM GW6200")
board_name="g6200"
;;
+ "Telsey CVPA502+")
+ board_name="cpva502p"
+ ;;
"Telsey CPVA642-type (CPA-ZNTE60T)")
board_name="cpva642"
;;
@@ -216,9 +219,6 @@ brcm63xx_legacy_detect() {
local board_name
case "$1" in
- CPVA502+)
- board_name="cpva502p"
- ;;
MAGIC)
board_name="magic"
;;
diff --git a/target/linux/brcm63xx/dts/cpva502plus.dts b/target/linux/brcm63xx/dts/cpva502plus.dts
new file mode 100644
index 0000000000..3cb702d5e8
--- /dev/null
+++ b/target/linux/brcm63xx/dts/cpva502plus.dts
@@ -0,0 +1,44 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+ model = "Telsey CPVA502+";
+ compatible = "telsey,cpva502+", "brcm,bcm6348";
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ power_green {
+ label = "CPVA502+:green:phone";
+ gpios = <&gpio0 0 1>;
+ };
+
+ status {
+ label = "CPVA502+:amber:link";
+ gpios = <&gpio0 1 1>;
+ };
+ };
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ linux@10000 {
+ label = "linux";
+ reg = <0x010000 0x3e0000>;
+ };
+
+ nvram@3f0000 {
+ label = "nvram";
+ reg = <0x3f0000 0x010000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 0c164770a1..d38ffe975f 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -368,6 +368,8 @@ $(eval $(call ImageDTB,CFEDTB,SPW500V,SPW500V,spw500v,96348GW,6348))
$(eval $(call ImageDTB,CFEDTB,GW6000,GW6000,gw6000,96348GW,6348))
# Tecom GW6200
$(eval $(call ImageDTB,CFEDTB,GW6200,GW6200,gw6200,96348GW,6348,--rsa-signature "$(shell printf '\x99')"))
+# Telsey CPVA502+
+$(eval $(call ImageDTB,Dummy,CPVA502PLUS,CVPA502PLUS,cpva502plus,CPVA502+,6348,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0"))
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
$(eval $(call ImageDTB,CFEDTB,CPVA642,CPA-ZNTE60T,cpva642,CPVA642,6358,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0" --pad 4))
# TP-Link TD-W8900GB
diff --git a/target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch b/target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
index 94a53e7cee..756b6437de 100644
--- a/target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
+++ b/target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
@@ -36,3 +36,11 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1216,6 +1238,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+ { .compatible = "tecom,gw6000", .data = &board_gw6000, },
+ { .compatible = "tecom,gw6200", .data = &board_gw6200, },
++ { .compatible = "telsey,cpva502+", .data = &board_CPVA502plus, },
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
+ { .compatible = "usr,9108", .data = &board_96348gw_a, },
+ #endif
diff --git a/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch b/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
index f9c3b73d9c..48cfd23019 100644
--- a/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
+++ b/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
@@ -81,7 +81,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
};
static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -1258,6 +1315,7 @@ static struct of_device_id const bcm963x
+@@ -1259,6 +1316,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
diff --git a/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch b/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
index 0979de726b..66490312a9 100644
--- a/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
+++ b/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
@@ -64,7 +64,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
#endif
};
-@@ -1315,6 +1356,7 @@ static struct of_device_id const bcm963x
+@@ -1316,6 +1357,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
diff --git a/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch b/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
index 11e4ff4be5..0ce7e0a262 100644
--- a/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
+++ b/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
@@ -40,7 +40,7 @@
&board_HW553,
&board_spw303v,
#endif
-@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
+@@ -1476,6 +1502,7 @@ static struct of_device_id const bcm963x
{ .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
{ .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
{ .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
diff --git a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
index 4ac9d2db5c..80d5d49c0b 100644
--- a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
+++ b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
@@ -45,7 +45,7 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
+@@ -1505,6 +1536,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
diff --git a/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch b/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
index 68c1dc3696..e4d8f4b282 100644
--- a/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
+++ b/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
@@ -100,7 +100,7 @@
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
-@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
+@@ -1547,6 +1619,9 @@ static struct of_device_id const bcm963x
{ .compatible = "t-com,spw303v", .data = &board_spw303v, },
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
index 280ac79f67..5bc7c792f1 100644
--- a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
+++ b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
@@ -112,7 +112,7 @@
&board_spw303v,
&board_DVAG3810BN,
#endif
-@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
+@@ -1857,6 +1948,9 @@ static struct of_device_id const bcm963x
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
{ .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
{ .compatible = "huawei,hg553", .data = &board_HW553, },
diff --git a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
index c83e5b7ae0..e33c7232a1 100644
--- a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
+++ b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
+@@ -2056,6 +2094,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6362
diff --git a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
index ca7ed5519c..289e5ded18 100644
--- a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
+++ b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
@@ -75,7 +75,7 @@
&board_963269bhr,
&board_vw6339gu,
#endif
-@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
+@@ -2238,6 +2299,7 @@ static struct of_device_id const bcm963x
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
index 803ccc9c3d..6412188036 100644
--- a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
+++ b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
@@ -84,7 +84,7 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
&board_963268bu_p300,
-@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
+@@ -2297,6 +2359,7 @@ static struct of_device_id const bcm963x
#ifdef CONFIG_BCM63XX_CPU_6368
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
diff --git a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
index 8660a6dfcb..71e9532abf 100644
--- a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
+++ b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
@@ -69,7 +69,7 @@
&board_WAP5813n,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
+@@ -2359,6 +2414,7 @@ static struct of_device_id const bcm963x
#ifdef CONFIG_BCM63XX_CPU_6368
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
diff --git a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
index e63b5e2220..3f3f0b0631 100644
--- a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
+++ b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
@@ -69,7 +69,7 @@
&board_WAP5813n,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
+@@ -2415,6 +2470,7 @@ static struct of_device_id const bcm963x
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
diff --git a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
index 8078200a9d..1a61b59125 100644
--- a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
+++ b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
@@ -58,7 +58,7 @@
&board_VR3025u,
&board_VR3025un,
&board_WAP5813n,
-@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
+@@ -2472,6 +2516,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
{ .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
{ .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
diff --git a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
index 19d5807b33..1a83b0eed0 100644
--- a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
+++ b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
@@ -46,7 +46,7 @@
&board_HW553,
&board_HW556_A,
&board_HW556_B,
-@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
+@@ -2493,6 +2525,7 @@ static struct of_device_id const bcm963x
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
{ .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
diff --git a/target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch b/target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
index c9463f0097..896ec8b115 100644
--- a/target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
+++ b/target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
@@ -57,7 +57,7 @@
&board_P870HW51A_V2,
&board_VR3025u,
&board_VR3025un,
-@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
+@@ -2731,6 +2774,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
{ .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
{ .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
diff --git a/target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch b/target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch
index 94a53e7cee..756b6437de 100644
--- a/target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch
+++ b/target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch
@@ -36,3 +36,11 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1216,6 +1238,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+ { .compatible = "tecom,gw6000", .data = &board_gw6000, },
+ { .compatible = "tecom,gw6200", .data = &board_gw6200, },
++ { .compatible = "telsey,cpva502+", .data = &board_CPVA502plus, },
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
+ { .compatible = "usr,9108", .data = &board_96348gw_a, },
+ #endif
diff --git a/target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch b/target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
index f9c3b73d9c..48cfd23019 100644
--- a/target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
+++ b/target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
@@ -81,7 +81,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
};
static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -1258,6 +1315,7 @@ static struct of_device_id const bcm963x
+@@ -1259,6 +1316,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
diff --git a/target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch b/target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
index 0979de726b..66490312a9 100644
--- a/target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
+++ b/target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
@@ -64,7 +64,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
#endif
};
-@@ -1315,6 +1356,7 @@ static struct of_device_id const bcm963x
+@@ -1316,6 +1357,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
diff --git a/target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch b/target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
index 11e4ff4be5..0ce7e0a262 100644
--- a/target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
+++ b/target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
@@ -40,7 +40,7 @@
&board_HW553,
&board_spw303v,
#endif
-@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
+@@ -1476,6 +1502,7 @@ static struct of_device_id const bcm963x
{ .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
{ .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
{ .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
diff --git a/target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch b/target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
index 4ac9d2db5c..80d5d49c0b 100644
--- a/target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
+++ b/target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
@@ -45,7 +45,7 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
+@@ -1505,6 +1536,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
diff --git a/target/linux/brcm63xx/patches-3.18/528-board_nb6.patch b/target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
index 68c1dc3696..e4d8f4b282 100644
--- a/target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
+++ b/target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
@@ -100,7 +100,7 @@
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
-@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
+@@ -1547,6 +1619,9 @@ static struct of_device_id const bcm963x
{ .compatible = "t-com,spw303v", .data = &board_spw303v, },
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
diff --git a/target/linux/brcm63xx/patches-3.18/534-board_hw556.patch b/target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
index 280ac79f67..5bc7c792f1 100644
--- a/target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
+++ b/target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
@@ -112,7 +112,7 @@
&board_spw303v,
&board_DVAG3810BN,
#endif
-@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
+@@ -1857,6 +1948,9 @@ static struct of_device_id const bcm963x
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
{ .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
{ .compatible = "huawei,hg553", .data = &board_HW553, },
diff --git a/target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch b/target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
index c83e5b7ae0..e33c7232a1 100644
--- a/target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
+++ b/target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
+@@ -2056,6 +2094,7 @@ static struct of_device_id const bcm963x
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6362
diff --git a/target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch b/target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
index ca7ed5519c..289e5ded18 100644
--- a/target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
+++ b/target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
@@ -75,7 +75,7 @@
&board_963269bhr,
&board_vw6339gu,
#endif
-@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
+@@ -2238,6 +2299,7 @@ static struct of_device_id const bcm963x
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch b/target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
index 803ccc9c3d..6412188036 100644
--- a/target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
+++ b/target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
@@ -84,7 +84,7 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
&board_963268bu_p300,
-@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
+@@ -2297,6 +2359,7 @@ static struct of_device_id const bcm963x
#ifdef CONFIG_BCM63XX_CPU_6368
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
diff --git a/target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
index 8660a6dfcb..71e9532abf 100644
--- a/target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
+++ b/target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
@@ -69,7 +69,7 @@
&board_WAP5813n,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
+@@ -2359,6 +2414,7 @@ static struct of_device_id const bcm963x
#ifdef CONFIG_BCM63XX_CPU_6368
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
diff --git a/target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
index e63b5e2220..3f3f0b0631 100644
--- a/target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
+++ b/target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
@@ -69,7 +69,7 @@
&board_WAP5813n,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
+@@ -2415,6 +2470,7 @@ static struct of_device_id const bcm963x
{ .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
{ .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
diff --git a/target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch b/target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
index 8078200a9d..1a61b59125 100644
--- a/target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
+++ b/target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
@@ -58,7 +58,7 @@
&board_VR3025u,
&board_VR3025un,
&board_WAP5813n,
-@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
+@@ -2472,6 +2516,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
{ .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
{ .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
diff --git a/target/linux/brcm63xx/patches-3.18/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
index 19d5807b33..1a83b0eed0 100644
--- a/target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
+++ b/target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
@@ -46,7 +46,7 @@
&board_HW553,
&board_HW556_A,
&board_HW556_B,
-@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
+@@ -2493,6 +2525,7 @@ static struct of_device_id const bcm963x
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
{ .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
{ .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
diff --git a/target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch b/target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
index c9463f0097..896ec8b115 100644
--- a/target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
+++ b/target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
@@ -57,7 +57,7 @@
&board_P870HW51A_V2,
&board_VR3025u,
&board_VR3025un,
-@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
+@@ -2731,6 +2774,7 @@ static struct of_device_id const bcm963x
{ .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
{ .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
{ .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
diff --git a/target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch b/target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
index ba304eac7e..ca0f0746f7 100644
--- a/target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
+++ b/target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
@@ -41,7 +41,7 @@
&board_HW520,
&board_HW553,
&board_HW556_A,
-@@ -2762,6 +2789,7 @@ static struct of_device_id const bcm963x
+@@ -2763,6 +2790,7 @@ static struct of_device_id const bcm963x
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
{ .compatible = "t-com,spw303v", .data = &board_spw303v, },
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
diff --git a/target/linux/brcm63xx/profiles/telsey.mk b/target/linux/brcm63xx/profiles/telsey.mk
index 5e2359aa0d..a8ad31eb1f 100644
--- a/target/linux/brcm63xx/profiles/telsey.mk
+++ b/target/linux/brcm63xx/profiles/telsey.mk
@@ -5,6 +5,15 @@
# See /LICENSE for more information.
#
+define Profile/CPVA502PLUS
+ NAME:=Telsey CPVA502+
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/CPVA502PLUS/Description
+ Package set optimized for CPVA502+.
+endef
+$(eval $(call Profile,CPVA502PLUS))
+
define Profile/CPVA642
NAME:=Telsey CPVA642-type (CPA-ZNTE60T)
PACKAGES:=kmod-rt61-pci wpad-mini\