summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
commit55baa6e4675ea9bde883884aa095673b9026d2b8 (patch)
treeb20b47e14eac9fc27127d31ff54bcb7f513155ae /target
parentff17ac5ec3a0a27a7a4e183788efa37d1090cdef (diff)
downloadmaster-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.tar.gz
master-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.tar.bz2
master-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.zip
Move wget2nand to the base-files for adm5120 also fix default permission (#1812)
SVN-Revision: 7633
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/adm5120-2.6/base-files/default/sbin/wget2nand72
-rw-r--r--target/linux/adm5120-2.6/profiles/RB1xx.mk2
2 files changed, 73 insertions, 1 deletions
diff --git a/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
new file mode 100755
index 0000000000..1f7548aa06
--- /dev/null
+++ b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
@@ -0,0 +1,72 @@
+#!/bin/sh
+# wget2nand
+# This script can be used to download a TGZ file from your build system which
+# contains the files to be installed on the NAND flash on your RB1xx card.
+# The one parameter is the URL of the TGZ file to be downloaded.
+# Licence GPL V2
+# Author david.goodenough@linkchoose.co.uk
+# Based on cf2nand from RB532 support
+. /etc/functions.sh
+
+[ -d /tmp/wget2nand ] && {
+ echo "/tmp/wget2nand already exists"
+ exit 1
+}
+
+# first get an address for br-lan using udhcpc
+killall udhcpc
+/sbin/udhcpc -i br-lan
+
+# need to find the wget server from the command line
+url=$1
+[ -z "$url" ] && {
+ echo "No URL specified for image TGZ"
+ echo "Usage : $0 URL"
+ exit 1
+}
+
+boot="$(find_mtd_part 'RouterBoard NAND Boot')"
+main="$(find_mtd_part 'rootfs')"
+[ -z "$boot" -o -z "$main" ] && {
+ echo "Cannot find NAND Flash partitions"
+ exit 1
+}
+
+echo "Erasing filesystem."
+mtd erase Boot 2>/dev/null >/dev/null
+mtd erase Main 2>/dev/null >/dev/null
+
+echo "Mounting $main as new root and $boot as boot partition"
+
+mkdir /tmp/wget2nand/
+mkdir /tmp/wget2nand-boot
+mount -t yaffs2 "$main" /tmp/wget2nand/
+mount -t yaffs2 "$boot" /tmp/wget2nand-boot
+
+echo "Copying filesystem..."
+( wget -O - $url/openwrt-adm5120-2.6-rootfs.tgz) | ( cd /tmp/wget2nand/; tar xvz )
+wget -O /tmp/wget2nand-boot/kernel $url/openwrt-adm5120-2.6-vmlinux.elf
+
+# update the command line on the kernel to boot from the right place
+[ ! -e /sbin/patch-cmdline ] && {
+ echo "Cannot find patch-cmdline"
+ exit 1
+}
+
+echo "Patching the kernel command line"
+/sbin/patch-cmdline /tmp/wget2nand-boot/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit "
+chmod +x /tmp/wget2nand-boot/kernel
+
+# make sure everything is written before we unmount the partitions
+echo "chmod ugo+x /" > /tmp/wget2nand/etc/uci-defaults/set_root_permission
+sync
+ls /tmp/wget2nand-boot/
+ls /tmp/wget2nand/
+# unmount the partitions and remove the directories into which they were mounted
+umount /tmp/wget2nand-boot
+umount /tmp/wget2nand
+rmdir /tmp/wget2nand-boot
+rmdir /tmp/wget2nand
+
+# all done
+echo "Image written, you can now reboot. Remember to change the boot source to Boot from Nand"
diff --git a/target/linux/adm5120-2.6/profiles/RB1xx.mk b/target/linux/adm5120-2.6/profiles/RB1xx.mk
index d832523a26..8bede7a79a 100644
--- a/target/linux/adm5120-2.6/profiles/RB1xx.mk
+++ b/target/linux/adm5120-2.6/profiles/RB1xx.mk
@@ -7,7 +7,7 @@
define Profile/RouterBoard
NAME:=RouterBoard RB1xx
- PACKAGES:=kmod-madwifi patch-cmdline wget2nand
+ PACKAGES:=kmod-madwifi patch-cmdline
endef
define Profile/RouterBoard/Description