summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-15 16:00:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-15 16:00:41 +0000
commit554772a66547afa10bc7fc3040f3bf9259728c60 (patch)
tree0e13685d463ed4e6c63782bdfa6a4258ba154c99 /target
parent57c6730ed623e347ed8eae420e5e2fa6e67ebecc (diff)
downloadmaster-31e0f0ae-554772a66547afa10bc7fc3040f3bf9259728c60.tar.gz
master-31e0f0ae-554772a66547afa10bc7fc3040f3bf9259728c60.tar.bz2
master-31e0f0ae-554772a66547afa10bc7fc3040f3bf9259728c60.zip
kernel: update 3.10 to 3.10.12
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38000
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch4
-rw-r--r--target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch12
-rw-r--r--target/linux/bcm53xx/Makefile2
-rw-r--r--target/linux/brcm2708/Makefile2
-rw-r--r--target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch2
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch16
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch2
-rw-r--r--target/linux/cns21xx/Makefile2
-rw-r--r--target/linux/generic/patches-3.10/030-timer_list_fix.patch45
-rw-r--r--target/linux/generic/patches-3.10/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch6
-rw-r--r--target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch2
-rw-r--r--target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch2
-rw-r--r--target/linux/generic/patches-3.10/620-sched_esfq.patch2
-rw-r--r--target/linux/generic/patches-3.10/630-packet_socket_type.patch2
-rw-r--r--target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch8
-rw-r--r--target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch16
-rw-r--r--target/linux/generic/patches-3.10/902-debloat_proc.patch6
-rw-r--r--target/linux/imx23/Makefile2
-rw-r--r--target/linux/imx6/Makefile2
-rw-r--r--target/linux/imx6/patches-3.10/200-imx6_pcie.patch4
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/octeon/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch4
-rw-r--r--target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch2
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/x86/alix2/target.mk2
-rw-r--r--target/linux/xburst/Makefile2
38 files changed, 62 insertions, 115 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 20464f81a2..ba63ded1de 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch b/target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch
index 6584c19e70..e55018ba7f 100644
--- a/target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch
+++ b/target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -172,6 +172,12 @@ config MTD_BCM47XX_PARTS
+@@ -176,6 +176,12 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.
diff --git a/target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch b/target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch
index 96fe34203c..f0d26b7434 100644
--- a/target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch
+++ b/target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -174,7 +174,7 @@ config MTD_BCM47XX_PARTS
+@@ -178,7 +178,7 @@ config MTD_BCM47XX_PARTS
config MTD_WRT160NL_PARTS
tristate "Linksys WRT160NL partitioning support"
@@ -9,7 +9,7 @@
---help---
Linksys WRT160NL partitioning support
-@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
+@@ -198,6 +198,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically.
diff --git a/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
index 2e07b14ca1..fa4ff47d3c 100644
--- a/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
@@ -883,7 +883,7 @@
tpi->seq = 0;
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3592,13 +3592,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3592,14 +3592,16 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);
@@ -897,11 +897,13 @@
- tp->rx_opt.rcv_tsval = ntohl(*ptr);
+ tp->rx_opt.rcv_tsval = get_unaligned_be32(ptr);
++ptr;
-- tp->rx_opt.rcv_tsecr = ntohl(*ptr) - tp->tsoffset;
-+ tp->rx_opt.rcv_tsecr = get_unaligned_be32(ptr) - tp->tsoffset;
+ if (*ptr)
+- tp->rx_opt.rcv_tsecr = ntohl(*ptr) - tp->tsoffset;
++ tp->rx_opt.rcv_tsecr = get_unaligned_be32(ptr) -
++ tp->tsoffset;
+ else
+ tp->rx_opt.rcv_tsecr = 0;
return true;
- }
- return false;
--- a/include/uapi/linux/if_pppox.h
+++ b/include/uapi/linux/if_pppox.h
@@ -47,6 +47,7 @@ struct pppoe_addr {
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index 31e745c252..591cc99fde 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
FEATURES:=squashfs usb pci pcie gpio
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 0a262488a1..ad0d1fb806 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -13,7 +13,7 @@ BOARDNAME:=Broadcom BCM2708/BCM2835
FEATURES:=ext4 audio usb usbgadget display gpio
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
diff --git a/target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch b/target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch
index 9800298aa0..baab5fbde5 100644
--- a/target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch
+++ b/target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch
@@ -2079,7 +2079,7 @@
+ENDPROC(__FIQ_Branch)
--- a/arch/arm/kernel/fiq.c
+++ b/arch/arm/kernel/fiq.c
-@@ -145,6 +145,7 @@ void disable_fiq(int fiq)
+@@ -141,6 +141,7 @@ void disable_fiq(int fiq)
EXPORT_SYMBOL(set_fiq_handler);
EXPORT_SYMBOL(__set_fiq_regs); /* defined in fiqasm.S */
EXPORT_SYMBOL(__get_fiq_regs); /* defined in fiqasm.S */
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 7719ae82f8..535e7033ca 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
diff --git a/target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch b/target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch
index 4a7b116745..19ab8fef2f 100644
--- a/target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch
+++ b/target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch
@@ -120,7 +120,7 @@
tp->phy_flags &= ~TG3_PHYFLG_IS_CONNECTED;
}
}
-@@ -3985,7 +3992,7 @@ static int tg3_power_down_prepare(struct
+@@ -3999,7 +4006,7 @@ static int tg3_power_down_prepare(struct
struct phy_device *phydev;
u32 phyid, advertising;
@@ -129,7 +129,7 @@
tp->phy_flags |= TG3_PHYFLG_IS_LOW_POWER;
-@@ -11769,7 +11776,7 @@ static int tg3_get_settings(struct net_d
+@@ -11783,7 +11790,7 @@ static int tg3_get_settings(struct net_d
struct phy_device *phydev;
if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
return -EAGAIN;
@@ -138,7 +138,7 @@
return phy_ethtool_gset(phydev, cmd);
}
-@@ -11836,7 +11843,7 @@ static int tg3_set_settings(struct net_d
+@@ -11850,7 +11857,7 @@ static int tg3_set_settings(struct net_d
struct phy_device *phydev;
if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
return -EAGAIN;
@@ -147,7 +147,7 @@
return phy_ethtool_sset(phydev, cmd);
}
-@@ -11993,7 +12000,7 @@ static int tg3_nway_reset(struct net_dev
+@@ -12007,7 +12014,7 @@ static int tg3_nway_reset(struct net_dev
if (tg3_flag(tp, USE_PHYLIB)) {
if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
return -EAGAIN;
@@ -156,7 +156,7 @@
} else {
u32 bmcr;
-@@ -12109,7 +12116,7 @@ static int tg3_set_pauseparam(struct net
+@@ -12123,7 +12130,7 @@ static int tg3_set_pauseparam(struct net
u32 newadv;
struct phy_device *phydev;
@@ -165,7 +165,7 @@
if (!(phydev->supported & SUPPORTED_Pause) ||
(!(phydev->supported & SUPPORTED_Asym_Pause) &&
-@@ -13543,7 +13550,7 @@ static int tg3_ioctl(struct net_device *
+@@ -13557,7 +13564,7 @@ static int tg3_ioctl(struct net_device *
struct phy_device *phydev;
if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
return -EAGAIN;
@@ -174,7 +174,7 @@
return phy_mii_ioctl(phydev, ifr, cmd);
}
-@@ -17176,8 +17183,10 @@ static int tg3_init_one(struct pci_dev *
+@@ -17190,8 +17197,10 @@ static int tg3_init_one(struct pci_dev *
tg3_flag_set(tp, FLUSH_POSTED_WRITES);
if (ssb_gige_one_dma_at_once(pdev))
tg3_flag_set(tp, ONE_DMA_AT_ONCE);
@@ -186,7 +186,7 @@
if (ssb_gige_is_rgmii(pdev))
tg3_flag_set(tp, RGMII_MODE);
}
-@@ -17447,7 +17456,7 @@ static int tg3_init_one(struct pci_dev *
+@@ -17461,7 +17470,7 @@ static int tg3_init_one(struct pci_dev *
if (tp->phy_flags & TG3_PHYFLG_IS_CONNECTED) {
struct phy_device *phydev;
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 6fce7fdc4c..1fcbc8174f 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
SUBTARGETS:=generic smp
FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch b/target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch
index b5df076dbc..04b5f2f4a0 100644
--- a/target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch
+++ b/target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch
@@ -11,7 +11,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -1088,7 +1088,8 @@ static int m25p_probe(struct spi_device
+@@ -1091,7 +1091,8 @@ static int m25p_probe(struct spi_device
/* partitions should match sector boundaries; and it may be good to
* use readonly partitions for writeprotected sectors (BP2..BP0).
*/
diff --git a/target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch b/target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch
index 7ac1b2fb10..0e4ca9daa6 100644
--- a/target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch
+++ b/target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch
@@ -60,7 +60,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
/*
* Write an address range to the flash chip. Data must be written in
* FLASH_PAGESIZE chunks. The address range may be any size provided
-@@ -983,6 +1005,9 @@ static int m25p_probe(struct spi_device
+@@ -986,6 +1008,9 @@ static int m25p_probe(struct spi_device
return -ENOMEM;
}
diff --git a/target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch b/target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch
index 6818a4d9cc..ca0ee6fc85 100644
--- a/target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch
+++ b/target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch
@@ -10,7 +10,7 @@ Subject: [PATCH 64/79] MTD: m25p80: allow passing pp_data
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -972,6 +972,9 @@ static int m25p_probe(struct spi_device
+@@ -975,6 +975,9 @@ static int m25p_probe(struct spi_device
dev_warn(&spi->dev, "unrecognized id %s\n", data->type);
}
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index ed64d9f090..3ecc476275 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-3.10/030-timer_list_fix.patch b/target/linux/generic/patches-3.10/030-timer_list_fix.patch
deleted file mode 100644
index ef3c7988fd..0000000000
--- a/target/linux/generic/patches-3.10/030-timer_list_fix.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Patch by: Nathan Zimmer <nzimmer@sgi.com>
-
-Fixes a regression in the commit
-"timer_list: Convert timer list to be a proper seq_file" which causes
-/proc/timer_list to return an infinite amount of data
-
-
---- a/kernel/time/timer_list.c
-+++ b/kernel/time/timer_list.c
-@@ -305,24 +305,26 @@ static void *timer_list_start(struct seq
- if (!*offset) {
- iter->cpu = -1;
- iter->now = ktime_to_ns(ktime_get());
-- } else if (iter->cpu >= nr_cpu_ids) {
-+ } else {
-+ iter->cpu = cpumask_next(iter->cpu, cpu_online_mask);
-+ if (iter->cpu >= nr_cpu_ids) {
- #ifdef CONFIG_GENERIC_CLOCKEVENTS
-- if (!iter->second_pass) {
-- iter->cpu = -1;
-- iter->second_pass = true;
-- } else
-- return NULL;
-+ if (!iter->second_pass) {
-+ iter->cpu = -1;
-+ iter->second_pass = true;
-+ } else
-+ return NULL;
- #else
-- return NULL;
-+ return NULL;
- #endif
-+ }
- }
-+
- return iter;
- }
-
- static void *timer_list_next(struct seq_file *file, void *v, loff_t *offset)
- {
-- struct timer_list_iter *iter = file->private;
-- iter->cpu = cpumask_next(iter->cpu, cpu_online_mask);
- ++*offset;
- return timer_list_start(file, offset);
- }
diff --git a/target/linux/generic/patches-3.10/259-regmap_dynamic.patch b/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
index 5282b076c1..8627bcc3c5 100644
--- a/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
@@ -31,7 +31,7 @@
bool
--- a/include/linux/regmap.h
+++ b/include/linux/regmap.h
-@@ -46,7 +46,7 @@ struct reg_default {
+@@ -47,7 +47,7 @@ struct reg_default {
unsigned int def;
};
diff --git a/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch b/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
index fbc2d5f0e1..07db137061 100644
--- a/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
+++ b/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
@@ -9,7 +9,7 @@
/* Our partition linked list */
static LIST_HEAD(mtd_partitions);
static DEFINE_MUTEX(mtd_partitions_mutex);
-@@ -232,13 +234,60 @@ static int part_erase(struct mtd_info *m
+@@ -231,13 +233,60 @@ static int part_erase(struct mtd_info *m
struct mtd_part *part = PART(mtd);
int ret;
@@ -70,7 +70,7 @@
return ret;
}
-@@ -246,7 +295,25 @@ void mtd_erase_callback(struct erase_inf
+@@ -245,7 +294,25 @@ void mtd_erase_callback(struct erase_inf
{
if (instr->mtd->_erase == part_erase) {
struct mtd_part *part = PART(instr->mtd);
@@ -96,7 +96,7 @@
if (instr->fail_addr != MTD_FAIL_ADDR_UNKNOWN)
instr->fail_addr -= part->offset;
instr->addr -= part->offset;
-@@ -506,18 +573,24 @@ static struct mtd_part *allocate_partiti
+@@ -505,18 +572,24 @@ static struct mtd_part *allocate_partiti
if ((slave->mtd.flags & MTD_WRITEABLE) &&
mtd_mod_by_eb(slave->offset, &slave->mtd)) {
/* Doesn't start on a boundary of major erase size */
diff --git a/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch b/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
index 87c8257fe1..134f65715e 100644
--- a/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
+++ b/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
+@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
{
struct mtd_part *part = PART(mtd);
diff --git a/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
index 026ba2b41a..4b61307c37 100644
--- a/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
+++ b/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -172,6 +172,22 @@ config MTD_BCM47XX_PARTS
+@@ -176,6 +176,22 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.
diff --git a/target/linux/generic/patches-3.10/620-sched_esfq.patch b/target/linux/generic/patches-3.10/620-sched_esfq.patch
index e037dcf38b..41969865bf 100644
--- a/target/linux/generic/patches-3.10/620-sched_esfq.patch
+++ b/target/linux/generic/patches-3.10/620-sched_esfq.patch
@@ -1,6 +1,6 @@
--- a/include/uapi/linux/pkt_sched.h
+++ b/include/uapi/linux/pkt_sched.h
-@@ -214,6 +214,33 @@ struct tc_sfq_xstats {
+@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
__s32 allot;
};
diff --git a/target/linux/generic/patches-3.10/630-packet_socket_type.patch b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
index e7f05def7f..48a9bb9126 100644
--- a/target/linux/generic/patches-3.10/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.10/630-packet_socket_type.patch
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3275,6 +3288,13 @@ static int packet_getsockopt(struct sock
+@@ -3277,6 +3290,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
index 5f88e6b8b6..010c6048af 100644
--- a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
@@ -32,7 +32,7 @@
+obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
--- a/net/ipv6/addrconf.c
+++ b/net/ipv6/addrconf.c
-@@ -1321,7 +1321,7 @@ out:
+@@ -1319,7 +1319,7 @@ out:
return ret;
}
@@ -41,7 +41,7 @@
const struct in6_addr *daddr, unsigned int prefs,
struct in6_addr *saddr)
{
-@@ -1446,7 +1446,6 @@ try_nextdev:
+@@ -1444,7 +1444,6 @@ try_nextdev:
in6_ifa_put(hiscore->ifa);
return 0;
}
@@ -49,7 +49,7 @@
int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
unsigned char banned_flags)
-@@ -5145,6 +5144,9 @@ int __init addrconf_init(void)
+@@ -5143,6 +5142,9 @@ int __init addrconf_init(void)
ipv6_addr_label_rtnl_register();
@@ -59,7 +59,7 @@
return 0;
errout:
rtnl_af_unregister(&inet6_ops);
-@@ -5163,6 +5165,9 @@ void addrconf_cleanup(void)
+@@ -5161,6 +5163,9 @@ void addrconf_cleanup(void)
struct net_device *dev;
int i;
diff --git a/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch b/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
index 0a93341672..556adcc935 100644
--- a/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
+++ b/target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
@@ -21,16 +21,6 @@
__FR_ACT_MAX,
};
---- a/include/uapi/linux/icmpv6.h
-+++ b/include/uapi/linux/icmpv6.h
-@@ -115,6 +115,7 @@ struct icmp6hdr {
- #define ICMPV6_NOT_NEIGHBOUR 2
- #define ICMPV6_ADDR_UNREACH 3
- #define ICMPV6_PORT_UNREACH 4
-+#define ICMPV6_FAILED_POLICY 5
-
- /*
- * Codes for Time Exceeded
--- a/include/uapi/linux/rtnetlink.h
+++ b/include/uapi/linux/rtnetlink.h
@@ -203,6 +203,7 @@ enum {
@@ -69,7 +59,7 @@
static void rt_fibinfo_free(struct rtable __rcu **rtp)
--- a/net/ipv4/fib_trie.c
+++ b/net/ipv4/fib_trie.c
-@@ -2334,6 +2334,7 @@ static const char *const rtn_type_names[
+@@ -2331,6 +2331,7 @@ static const char *const rtn_type_names[
[RTN_THROW] = "THROW",
[RTN_NAT] = "NAT",
[RTN_XRESOLVE] = "XRESOLVE",
@@ -153,13 +143,13 @@
+static int ip6_pkt_failed_policy(struct sk_buff *skb)
+{
-+ return ip6_pkt_drop(skb, ICMPV6_FAILED_POLICY, IPSTATS_MIB_INNOROUTES);
++ return ip6_pkt_drop(skb, ICMPV6_POLICY_FAIL, IPSTATS_MIB_INNOROUTES);
+}
+
+static int ip6_pkt_failed_policy_out(struct sk_buff *skb)
+{
+ skb->dev = skb_dst(skb)->dev;
-+ return ip6_pkt_drop(skb, ICMPV6_FAILED_POLICY, IPSTATS_MIB_OUTNOROUTES);
++ return ip6_pkt_drop(skb, ICMPV6_POLICY_FAIL, IPSTATS_MIB_OUTNOROUTES);
+}
+
#endif
diff --git a/target/linux/generic/patches-3.10/902-debloat_proc.patch b/target/linux/generic/patches-3.10/902-debloat_proc.patch
index 67ea753a10..907e04624c 100644
--- a/target/linux/generic/patches-3.10/902-debloat_proc.patch
+++ b/target/linux/generic/patches-3.10/902-debloat_proc.patch
@@ -111,7 +111,7 @@
if (!root_irq_dir)
--- a/kernel/time/timer_list.c
+++ b/kernel/time/timer_list.c
-@@ -357,6 +357,8 @@ static int __init init_timer_list_procfs
+@@ -362,6 +362,8 @@ static int __init init_timer_list_procfs
{
struct proc_dir_entry *pe;
@@ -184,7 +184,7 @@
--- a/net/ipv4/fib_trie.c
+++ b/net/ipv4/fib_trie.c
-@@ -2590,10 +2590,12 @@ static const struct file_operations fib_
+@@ -2587,10 +2587,12 @@ static const struct file_operations fib_
int __net_init fib_proc_init(struct net *net)
{
@@ -199,7 +199,7 @@
&fib_triestat_fops))
goto out2;
-@@ -2603,17 +2605,21 @@ int __net_init fib_proc_init(struct net
+@@ -2600,17 +2602,21 @@ int __net_init fib_proc_init(struct net
return 0;
out3:
diff --git a/target/linux/imx23/Makefile b/target/linux/imx23/Makefile
index def0a7ab77..21c33f9cd3 100644
--- a/target/linux/imx23/Makefile
+++ b/target/linux/imx23/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX23 series
FEATURES:=ext4 rtc usb gpio
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
KERNELNAME:="zImage dtbs"
define Target/Description
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index b26e4818c1..6eccacbaf7 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -13,7 +13,7 @@ FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/imx6/patches-3.10/200-imx6_pcie.patch b/target/linux/imx6/patches-3.10/200-imx6_pcie.patch
index 6aee13fb70..534ce9e9f8 100644
--- a/target/linux/imx6/patches-3.10/200-imx6_pcie.patch
+++ b/target/linux/imx6/patches-3.10/200-imx6_pcie.patch
@@ -1,7 +1,7 @@
--- a/arch/arm/boot/dts/imx6q.dtsi
+++ b/arch/arm/boot/dts/imx6q.dtsi
-@@ -382,6 +382,15 @@
- };
+@@ -391,6 +391,15 @@
+ status = "disabled";
};
+ pcie: pcie@01ffc000 {
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 6be0098625..7bc839ac49 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index bc1dfff818..c05a30246f 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
DEVICE_TYPE:=developerboard
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 93ba2c6143..c8ae94daf0 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic p1020
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 0085d22689..12fcacb585 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb
CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
MAINTAINER:=John Crispin <blogic@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 55ecbd0578..29982df190 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index f806f2482a..e3e5ecc675 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883 mt7620a
CFLAGS:=-Os -pipe -mno-branch-likely
FEATURES:=squashfs gpio
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch b/target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
index 6826463266..e9c992e2a1 100644
--- a/target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
+++ b/target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -922,10 +922,13 @@ static int m25p_probe(struct spi_device
+@@ -925,10 +925,13 @@ static int m25p_probe(struct spi_device
unsigned i;
struct mtd_part_parser_data ppdata;
struct device_node __maybe_unused *np = spi->dev.of_node;
@@ -28,7 +28,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#endif
/* Platform data helps sort out which chip type we have, as
-@@ -1001,6 +1004,8 @@ static int m25p_probe(struct spi_device
+@@ -1004,6 +1007,8 @@ static int m25p_probe(struct spi_device
if (data && data->name)
flash->mtd.name = data->name;
diff --git a/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch b/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
index f7da13a6d8..4d1a4ce6fb 100644
--- a/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
+++ b/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -807,10 +807,6 @@ static void split_uimage(struct mtd_info
+@@ -808,10 +808,6 @@ static void split_uimage(struct mtd_info
return;
len = be32_to_cpu(hdr.size) + 0x40;
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 84054bd4e6..ab284be246 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
DEVICE_TYPE:=developerboard
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index 780f471ca4..561aba6bcf 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
CS5535_MASK:=0x0b000042
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index ce1677f731..b799b7c70b 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
DEVICE_TYPE=other